aboutsummaryrefslogtreecommitdiffstats
path: root/games/tuxpuck/files
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2002-10-31 08:29:09 +0800
committeradamw <adamw@FreeBSD.org>2002-10-31 08:29:09 +0800
commite5eeec5d839b12436d9873caa4cb8e505813e9f6 (patch)
tree71d04b9e6b08697112108ab0aa75d46e482afc38 /games/tuxpuck/files
parenta89252e86724239eeb99b2ba6e59f10d00128e20 (diff)
downloadfreebsd-ports-gnome-e5eeec5d839b12436d9873caa4cb8e505813e9f6.tar.gz
freebsd-ports-gnome-e5eeec5d839b12436d9873caa4cb8e505813e9f6.tar.zst
freebsd-ports-gnome-e5eeec5d839b12436d9873caa4cb8e505813e9f6.zip
Update tuxpuck 0.7.116 -> 0.8.1 and make build respect ${CC}
PR: 44760 Submitted by: Jan Stocker <Jan.Stocker@t-online.de> (maintainer) Approved by: pat
Diffstat (limited to 'games/tuxpuck/files')
-rw-r--r--games/tuxpuck/files/patch-Makefile43
-rw-r--r--games/tuxpuck/files/patch-utils::Makefile15
2 files changed, 30 insertions, 28 deletions
diff --git a/games/tuxpuck/files/patch-Makefile b/games/tuxpuck/files/patch-Makefile
index 816dbfed65a0..ee98b8680483 100644
--- a/games/tuxpuck/files/patch-Makefile
+++ b/games/tuxpuck/files/patch-Makefile
@@ -1,36 +1,23 @@
---- Makefile.orig Thu Apr 25 23:14:27 2002
-+++ Makefile Thu Apr 25 23:25:55 2002
-@@ -1,7 +1,7 @@
+--- Makefile.orig Tue Oct 15 13:48:06 2002
++++ Makefile Wed Oct 30 13:01:37 2002
+@@ -1,8 +1,8 @@
# Makefile for TuxPuck , Copyright Jacob Kroon 2001-2002
- VERSION = 0.7.109
- CC = gcc
+ VERSION = 0.8.1
+-CC = gcc
-CFLAGS += `sdl-config --cflags` -D_VERSION=\"$(VERSION)\" \
+- -g -Wall
++CC ?= gcc
+CFLAGS += `$(SDL_CONFIG) --cflags` -D_VERSION=\"$(VERSION)\" \
- -g -Wall -Werror
- CSOURCES = tuxpuck.c video.c audio.c sprite.c font.c timer.c board.c \
- entity.c glass.c scoreboard.c player.c zoom.c png.c jpg.c \
-@@ -11,6 +11,7 @@
-
- #############################################################
-
-+
- OBJS=$(CSOURCES:.c=.o)
-
- %.o : %.c
-@@ -18,7 +19,7 @@
++ -Wall
+ CSOURCES = tuxpuck.c video.c audio.c menu.c sprite.c font.c timer.c \
+ board.c entity.c glass.c scoreboard.c player.c zoom.c png.c \
+ jpg.c intro.c tux.c arcana.c
+@@ -18,7 +18,7 @@
tuxpuck : $(OBJS)
cd data; $(MAKE)
-- $(CC) $(OBJS) data/libdata.a `sdl-config --libs` -lm -lpng -ljpeg \
-+ $(CC) $(OBJS) data/libdata.a `$(SDL_CONFIG) --libs` -lm -lpng -ljpeg \
- -lz -lvorbisfile -lvorbis -o tuxpuck
+- $(CC) $(CFLAGS) $(OBJS) data/libdata.a `sdl-config --libs` -lm -lpng \
++ $(CC) $(CFLAGS) $(OBJS) data/libdata.a `$(SDL_CONFIG) --libs` -lm -lpng \
+ -ljpeg -lz -lvorbisfile -lvorbis -logg -o tuxpuck
clean :
-@@ -55,3 +56,7 @@
- install -d $(DESTDIR)/usr/man/man6
- install -m755 tuxpuck $(DESTDIR)/usr/bin
- install -m644 man/tuxpuck.6.gz $(DESTDIR)/usr/man/man6
-+
-+all : tuxpuck
-+
-+
diff --git a/games/tuxpuck/files/patch-utils::Makefile b/games/tuxpuck/files/patch-utils::Makefile
new file mode 100644
index 000000000000..dbda89caa892
--- /dev/null
+++ b/games/tuxpuck/files/patch-utils::Makefile
@@ -0,0 +1,15 @@
+--- utils/Makefile.orig Tue Oct 15 13:48:06 2002
++++ utils/Makefile Wed Oct 30 13:06:42 2002
+@@ -9,10 +9,10 @@
+ $(CC) $(CFLAGS) ttf2font.c `freetype-config --cflags --libs` -o ttf2font
+
+ data2c : data2c.c
+- $(CC) $(CFLAGS) data2c.c `sdl-config --cflags` -o data2c
++ $(CC) $(CFLAGS) data2c.c `$(SDL_CONFIG) --cflags` -o data2c
+
+ anim : anim.c
+- $(CC) $(CFLAGS) anim.c `sdl-config --cflags` -o anim
++ $(CC) $(CFLAGS) anim.c `$(SDL_CONFIG) --cflags` -o anim
+
+ clean :
+ rm -f *~ data2c ttf2font anim