aboutsummaryrefslogtreecommitdiffstats
path: root/games/tuxpuck
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2012-06-01 13:26:28 +0800
committerdinoex <dinoex@FreeBSD.org>2012-06-01 13:26:28 +0800
commit530706893f31269bbfa303e069f2e76cbbe2fce7 (patch)
treea8077a0d6e20d70b39e6a7fe3e57a6dafe7c7f33 /games/tuxpuck
parent9d262811a145d3e715edefd1d5d64ceac41de547 (diff)
downloadfreebsd-ports-gnome-530706893f31269bbfa303e069f2e76cbbe2fce7.tar.gz
freebsd-ports-gnome-530706893f31269bbfa303e069f2e76cbbe2fce7.tar.zst
freebsd-ports-gnome-530706893f31269bbfa303e069f2e76cbbe2fce7.zip
- update png to 1.5.10
Diffstat (limited to 'games/tuxpuck')
-rw-r--r--games/tuxpuck/Makefile5
-rw-r--r--games/tuxpuck/files/patch-png.c30
2 files changed, 33 insertions, 2 deletions
diff --git a/games/tuxpuck/Makefile b/games/tuxpuck/Makefile
index 60414c910c03..d539eeede184 100644
--- a/games/tuxpuck/Makefile
+++ b/games/tuxpuck/Makefile
@@ -8,7 +8,7 @@
PORTNAME= tuxpuck
PORTVERSION= 0.8.2
-PORTREVISION= 15
+PORTREVISION= 16
CATEGORIES= games
MASTER_SITES= http://www.sourcefiles.org/Games/Sports/Miscellaneous/
@@ -16,7 +16,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Shufflepuck Cafe Clone
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
- png.6:${PORTSDIR}/graphics/png \
+ png15:${PORTSDIR}/graphics/png \
vorbis.4:${PORTSDIR}/audio/libvorbis \
freetype.9:${PORTSDIR}/print/freetype2
@@ -25,6 +25,7 @@ USE_GMAKE= yes
ALL_TARGET= tuxpuck
MAKE_JOBS_UNSAFE= yes
+CFLAGS+= -I${LOCALBASE}/include/libpng15
MANCOMPRESSED= yes
MAN6= tuxpuck.6
PLIST_FILES= bin/tuxpuck
diff --git a/games/tuxpuck/files/patch-png.c b/games/tuxpuck/files/patch-png.c
new file mode 100644
index 000000000000..b548b04b8943
--- /dev/null
+++ b/games/tuxpuck/files/patch-png.c
@@ -0,0 +1,30 @@
+--- png.c.orig 2002-11-08 11:50:29.000000000 +0100
++++ png.c 2012-04-30 06:40:16.000000000 +0200
+@@ -10,9 +10,10 @@
+ #define MACOS
+ #endif
+ #include <png.h>
++#include <pngpriv.h>
+
+ /* png code */
+-static void png_read_data(png_structp ctx, png_bytep area, png_size_t size)
++static void local_png_read_data(png_structp ctx, png_bytep area, png_size_t size)
+ {
+ SDL_RWops *src;
+
+@@ -74,13 +75,13 @@
+ * the normal method of doing things with libpng). REQUIRED unless you
+ * set up your own error handlers in png_create_read_struct() earlier.
+ */
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ SDL_SetError("Error reading the PNG file.");
+ goto done;
+ }
+
+ /* Set up the input control */
+- png_set_read_fn(png_ptr, src, png_read_data);
++ png_set_read_fn(png_ptr, src, local_png_read_data);
+
+ /* Read PNG header info */
+ png_read_info(png_ptr, info_ptr);