aboutsummaryrefslogtreecommitdiffstats
path: root/games/tuxracer
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2011-08-11 00:24:58 +0800
committerehaupt <ehaupt@FreeBSD.org>2011-08-11 00:24:58 +0800
commitebb372bd01ded4a305770c2df3c1e4e76b4fa9d3 (patch)
tree82c7ebeeb6f88facea3a7ea1a008fde2152aa0db /games/tuxracer
parent6f1e8d24ab6b718f160628fd4638d24d799bb318 (diff)
downloadfreebsd-ports-gnome-ebb372bd01ded4a305770c2df3c1e4e76b4fa9d3.tar.gz
freebsd-ports-gnome-ebb372bd01ded4a305770c2df3c1e4e76b4fa9d3.tar.zst
freebsd-ports-gnome-ebb372bd01ded4a305770c2df3c1e4e76b4fa9d3.zip
- Fix MASTER_SITES
- Support USE_TK - Support COPYTREE_SHARE PR: 159457 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Diffstat (limited to 'games/tuxracer')
-rw-r--r--games/tuxracer/Makefile24
1 files changed, 11 insertions, 13 deletions
diff --git a/games/tuxracer/Makefile b/games/tuxracer/Makefile
index 21b46dfa7a11..593e898d1d63 100644
--- a/games/tuxracer/Makefile
+++ b/games/tuxracer/Makefile
@@ -9,38 +9,36 @@ PORTNAME= tuxracer
PORTVERSION= 0.61
PORTREVISION= 10
CATEGORIES= games
-MASTER_SITES= SF
-DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz \
- ${PORTNAME}-data-${PORTVERSION}.tar.gz
+MASTER_SITES= SF \
+ SF/${PORTNAME}/${PORTNAME}-data/${PORTVERSION}:data
+DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
+ ${PORTNAME}-data-${PORTVERSION}${EXTRACT_SUFX}:data
MAINTAINER= ports@FreeBSD.org
COMMENT= A 3d penguin racing game using OpenGL
-LIB_DEPENDS= tcl85:${PORTSDIR}/lang/tcl85
-
USE_SDL= mixer sdl
USE_GL= gl
USE_XORG= x11 xt xmu xi
+USE_TK_BUILD= yes
+USE_TK= yes
USE_GMAKE= yes
USE_AUTOTOOLS= automake14 autoconf
AUTOMAKE_ARGS= -a
CONFIGURE_ENV= THREAD_LIB="${PTHREAD_LIBS}"
-MAKE_ENV= ${CONFIGURE_ENV}
-CONFIGURE_ARGS= --with-tcl-inc="${LOCALBASE}/include/tcl8.5" \
+CONFIGURE_ARGS= --with-tcl-inc="${TCL_INCLUDEDIR}" \
--with-tcl-libs="${LOCALBASE}/lib" \
--with-gl-libs="${LOCALBASE}/lib" \
--with-gl-inc="${LOCALBASE}/include" \
- --with-data-dir=${PREFIX}/share/tuxracer
-
-WORKDATA= ${WRKDIR}/${PORTNAME}-data-${PORTVERSION}
-COURSEDIRS= 1 2 3 4 5 6 7 8 9 10 11
+ --with-data-dir=${DATADIR}
+MAKE_ENV= ${CONFIGURE_ENV}
post-extract:
@${RM} ${WRKSRC}/missing
post-install:
@${MKDIR} ${DATADIR}
- @(${CHMOD} -R o+r ${WORKDATA} && cd ${WORKDATA} && ${TAR} -c -f - *) | \
- (cd ${DATADIR} && ${TAR} -x -f - )
+ @(cd ${WORKDATA} ${WRKDIR}/${PORTNAME}-data-${PORTVERSION} \
+ && ${COPYTREE_SHARE} . ${DATADIR})
.include <bsd.port.mk>