aboutsummaryrefslogtreecommitdiffstats
path: root/games/twitch/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-03-11 00:07:49 +0800
committersobomax <sobomax@FreeBSD.org>2001-03-11 00:07:49 +0800
commit1e504ea4d33cfaaac70fc376c78fdf34fd4007e7 (patch)
tree4acd5bd43ec28366d3ba3533b740c7b8b4a85e18 /games/twitch/Makefile
parent4320726667518b10141cb72d429ae09ccf3ea5a2 (diff)
downloadfreebsd-ports-gnome-1e504ea4d33cfaaac70fc376c78fdf34fd4007e7.tar.gz
freebsd-ports-gnome-1e504ea4d33cfaaac70fc376c78fdf34fd4007e7.tar.zst
freebsd-ports-gnome-1e504ea4d33cfaaac70fc376c78fdf34fd4007e7.zip
Add twitch 1.0, an overhead 2-d shooter written in Python, reminiscent of
games like Robotron.
Diffstat (limited to 'games/twitch/Makefile')
-rw-r--r--games/twitch/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/games/twitch/Makefile b/games/twitch/Makefile
new file mode 100644
index 000000000000..f7e29756c5e6
--- /dev/null
+++ b/games/twitch/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: twitch
+# Date created: 10 March 2001
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= twitch
+PORTVERSION= 1.0
+CATEGORIES= games
+MASTER_SITES= http://wildsau.idv.uni-linz.ac.at/mfx/download/pysol/
+
+MAINTAINER= sobomax@FreeBSD.org
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pygame/__init__.py:${PORTSDIR}/devel/py-game
+
+USE_PYTHON= yes
+
+do-build:
+ ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py -l ${WRKSRC}
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/twitch
+ (cd ${WRKSRC}; tar cf - images sound levels twitch.*) | \
+ (cd ${PREFIX}/share/twitch; tar xf -)
+ @printf "#!/bin/sh\ncd ${PREFIX}/share/twitch && \
+ ${PYTHON_CMD} ${PREFIX}/share/twitch/twitch.py\n" > ${WRKDIR}/twitch.sh
+ @${INSTALL_SCRIPT} ${WRKDIR}/twitch.sh ${PREFIX}/bin/twitch
+
+.include <bsd.port.mk>