aboutsummaryrefslogtreecommitdiffstats
path: root/games/ufoai-data/Makefile
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2006-10-01 10:10:10 +0800
committeracm <acm@FreeBSD.org>2006-10-01 10:10:10 +0800
commit21c52cfbdb4ae7e320bb18b350dedcc682627130 (patch)
tree1210bb2115579a1ad1789fc566a208a5d743f536 /games/ufoai-data/Makefile
parentae0b31e0186586e3619f771b5b42e5a0d9b4ea2b (diff)
downloadfreebsd-ports-gnome-21c52cfbdb4ae7e320bb18b350dedcc682627130.tar.gz
freebsd-ports-gnome-21c52cfbdb4ae7e320bb18b350dedcc682627130.tar.zst
freebsd-ports-gnome-21c52cfbdb4ae7e320bb18b350dedcc682627130.zip
- New ports: games/ufoai games/ufoai-data
UFO ALIEN INVASION is a strategy game featuring tactical combat against hostile alien forces which are about to infiltrate earth at this very moment. You are in command of a small special unit which has been founded to face the alien strike force. To be successful on the long run, you will also have to have a research team study the aliens and their technologies in order to learn as much as possible about their technology, their goals and the aliens themselves. WWW: http://ufo.myexp.de/
Diffstat (limited to 'games/ufoai-data/Makefile')
-rw-r--r--games/ufoai-data/Makefile52
1 files changed, 52 insertions, 0 deletions
diff --git a/games/ufoai-data/Makefile b/games/ufoai-data/Makefile
new file mode 100644
index 000000000000..723314fac27f
--- /dev/null
+++ b/games/ufoai-data/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: ufoai-data
+# Date created: 2006-09-03
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= data
+DISTVERSION= 2.0rc5
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PKGNAMEPREFIX:S/-//}
+PKGNAMEPREFIX= ufoai-
+DISTNAME= ${PKGNAMEPREFIX}${DISTVERSION:S/r/-r/}-linux
+EXTRACT_SUFX= .run
+DIST_SUBDIR= ${PKGNAMEPREFIX:S/-//}
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= UFO alien invasion data files
+
+NO_PACKAGE= Package will be 160MB, set FORCE_PACKAGE if you really want it
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+PLIST= ${WRKDIR}/pkg-plist
+DATADIR= share/${PKGNAMEPREFIX:S/-//}
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+ @cd ${WRKSRC} && \
+ ${TAIL} -c +9390 ${_DISTDIR}/${DISTFILES} | ${TAR} xf -
+ @cd ${WRKSRC} && \
+ ${TAR} -xjf ${PORTNAME}.tar.bz2
+
+post-patch:
+ @cd ${WRKSRC}/base && \
+ ${RM} -rf i18n game.so
+
+pre-install:
+ @${RM} -f ${PLIST}
+ @cd ${WRKDIR}/base && \
+ ${FIND} * -type f | ${SORT} | ${SED} -e 's|^|%%DATADIR%%/|' >> ${PLIST} && \
+ ${FIND} * -type d | ${SORT} -r | ${SED} -e 's|^|@dirrm %%DATADIR%%/|' >> ${PLIST}
+ @${ECHO_CMD} "@dirrm %%DATADIR%%" >> ${PLIST}
+
+do-install:
+ ${MKDIR} ${PREFIX}/${DATADIR}
+ cd ${WRKDIR}/base && \
+ ${FIND} * -type d -exec ${MKDIR} "${PREFIX}/${DATADIR}/{}" \; && \
+ ${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${PREFIX}/${DATADIR}/{}" \;
+
+.include <bsd.port.mk>