aboutsummaryrefslogtreecommitdiffstats
path: root/games/ufoai
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2012-06-01 13:26:28 +0800
committerdinoex <dinoex@FreeBSD.org>2012-06-01 13:26:28 +0800
commit530706893f31269bbfa303e069f2e76cbbe2fce7 (patch)
treea8077a0d6e20d70b39e6a7fe3e57a6dafe7c7f33 /games/ufoai
parent9d262811a145d3e715edefd1d5d64ceac41de547 (diff)
downloadfreebsd-ports-gnome-530706893f31269bbfa303e069f2e76cbbe2fce7.tar.gz
freebsd-ports-gnome-530706893f31269bbfa303e069f2e76cbbe2fce7.tar.zst
freebsd-ports-gnome-530706893f31269bbfa303e069f2e76cbbe2fce7.zip
- update png to 1.5.10
Diffstat (limited to 'games/ufoai')
-rw-r--r--games/ufoai/Makefile4
-rw-r--r--games/ufoai/files/patch-images.c10
2 files changed, 12 insertions, 2 deletions
diff --git a/games/ufoai/Makefile b/games/ufoai/Makefile
index a4c41a1663f9..0376d9f91d63 100644
--- a/games/ufoai/Makefile
+++ b/games/ufoai/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ufoai
PORTVERSION= 2.3.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/UFO_AI%202.x/${PORTVERSION}
DISTNAME= ${PORTNAME:S/$/-/}${PORTVERSION}-source
@@ -18,7 +18,7 @@ COMMENT= A strategy game featuring tactical combat
LIB_DEPENDS= vorbis:${PORTSDIR}/audio/libvorbis \
jpeg.11:${PORTSDIR}/graphics/jpeg \
- png.6:${PORTSDIR}/graphics/png \
+ png15:${PORTSDIR}/graphics/png \
curl:${PORTSDIR}/ftp/curl \
execinfo:${PORTSDIR}/devel/libexecinfo \
theora.0:${PORTSDIR}/multimedia/libtheora \
diff --git a/games/ufoai/files/patch-images.c b/games/ufoai/files/patch-images.c
new file mode 100644
index 000000000000..b2983addf4ba
--- /dev/null
+++ b/games/ufoai/files/patch-images.c
@@ -0,0 +1,10 @@
+--- src/shared/images.c.orig 2010-11-29 17:46:35.000000000 +0100
++++ src/shared/images.c 2012-04-25 06:15:32.000000000 +0200
+@@ -32,6 +32,7 @@
+
+ #include <jpeglib.h>
+ #include <png.h>
++#include <zlib.h>
+
+ /** image formats, tried in this order */
+ static char *IMAGE_TYPES[] = { "tga", "png", "jpg", NULL };