aboutsummaryrefslogtreecommitdiffstats
path: root/games/uhexen/Makefile
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2003-12-16 02:41:52 +0800
committeroliver <oliver@FreeBSD.org>2003-12-16 02:41:52 +0800
commitcf7b700633a03ed69cefd68a18de6a56fe76ad39 (patch)
tree7965110a31dafa9ae0587414ad4cc037c8e30928 /games/uhexen/Makefile
parent34f8b8a327831c653a33ccb3eac60499dce10551 (diff)
downloadfreebsd-ports-gnome-cf7b700633a03ed69cefd68a18de6a56fe76ad39.tar.gz
freebsd-ports-gnome-cf7b700633a03ed69cefd68a18de6a56fe76ad39.tar.zst
freebsd-ports-gnome-cf7b700633a03ed69cefd68a18de6a56fe76ad39.zip
download and install the shareware .wad file if WITHOUT_WAD isn't specified
Diffstat (limited to 'games/uhexen/Makefile')
-rw-r--r--games/uhexen/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/games/uhexen/Makefile b/games/uhexen/Makefile
index 7f9057a5fc6f..a8e2607116dc 100644
--- a/games/uhexen/Makefile
+++ b/games/uhexen/Makefile
@@ -10,12 +10,19 @@ PORTVERSION= 0.601
CATEGORIES= games
MASTER_SITES= http://uhexen.sourceforge.net/
DISTNAME= ${PORTNAME}-latest
+.if !defined(WITHOUT_WAD)
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} hexen.zip
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+.endif
MAINTAINER= ports@FreeBSD.org
COMMENT= Yet another port of Hexen, popular game from Raven Softrware
LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12 \
SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer
+.if !defined(WITHOUT_WAD)
+EXTRACT_DEPENDS=unzip:${PORTSDIR}/archivers/unzip
+.endif
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
@@ -25,9 +32,31 @@ USE_X_PREFIX= yes
USE_GMAKE= yes
MAKE_ENV= SDL_CONFIG="${SDL_CONFIG}"
+.if defined(WITHOUT_WAD)
+PLIST_SUB= WAD:="@comment "
+.else
+PLIST_SUB= WAD:=""
+.endif
+
+pre-everything::
+ @${ECHO} ""
+ @${ECHO} "You may use the following build options:"
+ @${ECHO} ""
+ @${ECHO} " WITHOUT_WAD=yes Don't install the wad file."
+ @${ECHO} ""
+
+post-extract:
+.if !defined(WITHOUT_WAD)
+ @${LOCALBASE}/bin/unzip -qo ${_DISTDIR}/hexen.zip \
+ -d ${WRKSRC}
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/uhexen ${PREFIX}/bin
${MKDIR} ${DATADIR}
+.if !defined(WITHOUT_WAD)
+ ${INSTALL_DATA} ${WRKSRC}/hexen.wad ${DATADIR}
+.endif
${TOUCH} ${DATADIR}/.keep_me
.include <bsd.port.mk>