aboutsummaryrefslogtreecommitdiffstats
path: root/games/uqm/Makefile
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2005-11-11 19:56:56 +0800
committerthierry <thierry@FreeBSD.org>2005-11-11 19:56:56 +0800
commit4d03b6e613cb46e25cfbc2f98f69fa4e5a6781f4 (patch)
tree69fcafd029087f9ed087bd5984e31addf51922e3 /games/uqm/Makefile
parente42e0e3e501c017d15b2aed747e090ebd5cb4a66 (diff)
downloadfreebsd-ports-gnome-4d03b6e613cb46e25cfbc2f98f69fa4e5a6781f4.tar.gz
freebsd-ports-gnome-4d03b6e613cb46e25cfbc2f98f69fa4e5a6781f4.tar.zst
freebsd-ports-gnome-4d03b6e613cb46e25cfbc2f98f69fa4e5a6781f4.zip
Changes:
- Replace an instance of a hardcoded /usr/X11R6 with $X11BASE. This was detected by dosirak.kr.freebsd.org. - Make use of the OPTIONS variable. Because of this, replace the MUSICADDON and VOICEADDON switches with WITH_MUSIC and WITH_VOICE. - Add support for OpenAL as wished by Peter Thoenen (eol1 at yahoo com). PR: 87958 Submitted by: maintainer
Diffstat (limited to 'games/uqm/Makefile')
-rw-r--r--games/uqm/Makefile40
1 files changed, 26 insertions, 14 deletions
diff --git a/games/uqm/Makefile b/games/uqm/Makefile
index c659ae03e34d..202cc6922791 100644
--- a/games/uqm/Makefile
+++ b/games/uqm/Makefile
@@ -7,9 +7,9 @@
# Ur-Quan Masters offers add-on packages that enhance the game. These are
# optional. The following add-ons exist at the moment:
#
-# Voice add-on (110 MB). Enable this with -DVOICEADDON
+# Voice add-on (110 MB). Enable this with -DWITH_VOICE
#
-# 3DO Music add-on (18 MB). Enable this with -DMUSICADDON
+# 3DO Music add-on (18 MB). Enable this with -DWITH_MUSIC
#
PORTNAME= uqm
@@ -33,64 +33,76 @@ NO_INSTALL_MANPAGES= yes
ONLY_FOR_ARCHS= i386
-.ifdef(VOICEADDON)
+OPTIONS= VOICE "Voice add-on (110MB)" Off \
+ MUSIC "Music add-on (18MB)" Off \
+ OPENAL "OpenAL support (experimental)" Off
+
+.include <bsd.port.pre.mk>
+
+.ifdef(WITH_VOICE)
DISTFILES+= ${PORTNAME}-${PORTVERSION}-voice.uqm
PLIST_SUB+= VOICEADDON=""
.else
PLIST_SUB+= VOICEADDON="@comment "
.endif
-.ifdef(MUSICADDON)
+.ifdef(WITH_MUSIC)
DISTFILES+= ${PORTNAME}-${PORTVERSION}-3domusic.uqm
PLIST_SUB+= MUSICADDON=""
.else
PLIST_SUB+= MUSICADDON="@comment "
.endif
-.include <bsd.port.pre.mk>
+.ifdef(WITH_OPENAL)
+LIB_DEPENDS+= openal.0:${PORTSDIR}/audio/openal
+.endif
.if ${OSVERSION} < 500000
BROKEN= "does not compile"
.endif
pre-everything::
-.ifdef(!VOICEADDON || !MUSICADDON)
+.ifdef(!WITH_VOICE || !WITH_MUSIC)
@${ECHO_MSG} ""
@${ECHO_MSG} "You may specify the following options:"
.endif
-.ifdef(!VOICEADDON)
+.ifdef(!WITH_VOICE)
@${ECHO_MSG} ""
- @${ECHO_MSG} "-DVOICEADDON"
+ @${ECHO_MSG} "-DWITH_VOICE"
@${ECHO_MSG} " Installs the voice add-on (110MB)."
.endif
-.ifdef(!MUSICADDON)
+.ifdef(!WITH_MUSIC)
@${ECHO_MSG} ""
- @${ECHO_MSG} "-DMUSICADDON"
+ @${ECHO_MSG} "-DWITH_MUSIC"
@${ECHO_MSG} " Installs the music add-on (18MB) containing the original"
@${ECHO_MSG} " 3do music files. Note that there is music without this"
- @${ECHO_MSG} " add-on, just not as much."
+ @${ECHO_MSG} " add-on, but it's of lower quality."
.endif
post-extract:
${MKDIR} ${WRKSRC}/content/packages
${CP} ${DISTDIR}/${PORTNAME}-${PORTVERSION}-content.uqm ${WRKSRC}/content/packages/
-.ifdef(VOICEADDON)
+.ifdef(WITH_VOICE)
${CP} ${DISTDIR}/${PORTNAME}-${PORTVERSION}-voice.uqm ${WRKSRC}/content/packages/
.endif
-.ifdef(MUSICADDON)
+.ifdef(WITH_MUSIC)
${CP} ${DISTDIR}/${PORTNAME}-${PORTVERSION}-3domusic.uqm ${WRKSRC}/content/packages/
.endif
do-configure:
@${ECHO_MSG} CHOICE_debug_VALUE=\'nodebug\' > ${WRKSRC}/config.state
@${ECHO_MSG} CHOICE_graphics_VALUE=\'opengl\' >> ${WRKSRC}/config.state
+.ifdef(WITH_OPENAL)
+ @${ECHO_MSG} CHOICE_sound_VALUE=\'openal\' >> ${WRKSRC}/config.state
+.else
@${ECHO_MSG} CHOICE_sound_VALUE=\'mixsdl\' >> ${WRKSRC}/config.state
+.endif
@${ECHO_MSG} CHOICE_ioformat_VALUE=\'stdio_zip\' >> ${WRKSRC}/config.state
@${ECHO_MSG} INPUT_install_prefix_VALUE=\'${PREFIX}\' >> ${WRKSRC}/config.state
@${ECHO_MSG} INPUT_install_bindir_VALUE=\''$$prefix/bin'\' >> ${WRKSRC}/config.state
@${ECHO_MSG} INPUT_install_libdir_VALUE=\''$$prefix/lib'\' >> ${WRKSRC}/config.state
@${ECHO_MSG} INPUT_install_sharedir_VALUE=\''$$prefix/share'\' >> ${WRKSRC}/config.state
- cd ${WRKSRC} && ${SETENV} LOCALBASE=${LOCALBASE} PREFIX=${PREFIX} ./build.sh uqm config
+ cd ${WRKSRC} && ${SETENV} LOCALBASE=${LOCALBASE} X11BASE=${X11BASE} PREFIX=${PREFIX} ./build.sh uqm config
do-build:
cd ${WRKSRC} && ./build.sh uqm