aboutsummaryrefslogtreecommitdiffstats
path: root/games/wargus
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-08-26 22:06:08 +0800
committertijl <tijl@FreeBSD.org>2014-08-26 22:06:08 +0800
commitf8357b5cbaa160ccdf9943cac099f5e092c591da (patch)
treed0c8617b772b8f0a175d436d938b8d844590b41f /games/wargus
parent89a7d6ecbdde724b92ca6650493f56cf68855f35 (diff)
downloadfreebsd-ports-gnome-f8357b5cbaa160ccdf9943cac099f5e092c591da.tar.gz
freebsd-ports-gnome-f8357b5cbaa160ccdf9943cac099f5e092c591da.tar.zst
freebsd-ports-gnome-f8357b5cbaa160ccdf9943cac099f5e092c591da.zip
- Fix missing library problems when the linker enforces explicit linking
PR: 192062 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'games/wargus')
-rw-r--r--games/wargus/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/games/wargus/Makefile b/games/wargus/Makefile
index ed15d06a5980..30cd4d7ab8b8 100644
--- a/games/wargus/Makefile
+++ b/games/wargus/Makefile
@@ -23,8 +23,16 @@ USE_GNOME= gtk20
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
SUB_FILES= ${PORTNAME} pkg-message
-MAKE_ARGS+= CFLAGS+="-I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15" LDFLAGS+=-L${LOCALBASE}/lib
-
+CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
+LDFLAGS+= -L${LOCALBASE}/lib
+
+post-patch:
+ @${REINPLACE_CMD} \
+ -e '/^CFLAGS/s|-O2|${CPPFLAGS} ${CFLAGS}|' \
+ -e '/^CXXFLAGS/s|$$| ${CXXFLAGS}|' \
+ -e '/^LDFLAGS/s|$$| ${LDFLAGS}|' \
+ -e '/^GTKFLAGS/s/gtk+-2.0/& x11/' \
+ ${WRKSRC}/Makefile
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
cd ${WRKSRC} && ${COPYTREE_SHARE} "campaigns contrib maps scripts" ${STAGEDIR}${DATADIR}