aboutsummaryrefslogtreecommitdiffstats
path: root/games/warsow/Makefile
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2006-08-20 23:11:09 +0800
committeracm <acm@FreeBSD.org>2006-08-20 23:11:09 +0800
commitaadef666a0c53a9afdde7b28cc2ad70c14eb3ef5 (patch)
treeb533a5773b3f8ad0e72a1dcf68dfe31cda64a27f /games/warsow/Makefile
parentae882a3d53808ba2410395f21c7fb931c06735df (diff)
downloadfreebsd-ports-gnome-aadef666a0c53a9afdde7b28cc2ad70c14eb3ef5.tar.gz
freebsd-ports-gnome-aadef666a0c53a9afdde7b28cc2ad70c14eb3ef5.tar.zst
freebsd-ports-gnome-aadef666a0c53a9afdde7b28cc2ad70c14eb3ef5.zip
- Integrate games/warsow with games/warsow-data
- Fixes some problems with games/linux-warsow and games/warsow-data, now we can install games/warsow and games/linux-warsow at the same place. Submitted by: me Approved by: maintainer timeout (16 days), garga (mentor)
Diffstat (limited to 'games/warsow/Makefile')
-rw-r--r--games/warsow/Makefile45
1 files changed, 22 insertions, 23 deletions
diff --git a/games/warsow/Makefile b/games/warsow/Makefile
index bf18e6e2ed19..791f0d60626b 100644
--- a/games/warsow/Makefile
+++ b/games/warsow/Makefile
@@ -7,29 +7,29 @@
PORTNAME= warsow
PORTVERSION= 0.12
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= http://warsow.aditsystems.com/ \
http://ftp.club-internet.fr/pub/games/nofrag/warsow/ \
http://wsw.surreal-xenotronic.com/
DISTNAME= ${PORTNAME}_${PORTVERSION}_sdk
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
- ${PORTNAME}_${PORTVERSION}_linux.tar.gz
DIST_SUBDIR= ${PORTNAME}
-EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= danfe@FreeBSD.org
COMMENT= A fast paced first person shooter game
+RUN_DEPENDS= ${DATADIR}/data0.pk3:${PORTSDIR}/games/warsow-data
+
+ONLY_FOR_ARCHS= i386 amd64
USE_GMAKE= yes
-USE_GCC= 3.3+
+USE_GCC= 3.4+
USE_ZIP= yes
USE_DOS2UNIX= linux/in_x11.c linux/sys_linux.c
-ALL_TARGET= game
WRKSRC= ${WRKDIR}/source/source012
+ALL_TARGET= game
RELEASEDIR= ${WRKSRC}/release
-DATADIR= ${PREFIX}/lib/${PORTNAME}
+WSWDATADIR= ${PREFIX}/lib/${PORTNAME}
OPTIONS= CLIENT "Build client executable" on \
SERVER "Build dedicated server executable" on
@@ -40,6 +40,14 @@ OPTIONS= CLIENT "Build client executable" on \
IGNORE= requires at least one of CLIENT and SERVER options
.endif
+.if ${ARCH} == "i386"
+ARCHSUFFIX= "_i386"
+PLIST_SUB+= ARCHSUFFIX=${ARCHSUFFIX}
+.elif ${ARCH} == "amd64"
+ARCHSUFFIX= "_x86_64"
+PLIST_SUB+= ARCHSUFFIX=${ARCHSUFFIX}
+.endif
+
.if !defined(WITHOUT_CLIENT)
LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl \
jpeg.9:${PORTSDIR}/graphics/jpeg
@@ -62,26 +70,17 @@ PLIST_SUB+= SERVER="@comment "
post-patch: .SILENT
${REINPLACE_CMD} -e 's#@$$(DO_CC#$$(DO_CC#; \
- s#_$$(ARCH)##; s#-O2 ##' ${WRKSRC}/Makefile
- ${REINPLACE_CMD} -e 's#path", "\.#path", "${DATADIR}#; \
+ s#-O2 ##' ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's#path", "\.#path", "${WSWDATADIR}#; \
s#dir", "0#dir", "1#' ${WRKSRC}/qcommon/files.c
${REINPLACE_CMD} -e 's#Linux#FreeBSD#' ${WRKSRC}/game/q_shared.h
do-install:
-.for bin in ${WSBIN}
- ${INSTALL_PROGRAM} ${RELEASEDIR}/${bin} ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/lib/${PORTNAME}/basewsw
+.for FILE in ${WSBIN}
+ ${INSTALL_PROGRAM} ${RELEASEDIR}/${FILE} ${PREFIX}/bin
.endfor
- @${MKDIR} ${DATADIR}/basewsw
- ${INSTALL_PROGRAM} ${RELEASEDIR}/basewsw/*.so ${DATADIR}/basewsw
- @${TAR} xzvf ${_DISTDIR}/${PORTNAME}_${PORTVERSION}_linux.tar.gz \
- -C ${PREFIX}/lib warsow/basewsw/cfgs warsow/basewsw/huds \
- warsow/basewsw/dedicated_autoexec.cfg \
- warsow/basewsw/\*.pk3 && ${CHOWN} -R root:wheel ${DATADIR}
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @${TAR} xzvf ${_DISTDIR}/${PORTNAME}_${PORTVERSION}_linux.tar.gz \
- -C ${WRKDIR} warsow/docs && ${CP} -R ${WRKDIR}/warsow/docs/ \
- ${DOCSDIR} && ${CHMOD} -R 777 ${WRKDIR}/warsow
-.endif
+ ${INSTALL_DATA} ${RELEASEDIR}/basewsw/*.so ${PREFIX}/lib/${PORTNAME}/basewsw
+ ${LN} -s ${DATADIR}/* ${PREFIX}/lib/${PORTNAME}/basewsw
.include <bsd.port.post.mk>