aboutsummaryrefslogtreecommitdiffstats
path: root/games/warsow
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2010-01-26 03:15:18 +0800
committerpav <pav@FreeBSD.org>2010-01-26 03:15:18 +0800
commitdfee6d5c62ab6b269042d70b16ee7a2529db951e (patch)
treebe83fbf870c86e4040bbca6fff53505cd1e7c8e2 /games/warsow
parent4c40a810f99571b1f539a6fbd7c3a13147bb82c0 (diff)
downloadfreebsd-ports-gnome-dfee6d5c62ab6b269042d70b16ee7a2529db951e.tar.gz
freebsd-ports-gnome-dfee6d5c62ab6b269042d70b16ee7a2529db951e.tar.zst
freebsd-ports-gnome-dfee6d5c62ab6b269042d70b16ee7a2529db951e.zip
- Introduce USE_OPENAL variable for OpenAL consumers
- Switch to openal-soft as a default OpenAL implementation PR: ports/142123 Submitted by: mva Tested by: pointyhat exp-run Approved by: portmgr (hat)
Diffstat (limited to 'games/warsow')
-rw-r--r--games/warsow/Makefile3
-rw-r--r--games/warsow/files/patch-snd_openal_snd_main.c11
2 files changed, 13 insertions, 1 deletions
diff --git a/games/warsow/Makefile b/games/warsow/Makefile
index 788f941a57b6..1fbb2ac19fe8 100644
--- a/games/warsow/Makefile
+++ b/games/warsow/Makefile
@@ -7,6 +7,7 @@
PORTNAME= warsow
PORTVERSION= 0.5
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://woe.crying-wolves.net/ \
http://www.derchris.eu/warsow/ \
@@ -83,7 +84,7 @@ PLIST_SUB+= QF="@comment "
.endif
.if !defined(WITHOUT_OPENAL)
-LIB_DEPENDS+= openal.0:${PORTSDIR}/audio/openal
+USE_OPENAL= al
ALL_TARGET+= openal
PLIST_SUB+= OPENAL=""
.else
diff --git a/games/warsow/files/patch-snd_openal_snd_main.c b/games/warsow/files/patch-snd_openal_snd_main.c
new file mode 100644
index 000000000000..84c1d6ed71b6
--- /dev/null
+++ b/games/warsow/files/patch-snd_openal_snd_main.c
@@ -0,0 +1,11 @@
+--- ./snd_openal/snd_main.c.orig 2009-12-26 19:07:05.000000000 +0100
++++ ./snd_openal/snd_main.c 2009-12-26 19:07:13.000000000 +0100
+@@ -231,7 +231,7 @@
+ #define ALDRIVER "/System/Library/Frameworks/OpenAL.framework/OpenAL"
+ #define ALDEVICE_DEFAULT NULL
+ #else
+-#define ALDRIVER "libopenal.so.0"
++#define ALDRIVER "libopenal.so"
+ #define ALDEVICE_DEFAULT NULL
+ #endif
+