aboutsummaryrefslogtreecommitdiffstats
path: root/games/windstille
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2009-07-29 06:29:54 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2009-07-29 06:29:54 +0800
commit242fc244559f57400c101bf17895f0563d7bb800 (patch)
tree9d6a02629e688ca32cf23eb3d788e9b1dbfc30d6 /games/windstille
parent87f884d07c3af020cbd68560aa2af56a6624fafb (diff)
downloadfreebsd-ports-gnome-242fc244559f57400c101bf17895f0563d7bb800.tar.gz
freebsd-ports-gnome-242fc244559f57400c101bf17895f0563d7bb800.tar.zst
freebsd-ports-gnome-242fc244559f57400c101bf17895f0563d7bb800.zip
- Fix build after lang/squirrel update
Reported by: pointyhat
Diffstat (limited to 'games/windstille')
-rw-r--r--games/windstille/Makefile2
-rw-r--r--games/windstille/files/patch-src-script_manager.cpp11
2 files changed, 12 insertions, 1 deletions
diff --git a/games/windstille/Makefile b/games/windstille/Makefile
index 0b4f67c932d7..c1e8cddf8f5f 100644
--- a/games/windstille/Makefile
+++ b/games/windstille/Makefile
@@ -7,7 +7,7 @@
PORTNAME= windstille
PORTVERSION= 0.3.0
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= games
MASTER_SITES= BERLIOS CENKES
diff --git a/games/windstille/files/patch-src-script_manager.cpp b/games/windstille/files/patch-src-script_manager.cpp
new file mode 100644
index 000000000000..24149d6b8dc8
--- /dev/null
+++ b/games/windstille/files/patch-src-script_manager.cpp
@@ -0,0 +1,11 @@
+--- src/script_manager.cpp.orig 2007-06-12 21:32:05.000000000 +0400
++++ src/script_manager.cpp 2009-07-28 23:45:51.000000000 +0400
+@@ -130,7 +130,7 @@
+ {
+ squirrel_vm.waiting_for_events = WakeupData(NO_EVENT);
+ try {
+- if(sq_wakeupvm(squirrel_vm.vm, false, false, true) < 0) {
++ if(sq_wakeupvm(squirrel_vm.vm, false, false, true, false) < 0) {
+ throw SquirrelError(squirrel_vm.vm, "Couldn't resume script");
+ }
+ } catch(std::exception& e) {