aboutsummaryrefslogtreecommitdiffstats
path: root/games/xabacus
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2005-10-10 18:29:13 +0800
committergarga <garga@FreeBSD.org>2005-10-10 18:29:13 +0800
commit0ab3e8653ada821106c74ade3153688bc6396d76 (patch)
treeb0e330af8d498ea7e684dbefbbd9f9c8940911f7 /games/xabacus
parentf27bca6b185d21273385290ee1e55a56887e1df7 (diff)
downloadfreebsd-ports-gnome-0ab3e8653ada821106c74ade3153688bc6396d76.tar.gz
freebsd-ports-gnome-0ab3e8653ada821106c74ade3153688bc6396d76.tar.zst
freebsd-ports-gnome-0ab3e8653ada821106c74ade3153688bc6396d76.zip
- Support sound playing functionality
PR: ports/87060 Submitted by: Ports Fury
Diffstat (limited to 'games/xabacus')
-rw-r--r--games/xabacus/Makefile17
1 files changed, 15 insertions, 2 deletions
diff --git a/games/xabacus/Makefile b/games/xabacus/Makefile
index 1eae39978c83..427e57c5fd63 100644
--- a/games/xabacus/Makefile
+++ b/games/xabacus/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xabacus
PORTVERSION= 7.1.4
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SUNSITE} \
ftp://ftp.tux.org/pub/tux/bagleyd/xabacus/
@@ -17,20 +18,32 @@ COMMENT= Abacus for X Window System
USE_BZIP2= yes
USE_X_PREFIX= yes
+WANT_GNOME= yes
+USE_GNOME= gnometarget
USE_XPM= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --without-nas
MAN6= xabacus.6
+.include <bsd.port.pre.mk>
+
.if defined(WITHOUT_MOTIF)
CONFIGURE_ARGS+= --without-motif
.else
USE_MOTIF= yes
.endif
+.if ${HAVE_GNOME:Mesound}!=""
+USE_GNOME+= esound
+CONFIGURE_ARGS+= --without-rplay --with-esound
+.else
+LIB_DEPENDS+= rplay.1:${PORTSDIR}/audio/rplay
+CONFIGURE_ARGS+= --with-rplay --without-esound
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|/games/|/|g' ${WRKSRC}/Makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>