aboutsummaryrefslogtreecommitdiffstats
path: root/games/xasteroids
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1995-02-11 21:51:48 +0800
committerasami <asami@FreeBSD.org>1995-02-11 21:51:48 +0800
commitf00f61ef610a8de3a2a910e987fb397bed2e1dd0 (patch)
tree24bbbb01a66b3966a65153402e4eaaad5f842bab /games/xasteroids
parent0707f721571142597f21951399e1bca2bfed70fe (diff)
downloadfreebsd-ports-gnome-f00f61ef610a8de3a2a910e987fb397bed2e1dd0.tar.gz
freebsd-ports-gnome-f00f61ef610a8de3a2a910e987fb397bed2e1dd0.tar.zst
freebsd-ports-gnome-f00f61ef610a8de3a2a910e987fb397bed2e1dd0.zip
Converted Makefiles as much as I could.
(1) Took out INSTALL_MANPAGES (not necessary anymore, porter should set NO_INSTALL_MANPAGES for not calling "make install.man") (2) Replaced most of DEPENDS with EXEC_DEPENDS and LIB_DEPENDS. These are the entries I used: EXEC_DEPENDS: unzip:${PORTSDIR}/archivers/unzip gmake:${PORTSDIR}/devel/gmake wishx:${PORTSDIR}/lang/tclX xli:${PORTSDIR}/graphics/xli gs:${PORTSDIR}/print/ghostscript gunshar:${PORTSDIR}/archivers/gshar+gunshar hfs:${PORTSDIR}/utils/hfs rman:${PORTSDIR}/utils/rman LIB_DEPENDS: tiff\\.3\\.:${PORTSDIR}/graphics/tiff jpeg\\.5\\.:${PORTSDIR}/graphics/jpeg Xpm\\.4\\.:${PORTSDIR}/graphics/xpm tcl\\.7\\.:${PORTSDIR}/lang/tcl tk\\.3\\.:${PORTSDIR}/x11/tk xview\\.1\\.:${PORTSDIR}/x11/xview-lib Xaw3d\\.:${PORTSDIR}/x11/Xaw3d mpeg\\.1\\.:${PORTSDIR}/graphics/mpeg-lib xview\\.3\\.:${PORTSDIR}/x11/xview-lib BLT\\.1\\.:${PORTSDIR}/x11/blt There are still some dependencies I can't figure out what exactly is needed. If your port still has DEPENDS in it, please check it out!
Diffstat (limited to 'games/xasteroids')
-rw-r--r--games/xasteroids/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/games/xasteroids/Makefile b/games/xasteroids/Makefile
index 019bc405c3cc..ba9d398b2c7d 100644
--- a/games/xasteroids/Makefile
+++ b/games/xasteroids/Makefile
@@ -2,7 +2,7 @@
# Date created: 3 Jan 1995
# Whom: swallace
#
-# $Id: Makefile,v 1.1.1.1 1995/01/04 08:56:17 swallace Exp $
+# $Id: Makefile,v 1.2 1995/01/29 22:00:24 ats Exp $
#
DISTNAME= xasteroids
@@ -11,7 +11,6 @@ EXTRACT_SUFX= .sh.Z
EXTRACT_CMD= ( cd ${WRKDIR}; zcat | sh -s )
EXTRACT_ARGS= <
USE_IMAKE= yes
-INSTALL_MANPAGES= yes
NO_WRKSUBDIR= yes
.include <bsd.port.mk>