aboutsummaryrefslogtreecommitdiffstats
path: root/games/xkobo
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2007-03-21 04:11:49 +0800
committerwill <will@FreeBSD.org>2007-03-21 04:11:49 +0800
commit1ded8f655b74e0539e478e63e922e4f94254b5aa (patch)
tree56a9888f2689c81ace4d4e40fac0c225f391bda7 /games/xkobo
parent5f7e96c9d35006c535b52e3a30d87ad97498e853 (diff)
downloadfreebsd-ports-gnome-1ded8f655b74e0539e478e63e922e4f94254b5aa.tar.gz
freebsd-ports-gnome-1ded8f655b74e0539e478e63e922e4f94254b5aa.tar.zst
freebsd-ports-gnome-1ded8f655b74e0539e478e63e922e4f94254b5aa.zip
Fix compilation when using gcc 4.1 due to attempting to cast a pointer to an
int, which may lose precision on platforms where sizeof(void*) > sizeof(int). Properly support overriding CC/CXX, which is a prerequisite for fixing this. Noticed by: pointyhat/kris
Diffstat (limited to 'games/xkobo')
-rw-r--r--games/xkobo/Makefile4
-rw-r--r--games/xkobo/files/patch-af4
2 files changed, 6 insertions, 2 deletions
diff --git a/games/xkobo/Makefile b/games/xkobo/Makefile
index 6eae33de7b49..44018bd64d0e 100644
--- a/games/xkobo/Makefile
+++ b/games/xkobo/Makefile
@@ -19,6 +19,10 @@ USE_IMAKE= yes
ALL_TARGET= xkobo
MAN1= xkobo.1
+post-configure:
+ ${REINPLACE_CMD} -E -e 's,^.* CC = .*$$, CC=${CC},' \
+ -e 's,^.* CXX = .*$$, CXX=${CXX},' ${WRKSRC}/Makefile
+
post-install:
${CHMOD} u-s,g+s ${PREFIX}/bin/xkobo
${CHOWN} root:games ${PREFIX}/bin/xkobo ${PREFIX}/lib/X11/xkobo-scores
diff --git a/games/xkobo/files/patch-af b/games/xkobo/files/patch-af
index 1db897a8ebf4..2bd42624e7b3 100644
--- a/games/xkobo/files/patch-af
+++ b/games/xkobo/files/patch-af
@@ -5,7 +5,7 @@
break;
}
- t += i;
-+ t = (void *) ((int) t + i);
++ t = (void *) ((long) t + i);
len -= i;
} while (len > 0);
for (;;){
@@ -14,7 +14,7 @@
break;
}
- t += i;
-+ t = (void *) ((int) t + i);
++ t = (void *) ((long) t + i);
len -= i;
} while (len > 0);
for (;;){