aboutsummaryrefslogtreecommitdiffstats
path: root/games/xkoules/Makefile
diff options
context:
space:
mode:
authormph <mph@FreeBSD.org>1998-04-20 05:35:22 +0800
committermph <mph@FreeBSD.org>1998-04-20 05:35:22 +0800
commit49b104f1384c41ea9a7624cf53fbe4c9e98f1533 (patch)
tree4e9223822552e46dedfaeac60e7bac78f2adce24 /games/xkoules/Makefile
parent779ddc3bbbf6113afd80f90cae01a192f0903b44 (diff)
downloadfreebsd-ports-gnome-49b104f1384c41ea9a7624cf53fbe4c9e98f1533.tar.gz
freebsd-ports-gnome-49b104f1384c41ea9a7624cf53fbe4c9e98f1533.tar.zst
freebsd-ports-gnome-49b104f1384c41ea9a7624cf53fbe4c9e98f1533.zip
Import of xkoules 1.4, an action game for X11.
PR: 5988 Submitted by: Andrey Zakhvatov <andy@icc.surw.chel.su>
Diffstat (limited to 'games/xkoules/Makefile')
-rw-r--r--games/xkoules/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/games/xkoules/Makefile b/games/xkoules/Makefile
new file mode 100644
index 000000000000..7f71146c8fa1
--- /dev/null
+++ b/games/xkoules/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: xkoules
+# Version required: 1.4
+# Date created: 11 March 1998
+# Whom: Andrey Zakhvatov
+#
+# $Id$
+#
+
+DISTNAME= koules1.4-src
+PKGNAME= xkoules-1.4
+CATEGORIES= games x11
+MASTER_SITES= http://www.paru.cas.cz/~hubicka/koules/packages/
+
+MAINTAINER= andy@icc.surw.chel.su
+
+USE_IMAKE= yes
+WRKSRC= ${WRKDIR}/koules1.4
+MAN6= xkoules.6
+
+do-install:
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/xkoules ${PREFIX}/bin
+ @ ${MKDIR} ${PREFIX}/share/xkoules
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/koules.sndsrv.freebsd ${PREFIX}/share/xkoules
+ @ ${INSTALL_DATA} ${WRKSRC}/sounds/*.raw ${PREFIX}/share/xkoules
+ @ ${INSTALL_MAN} ${WRKSRC}/xkoules.6 ${PREFIX}/man/man6
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${PREFIX}/share/doc/xkoules
+.for file in ANNOUNCE BUGS COPYING Card ChangeLog Koules.FAQ TODO
+ @ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/xkoules
+.endfor
+.endif
+
+.include <bsd.port.mk>