aboutsummaryrefslogtreecommitdiffstats
path: root/games/xlines/Makefile
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>1998-02-14 02:08:30 +0800
committervanilla <vanilla@FreeBSD.org>1998-02-14 02:08:30 +0800
commit6c59b563749216efc876621ab551a53862c37eb5 (patch)
tree56320af3673c3db76a52482de324b83e3005f15e /games/xlines/Makefile
parentae1eac26626aed32bd11b234684ea3417d29dea6 (diff)
downloadfreebsd-ports-gnome-6c59b563749216efc876621ab551a53862c37eb5.tar.gz
freebsd-ports-gnome-6c59b563749216efc876621ab551a53862c37eb5.tar.zst
freebsd-ports-gnome-6c59b563749216efc876621ab551a53862c37eb5.zip
XLines is an old game of balls where your goal is to remove
as many balls from the game field as you can. PR: ports/5736 Submitted by: Andrey Zakhvatov <andy@icc.surw.chel.su>
Diffstat (limited to 'games/xlines/Makefile')
-rw-r--r--games/xlines/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/games/xlines/Makefile b/games/xlines/Makefile
new file mode 100644
index 000000000000..a0cd6517170a
--- /dev/null
+++ b/games/xlines/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: xlines
+# Version required: 1.0
+# Date created: 11 February 1998
+# Whom: Andrey Zakhvatov
+#
+# $Id:$
+#
+
+DISTNAME= xlines
+PKGNAME= xlines-1.0
+CATEGORIES= games x11
+MASTER_SITES= ftp://risq.belcaf.minsk.by/pub/genie/
+
+MAINTAINER= andy@icc.surw.chel.su
+
+LIB_DEPENDS= qt\\.1\\.:${PORTSDIR}/x11/qt
+BUILD_DEPENDS= moc:${PORTSDIR}/x11/qt
+
+USE_X11= yes
+WRKSRC= ${WRKDIR}
+
+pre-patch:
+ @ ${TR} -d "\015" < ${WRKSRC}/Makefile > ${WRKSRC}/Makefile.new
+ @ ${MV} ${WRKSRC}/Makefile.new ${WRKSRC}/Makefile
+
+do-install:
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/xlines ${PREFIX}/bin
+ @ ${MKDIR} ${PREFIX}/share/xlines
+ @ ${INSTALL_DATA} ${WRKSRC}/trolltech.gif ${PREFIX}/share/xlines
+ @ ${MKDIR} ${PREFIX}/share/doc/xlines
+ @ ${INSTALL_DATA} ${WRKSRC}/readme.lines ${PREFIX}/share/doc/xlines
+ @ ${INSTALL_DATA} ${WRKSRC}/readme.qt ${PREFIX}/share/doc/xlines
+
+.include <bsd.port.mk>