aboutsummaryrefslogtreecommitdiffstats
path: root/games/xlines
diff options
context:
space:
mode:
authordwcjr <dwcjr@FreeBSD.org>2002-09-02 00:07:59 +0800
committerdwcjr <dwcjr@FreeBSD.org>2002-09-02 00:07:59 +0800
commitfd50192ea7567a034b59dfc96a1d112f8ccfa573 (patch)
tree6975c46330f04e77b17cb4d014c9d66ceb4f7a68 /games/xlines
parent54d69c112debb52b84b6d174bd59479eec834fb7 (diff)
downloadfreebsd-ports-gnome-fd50192ea7567a034b59dfc96a1d112f8ccfa573.tar.gz
freebsd-ports-gnome-fd50192ea7567a034b59dfc96a1d112f8ccfa573.tar.zst
freebsd-ports-gnome-fd50192ea7567a034b59dfc96a1d112f8ccfa573.zip
${PERL} -> ${REINPLACE_CMD}
PR: 40784 Submitted by: corecode@corecode.ath.cx Reviewed by: flynn@energyhq.homeip.net
Diffstat (limited to 'games/xlines')
-rw-r--r--games/xlines/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/games/xlines/Makefile b/games/xlines/Makefile
index 8b7f0b387839..812f58a7e9a1 100644
--- a/games/xlines/Makefile
+++ b/games/xlines/Makefile
@@ -15,13 +15,14 @@ MAINTAINER= ports@FreeBSD.org
USE_QT_VER= 1
USE_X_PREFIX= yes
+USE_REINPLACE= yes
NO_WRKSUBDIR= yes
pre-patch:
- @find ${WRKSRC} -type f | xargs ${PERL} -pi -e "s|\r\n|\n|g"
+ @${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -e "s|`/usr/bin/printf '\r'`||g"
post-patch:
- @${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/*.cpp
+ @${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/*.cpp
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xlines ${PREFIX}/bin