aboutsummaryrefslogtreecommitdiffstats
path: root/games/xmastermind
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
committermiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
commitbce9b81f9d6099820f3839d7809d6b08c1d2ae7b (patch)
treef5dd7c3a8dbebad79bdb5e844aeb69c59a9fd12c /games/xmastermind
parent2eea5f1d2e44418020f8f4db08d40bea6915b6e8 (diff)
downloadfreebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.gz
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.zst
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Diffstat (limited to 'games/xmastermind')
-rw-r--r--games/xmastermind/Makefile4
-rw-r--r--games/xmastermind/files/patch-aa8
2 files changed, 6 insertions, 6 deletions
diff --git a/games/xmastermind/Makefile b/games/xmastermind/Makefile
index 60c8be6c9a53..279eb04b6048 100644
--- a/games/xmastermind/Makefile
+++ b/games/xmastermind/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xmastermind
PORTVERSION= 0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= games/strategy
@@ -17,7 +17,7 @@ COMMENT= Mastermind game for X Window System
LIB_DEPENDS= forms.1:${PORTSDIR}/x11-toolkits/xforms
-USE_X_PREFIX= yes
+USE_XORG= x11 xpm
pre-patch:
@${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' \
diff --git a/games/xmastermind/files/patch-aa b/games/xmastermind/files/patch-aa
index ee322a413bff..afb6f3547394 100644
--- a/games/xmastermind/files/patch-aa
+++ b/games/xmastermind/files/patch-aa
@@ -5,14 +5,14 @@
CC = gcc
-CFLAGS = -O2 -Wall -Wpointer-arith -Wstrict-prototypes -pedantic -ansi
-+.if exists(${X11BASE}/include/X11/forms.h)
-+XFORMSINC=-I${X11BASE}/include/X11
++.if exists(${LOCALBASE}/include/X11/forms.h)
++XFORMSINC=-I${LOCALBASE}/include/X11
+.endif
-+CFLAGS+= -Wall -Wpointer-arith -Wstrict-prototypes -pedantic -ansi -I${X11BASE}/include ${XFORMSINC}
++CFLAGS+= -Wall -Wpointer-arith -Wstrict-prototypes -pedantic -ansi -I${LOCALBASE}/include ${XFORMSINC}
CLIBS = -lm
#GRAPHLIBS = -lforms -L/usr/X11R6/lib/ -lX11 -static
-GRAPHLIBS = -lforms -L/usr/X11R6/lib/ -lX11
-+GRAPHLIBS = -lforms -L${X11BASE}/lib -lX11 -lXpm
++GRAPHLIBS = -lforms -L${LOCALBASE}/lib -lX11 -lXpm
MF = Makefile
ALLLIBS = $(GRAPHLIBS) $(CLIBS)