aboutsummaryrefslogtreecommitdiffstats
path: root/games/xmoto/Makefile
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2013-07-12 23:01:45 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2013-07-12 23:01:45 +0800
commit816503d0c5051e291b1c9d153597bec2c0d90e3e (patch)
tree713942325bda393305edb21d46cd7f38d213aebc /games/xmoto/Makefile
parent422d267e1126322ee1278071a404f04be2383f95 (diff)
downloadfreebsd-ports-gnome-816503d0c5051e291b1c9d153597bec2c0d90e3e.tar.gz
freebsd-ports-gnome-816503d0c5051e291b1c9d153597bec2c0d90e3e.tar.zst
freebsd-ports-gnome-816503d0c5051e291b1c9d153597bec2c0d90e3e.zip
- Trim Makefile headers
- Drop ABI versions from LIB_DEPENDS - OptionsNG - Pet portlint - Switch to dynamic plist where useful - Canonicalize patch names - Fix DOS line endings in patch files
Diffstat (limited to 'games/xmoto/Makefile')
-rw-r--r--games/xmoto/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/games/xmoto/Makefile b/games/xmoto/Makefile
index 5cfab1736da5..4f57e53cc819 100644
--- a/games/xmoto/Makefile
+++ b/games/xmoto/Makefile
@@ -13,14 +13,14 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Challenging 2D motocross platform game
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- jpeg.11:${PORTSDIR}/graphics/jpeg \
+ jpeg:${PORTSDIR}/graphics/jpeg \
curl:${PORTSDIR}/ftp/curl \
xdg-basedir:${PORTSDIR}/x11/libxdg-basedir
BUILD_DEPENDS= ${LOCALBASE}/lib/libode.a:${PORTSDIR}/devel/ode
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_GNOME= pkgconfig libxml2
+USE_GNOME= libxml2
USE_LUA= 5.1
USE_SQLITE= 3
USE_SDL= sdl mixer ttf net
@@ -57,11 +57,11 @@ CONFIGURE_ARGS+=--without-asian-ttf-file
.endif
.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
+USES+= gettext
PLIST_SUB+= NLS=""
CONFIGURE_ENV+= LIBS="-lintl"
.else
-CONFIGURE_ARGS+= --disable-nls
+CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif