aboutsummaryrefslogtreecommitdiffstats
path: root/games/xmoto
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-02-05 21:38:45 +0800
committermiwi <miwi@FreeBSD.org>2008-02-05 21:38:45 +0800
commit466d0fce0596d0dede862790b37e1bd666a87e8a (patch)
tree29c25fe6e4640e6a0ea9d8a5f46841606757f081 /games/xmoto
parent9d938276ef57a9f1fec5d7672d6b89fceb3c5234 (diff)
downloadfreebsd-ports-gnome-466d0fce0596d0dede862790b37e1bd666a87e8a.tar.gz
freebsd-ports-gnome-466d0fce0596d0dede862790b37e1bd666a87e8a.tar.zst
freebsd-ports-gnome-466d0fce0596d0dede862790b37e1bd666a87e8a.zip
- Update to 0.4.0
PR: 120067 Submitted by: Dmitry Marakasov <amdmi3@amdmi3.ru> (maintainer)
Diffstat (limited to 'games/xmoto')
-rw-r--r--games/xmoto/Makefile6
-rw-r--r--games/xmoto/distinfo6
-rw-r--r--games/xmoto/files/patch-src-xmscene-BikeController.cpp15
3 files changed, 21 insertions, 6 deletions
diff --git a/games/xmoto/Makefile b/games/xmoto/Makefile
index 1a94287b2ef1..612f3b21b5db 100644
--- a/games/xmoto/Makefile
+++ b/games/xmoto/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xmoto
-PORTVERSION= 0.3.4
+PORTVERSION= 0.4.0
CATEGORIES= games
MASTER_SITES= http://download.tuxfamily.org/xmoto/xmoto/${PORTVERSION}/ \
http://www.amdmi3.ru/distfiles/
@@ -15,8 +15,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= amdmi3@amdmi3.ru
COMMENT= Challenging 2D motocross platform game
-LIB_DEPENDS= vorbis.4:${PORTSDIR}/audio/libvorbis \
- png.5:${PORTSDIR}/graphics/png \
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg \
curl.4:${PORTSDIR}/ftp/curl
BUILD_DEPENDS= ${X11BASE}/lib/libode.a:${PORTSDIR}/devel/ode
@@ -72,6 +71,7 @@ post-patch:
@${REINPLACE_CMD} -e '/LIBS/ s|-lSDL_mixer|`${SDL_CONFIG} --libs` &|' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|/mang|/man6|' ${WRKSRC}/Makefile.in
+ @${ECHO_CMD} -n exported > ${WRKSRC}/src/svnVersion
.if !defined(NOPORTDOCS)
post-install:
diff --git a/games/xmoto/distinfo b/games/xmoto/distinfo
index 051e0b5cf34d..a50226415576 100644
--- a/games/xmoto/distinfo
+++ b/games/xmoto/distinfo
@@ -1,3 +1,3 @@
-MD5 (xmoto-0.3.4-src.tar.gz) = cd2041652586119f68655c789c0ce7b3
-SHA256 (xmoto-0.3.4-src.tar.gz) = 79d80562e051cce58da357d9d31308aeda8bffb668c8d3ff49fe4d27e3c9b243
-SIZE (xmoto-0.3.4-src.tar.gz) = 17017466
+MD5 (xmoto-0.4.0-src.tar.gz) = 87819a23ccaf3b919d8b80d8c6f3c374
+SHA256 (xmoto-0.4.0-src.tar.gz) = 6acaa967a8e687e23ca9a3d66b1a280590dae521fc410ef16bd14289af906492
+SIZE (xmoto-0.4.0-src.tar.gz) = 17200350
diff --git a/games/xmoto/files/patch-src-xmscene-BikeController.cpp b/games/xmoto/files/patch-src-xmscene-BikeController.cpp
new file mode 100644
index 000000000000..1154fd0f6bb5
--- /dev/null
+++ b/games/xmoto/files/patch-src-xmscene-BikeController.cpp
@@ -0,0 +1,15 @@
+--- src/xmscene/BikeController.cpp.orig 2008-01-06 12:56:21.000000000 +0300
++++ src/xmscene/BikeController.cpp 2008-02-05 14:49:40.000000000 +0300
+@@ -77,11 +77,7 @@
+ m_drive = -m_break;
+ }
+ else if(m_break == 0.0f){
+- if(m_throttle != 0.0f){
+- m_drive = m_throttle;
+- } else {
+- m_drive = 0.0f;
+- }
++ m_drive = m_throttle;
+ }
+ }
+