aboutsummaryrefslogtreecommitdiffstats
path: root/games/xneko/files
diff options
context:
space:
mode:
authormarkm <markm@FreeBSD.org>1995-12-23 02:10:20 +0800
committermarkm <markm@FreeBSD.org>1995-12-23 02:10:20 +0800
commit3aac0055fac3293616ee42101e2ec58b75f7b711 (patch)
tree8aa206fadb5c72d9ad334aa723b5979805d502cb /games/xneko/files
parenta9bd582ba4c269d876e1ae95784bf9b1df8333ae (diff)
downloadfreebsd-ports-gnome-3aac0055fac3293616ee42101e2ec58b75f7b711.tar.gz
freebsd-ports-gnome-3aac0055fac3293616ee42101e2ec58b75f7b711.tar.zst
freebsd-ports-gnome-3aac0055fac3293616ee42101e2ec58b75f7b711.zip
Bring xneko into the ports area preparatory to removing it from the
main source tree. OK'ed by: jkh asami (amongst others)
Diffstat (limited to 'games/xneko/files')
-rw-r--r--games/xneko/files/patch-aa37
1 files changed, 37 insertions, 0 deletions
diff --git a/games/xneko/files/patch-aa b/games/xneko/files/patch-aa
new file mode 100644
index 000000000000..483988a15c8c
--- /dev/null
+++ b/games/xneko/files/patch-aa
@@ -0,0 +1,37 @@
+diff -udr ../xneko.BSD/Makefile ./Makefile
+--- ../xneko.BSD/Makefile Tue Jun 1 03:46:11 1993
++++ ./Makefile Fri Dec 22 19:16:13 1995
+@@ -1,8 +1,17 @@
+ # @(#)Makefile 8.1 (Berkeley) 5/31/93
+
+ PROG= xneko
+-MAN6= xneko.0
+-DPADD= ${LIBX} ${LIBM}
+-LDADD= -lX11/X11 -lm
++MAN6= xneko.6
++
++DPADD+= ${X11BASE}/lib/libX11.a ${LIBM}
++CFLAGS+= -I${X11BASE}/include
++LDDESTDIR+= -L${X11BASE}/lib
++LDADD+= -lX11 -lm
++
++MANDIR= ${X11BASE}/man/man
++
++BINOWN= bin
++BINDIR= ${X11BASE}/bin
++BINMODE= 755
+
+ .include <bsd.prog.mk>
+diff -udr ../xneko.BSD/xneko.c ./xneko.c
+--- ../xneko.BSD/xneko.c Tue Jun 1 03:46:10 1993
++++ ./xneko.c Fri Dec 22 19:10:44 1995
+@@ -139,6 +139,9 @@
+
+ #include <stdio.h>
+
++#include <stdlib.h>
++#include <string.h>
++
+ #include <signal.h>
+ #include <math.h>
+ #include <sys/time.h>