aboutsummaryrefslogtreecommitdiffstats
path: root/games/xpanex/Makefile
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>1998-05-20 15:54:07 +0800
committertg <tg@FreeBSD.org>1998-05-20 15:54:07 +0800
commit28358697748e7780250534312dcf8aad7a39a82a (patch)
tree48e571bb96d711921099d6268f28b6fa23fe74c6 /games/xpanex/Makefile
parent7e663492c8124c77fd69eb5370394ca5e9d04a03 (diff)
downloadfreebsd-ports-gnome-28358697748e7780250534312dcf8aad7a39a82a.tar.gz
freebsd-ports-gnome-28358697748e7780250534312dcf8aad7a39a82a.tar.zst
freebsd-ports-gnome-28358697748e7780250534312dcf8aad7a39a82a.zip
New port xpanex, another puzzle for X11.
PR: 6165 Submitted by: Andrey Zakhvatov <andy@icc.surw.chel.su>
Diffstat (limited to 'games/xpanex/Makefile')
-rw-r--r--games/xpanex/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/games/xpanex/Makefile b/games/xpanex/Makefile
new file mode 100644
index 000000000000..22a2728c15e7
--- /dev/null
+++ b/games/xpanex/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: xpanex
+# Version required: 5.4.3
+# Date created: 27 March 1998
+# Whom: Andrey Zakhvatov
+#
+# $Id$
+#
+
+DISTNAME= xpanex-5.4.3
+CATEGORIES= games x11
+MASTER_SITES= ${MASTER_SITE_XCONTRIB}
+MASTER_SITE_SUBDIR= games/xpuzzles
+
+MAINTAINER= andy@icc.surw.chel.su
+
+WRKSRC= ${WRKDIR}/xpanex
+USE_IMAKE= yes
+MAN1= xpanex.1
+
+do-install:
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/xpanex ${PREFIX}/bin
+ @ ${INSTALL_DATA} ${WRKSRC}/Panex.ad ${PREFIX}/lib/X11/app-defaults/Panex
+ @ ${INSTALL_MAN} ${WRKSRC}/xpanex.man ${PREFIX}/man/man1/xpanex.1
+
+.include <bsd.port.mk>