aboutsummaryrefslogtreecommitdiffstats
path: root/games/xpired/Makefile
diff options
context:
space:
mode:
authorpat <pat@FreeBSD.org>2002-08-06 05:54:48 +0800
committerpat <pat@FreeBSD.org>2002-08-06 05:54:48 +0800
commit66115e200773f6f8a121e11fa8578cd36f50d9a0 (patch)
treef6c255133cae699dc7a203af32495ebe53949290 /games/xpired/Makefile
parent518a1f1cd7d9bb953776282bcace500280d8930d (diff)
downloadfreebsd-ports-gnome-66115e200773f6f8a121e11fa8578cd36f50d9a0.tar.gz
freebsd-ports-gnome-66115e200773f6f8a121e11fa8578cd36f50d9a0.tar.zst
freebsd-ports-gnome-66115e200773f6f8a121e11fa8578cd36f50d9a0.zip
Add new port xpired: An action-puzzle game
PR: ports/40161 Submitted by: Edwin Groothuis <edwin@mavetju.org>
Diffstat (limited to 'games/xpired/Makefile')
-rw-r--r--games/xpired/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/games/xpired/Makefile b/games/xpired/Makefile
new file mode 100644
index 000000000000..bafcc1e2680e
--- /dev/null
+++ b/games/xpired/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: xpired
+# Date created: 2 July 2002
+# Whom: Edwin Groothuis <edwin@mavetju.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xpired
+PORTVERSION= 1.22
+CATEGORIES= games
+MASTER_SITES= http://xpired.temnet.org/files/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-linux_source
+
+MAINTAINER= edwin@mavetju.org
+
+LIB_DEPENDS= SDL_gfx.0:${PORTSDIR}/graphics/sdl_gfx \
+ SDL_image.10:${PORTSDIR}/graphics/sdl_image \
+ SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer \
+ SDL-1.1.4:${PORTSDIR}/devel/sdl12
+
+WRKSRC= ${WRKDIR}/src
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/xpired ${WRKSRC}/xpiredit ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}/img
+ @${MKDIR} ${DATADIR}/snd
+.for files in xpired.lvl xpired.cfg bgimages.txt readme.txt xpired.dmo
+ @${INSTALL_DATA} ${WRKSRC}/${files} ${DATADIR}
+.endfor
+ @${INSTALL_DATA} ${WRKSRC}/img/* ${DATADIR}/img
+ @${INSTALL_DATA} ${WRKSRC}/snd/* ${DATADIR}/snd
+
+.include <bsd.port.mk>