aboutsummaryrefslogtreecommitdiffstats
path: root/games/xqf
diff options
context:
space:
mode:
authormux <mux@FreeBSD.org>2006-04-13 22:11:34 +0800
committermux <mux@FreeBSD.org>2006-04-13 22:11:34 +0800
commit56a2257b0ea50e2a213dea1d5ee72a1b4695ac27 (patch)
treedff2082d71f0fe13f0f1cb22545e09749b7e91fe /games/xqf
parentf91d63f8dc526fc71979381db32046850724935d (diff)
downloadfreebsd-ports-gnome-56a2257b0ea50e2a213dea1d5ee72a1b4695ac27.tar.gz
freebsd-ports-gnome-56a2257b0ea50e2a213dea1d5ee72a1b4695ac27.tar.zst
freebsd-ports-gnome-56a2257b0ea50e2a213dea1d5ee72a1b4695ac27.zip
Apply a patch found on the sourceforce project page for XQF, that fixes
loading the pixmaps bundled in the binary with recent GCC versions. XQF would just crash at startup without this fix. Reviewed by: pav
Diffstat (limited to 'games/xqf')
-rw-r--r--games/xqf/Makefile2
-rw-r--r--games/xqf/files/patch-src-Makefile.in11
-rw-r--r--games/xqf/files/patch-src-xqf.map11
3 files changed, 23 insertions, 1 deletions
diff --git a/games/xqf/Makefile b/games/xqf/Makefile
index 8c2fc0d74235..9cf0e66044ad 100644
--- a/games/xqf/Makefile
+++ b/games/xqf/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xqf
PORTVERSION= 1.0.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/games/xqf/files/patch-src-Makefile.in b/games/xqf/files/patch-src-Makefile.in
new file mode 100644
index 000000000000..482efc93ba71
--- /dev/null
+++ b/games/xqf/files/patch-src-Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Thu Apr 13 15:51:27 2006
++++ src/Makefile.in Thu Apr 13 15:51:37 2006
+@@ -313,7 +313,7 @@
+ $(GDK_PIXBUF_LIBS) \
+ -lz
+
+-xqf_LDFLAGS = -Wl,-rpath,$(pkglibdir)
++xqf_LDFLAGS = -Wl,-rpath,$(pkglibdir) -Wl,--export-dynamic -Wl,--version-script=$(top_srcdir)/src/xqf.map
+
+ # we need to specify all deps manually due to dummy libs
+ xqf_DEPENDENCIES = $(top_builddir)/src/zip/libunzip.a \
diff --git a/games/xqf/files/patch-src-xqf.map b/games/xqf/files/patch-src-xqf.map
new file mode 100644
index 000000000000..9fa7ea51d210
--- /dev/null
+++ b/games/xqf/files/patch-src-xqf.map
@@ -0,0 +1,11 @@
+Index: src/xqf.map
+===================================================================
+--- /dev/null
++++ src/xqf.map
+@@ -0,0 +1,6 @@
++{
++ global:
++ *_xpm;
++ local:
++ *;
++};