aboutsummaryrefslogtreecommitdiffstats
path: root/games/xracer
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2005-11-15 14:52:12 +0800
committerade <ade@FreeBSD.org>2005-11-15 14:52:12 +0800
commit8d9d5197561118544281733430b48b0b60884450 (patch)
tree45e5dcd7c2206fce8b01186555aac96b6292c602 /games/xracer
parent081b17449bd91bcac5390cd0d8a63ed3914df51d (diff)
downloadfreebsd-ports-gnome-8d9d5197561118544281733430b48b0b60884450.tar.gz
freebsd-ports-gnome-8d9d5197561118544281733430b48b0b60884450.tar.zst
freebsd-ports-gnome-8d9d5197561118544281733430b48b0b60884450.zip
Mass-conversion to the USE_AUTOTOOLS New World Order. The code present
in bsd.autotools.mk essentially makes this a no-op given that all the old variables set a USE_AUTOTOOLS_COMPAT variable, which is parsed in exactly the same way as USE_AUTOTOOLS itself. Moreover, USE_AUTOTOOLS has already been extensively tested by the GNOME team -- all GNOME 2.12.x ports use it. Preliminary documentation can be found at: http://people.FreeBSD.org/~ade/autotools.txt which is in the process of being SGMLized before introduction into the Porters Handbook. Light blue touch-paper. Run.
Diffstat (limited to 'games/xracer')
-rw-r--r--games/xracer/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/games/xracer/Makefile b/games/xracer/Makefile
index 1dfb0bf5cb26..fd4f9af7d0ea 100644
--- a/games/xracer/Makefile
+++ b/games/xracer/Makefile
@@ -20,8 +20,7 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
USE_XLIB= yes
USE_MESA= yes
USE_GMAKE= yes
-USE_AUTOMAKE_VER= 14
-USE_AUTOCONF_VER= 213
+USE_AUTOTOOLS= automake:14 autoconf:213
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}"
CONFIGURE_ARGS= --disable-esd