aboutsummaryrefslogtreecommitdiffstats
path: root/games/xscrabble
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2011-11-20 20:13:12 +0800
committerdinoex <dinoex@FreeBSD.org>2011-11-20 20:13:12 +0800
commit6c4d9a454b88ef8df0d0841efb0d64d47ea03748 (patch)
tree6bf83f3ae1fe1268c4d05f09670658d81dd20f87 /games/xscrabble
parent62d21b089bf9742a39c52be288dff1835f86f1f6 (diff)
downloadfreebsd-ports-gnome-6c4d9a454b88ef8df0d0841efb0d64d47ea03748.tar.gz
freebsd-ports-gnome-6c4d9a454b88ef8df0d0841efb0d64d47ea03748.tar.zst
freebsd-ports-gnome-6c4d9a454b88ef8df0d0841efb0d64d47ea03748.zip
Ressurrect the game, fetch, build and runs.
Feature safe: yes
Diffstat (limited to 'games/xscrabble')
-rw-r--r--games/xscrabble/Makefile48
-rw-r--r--games/xscrabble/distinfo4
-rw-r--r--games/xscrabble/pkg-descr18
-rw-r--r--games/xscrabble/pkg-plist8
4 files changed, 78 insertions, 0 deletions
diff --git a/games/xscrabble/Makefile b/games/xscrabble/Makefile
new file mode 100644
index 000000000000..04453a50a5a6
--- /dev/null
+++ b/games/xscrabble/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: xscrabble
+# Date created: 27 July 1997
+# Whom: Thomas Gellekum <tg@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xscrabble
+PORTVERSION= 2.12
+PORTREVISION= 1
+CATEGORIES= games
+MASTER_SITES= ftp://ftp.ac-grenoble.fr/ge/educational_games/
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${PORTNAME}_en${EXTRACT_SUFX}
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= X version of the popular board game
+
+USE_BZIP2= yes
+USE_IMAKE= yes
+USE_XORG= xaw
+NO_INSTALL_MANPAGES= yes
+
+XSCRABBLEDIR= ${PREFIX}/lib/X11/xscrabble
+
+post-patch:
+ @${ECHO_CMD} '#define VERSION ${PORTVERSION:S/.//g}' \
+ > ${WRKSRC}/src/config.h
+ @${ECHO_CMD} '#define DICT_FILE "${XSCRABBLEDIR}/OSPD3.gz"' \
+ >> ${WRKSRC}/src/config.h
+ @${ECHO_CMD} '#define SCORE_FILE "${XSCRABBLEDIR}/scrabble_scores"' \
+ >> ${WRKSRC}/src/config.h
+ @${ECHO_CMD} '#define RULES_FILE "${XSCRABBLEDIR}/scrabble_rules"' \
+ >> ${WRKSRC}/src/config.h
+ @${SED} -e 's|/usr/share/games/scrabble/en|${XSCRABBLEDIR}|g' \
+ ${WRKSRC}/../xscrabble_en/app-defaults/XScrabble_en \
+ > ${WRKSRC}/XScrabble
+ @${REINPLACE_CMD} -e 's|= -O|=$$(CDEBUGFLAGS)|g' ${WRKSRC}/Imakefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/xscrab ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/xscrabble ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/XScrabble ${PREFIX}/lib/X11/app-defaults
+ @${MKDIR} ${XSCRABBLEDIR}
+.for file in OSPD3.gz duplicate scrabble_rules scrabble_scores
+ ${INSTALL_DATA} ${WRKSRC}/../xscrabble_en/lib/${file} ${XSCRABBLEDIR}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/games/xscrabble/distinfo b/games/xscrabble/distinfo
new file mode 100644
index 000000000000..c55b2bcb5cb2
--- /dev/null
+++ b/games/xscrabble/distinfo
@@ -0,0 +1,4 @@
+SHA256 (xscrabble-2.12.tar.bz2) = e3eb8a93810af31ea9589f801fb529e7d83df4a54f5d836972777cb4fce81b3d
+SIZE (xscrabble-2.12.tar.bz2) = 79415
+SHA256 (xscrabble_en.tar.bz2) = c52c672fb5f3a3b19f6759d26bc1e3b1755bbc79361ddfa1d085842810560a4c
+SIZE (xscrabble_en.tar.bz2) = 397796
diff --git a/games/xscrabble/pkg-descr b/games/xscrabble/pkg-descr
new file mode 100644
index 000000000000..8d85be5d0bcb
--- /dev/null
+++ b/games/xscrabble/pkg-descr
@@ -0,0 +1,18 @@
+To run:
+
+Simply type xscrabble. This will bring up the setup box which will allow
+you to enter the names and displays and other info for the game to wish
+to play. Then click on the Start Game button, (or Load Previous if you're
+restarting a game). The main program, xscrab, will then be automatically
+called with the appropriate options.
+
+The game is saved after every turn (in "~/.xscrabble.save" of the
+person running it) and can be restarted by running xscrabble, entering
+exactly the same info, and hitting the Load Previous button.
+
+This was a student project, and there are not likely to be any future
+releases.
+
+Have fun,
+
+Matt Chapman.
diff --git a/games/xscrabble/pkg-plist b/games/xscrabble/pkg-plist
new file mode 100644
index 000000000000..95903466f590
--- /dev/null
+++ b/games/xscrabble/pkg-plist
@@ -0,0 +1,8 @@
+bin/xscrab
+bin/xscrabble
+lib/X11/app-defaults/XScrabble
+lib/X11/xscrabble/OSPD3.gz
+lib/X11/xscrabble/duplicate
+lib/X11/xscrabble/scrabble_rules
+lib/X11/xscrabble/scrabble_scores
+@dirrm lib/X11/xscrabble