aboutsummaryrefslogtreecommitdiffstats
path: root/games/xvmines/Makefile
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>1998-03-27 18:09:58 +0800
committertg <tg@FreeBSD.org>1998-03-27 18:09:58 +0800
commitc089c6c08209d17044f6325b39f3c8296d02cf85 (patch)
treeeddedbf4fde711d3760852164895948ce2fe944c /games/xvmines/Makefile
parentc044c9fab01115a793ae57eb96e26596402ea879 (diff)
downloadfreebsd-ports-gnome-c089c6c08209d17044f6325b39f3c8296d02cf85.tar.gz
freebsd-ports-gnome-c089c6c08209d17044f6325b39f3c8296d02cf85.tar.zst
freebsd-ports-gnome-c089c6c08209d17044f6325b39f3c8296d02cf85.zip
Continuing our relentless quest for minesweepers, we give you xvmines.
PR: 6070 Submitted by: Andrey Zakhvatov <andy@icc.surw.chel.su>
Diffstat (limited to 'games/xvmines/Makefile')
-rw-r--r--games/xvmines/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/games/xvmines/Makefile b/games/xvmines/Makefile
new file mode 100644
index 000000000000..d97c01ada5a9
--- /dev/null
+++ b/games/xvmines/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: xvmines
+# Version required: 1.0
+# Date created: 18 March 1998
+# Whom: Andrey Zakhvatov
+#
+# $Id$
+#
+
+DISTNAME= xvmines-1.0
+CATEGORIES= games
+MASTER_SITES= ftp://ftp.csd.uch.gr/pub/X11/games/ \
+ ftp://ftp.cdrom.com/pub/X11/R5contrib/ \
+ ftp://ftp.gwdg.de/pub/x11/x.org/R5contrib/
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= andy@icc.surw.chel.su
+
+LIB_DEPENDS= xview\\.3\\.2:${PORTSDIR}/x11/xview-lib \
+ olgx\\.3\\.2:${PORTSDIR}/x11/xview-lib
+
+USE_IMAKE= yes
+MAN6= xvmines.6
+
+do-install:
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/xvmines ${PREFIX}/bin
+ @ ${INSTALL_DATA} ${WRKSRC}/xvmines.man ${PREFIX}/man/man6/xvmines.6
+ @ ${MKDIR} ${PREFIX}/share/doc/xvmines
+ @ ${INSTALL_DATA} ${WRKSRC}/Copyright ${PREFIX}/share/doc/xvmines
+
+.include <bsd.port.mk>