aboutsummaryrefslogtreecommitdiffstats
path: root/games/yahtzee/Makefile
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2000-11-11 14:38:20 +0800
committerkevlo <kevlo@FreeBSD.org>2000-11-11 14:38:20 +0800
commit3bef30fd90cdd2264c609857b3d1479ce83459fe (patch)
treef0427ff23ff066aa5913ffda25276b3df4bb2f54 /games/yahtzee/Makefile
parentaed42626953e3c2289c04e4779c2d4cf26427a91 (diff)
downloadfreebsd-ports-gnome-3bef30fd90cdd2264c609857b3d1479ce83459fe.tar.gz
freebsd-ports-gnome-3bef30fd90cdd2264c609857b3d1479ce83459fe.tar.zst
freebsd-ports-gnome-3bef30fd90cdd2264c609857b3d1479ce83459fe.zip
- Support CFLAGS/PREFIX properly
- freebsd.org -> FreeBSD.org - Change location of data files from lib/ to share/ PR: 22746 Submitted by: Ports Fury
Diffstat (limited to 'games/yahtzee/Makefile')
-rw-r--r--games/yahtzee/Makefile26
1 files changed, 13 insertions, 13 deletions
diff --git a/games/yahtzee/Makefile b/games/yahtzee/Makefile
index 15252125cf47..6711cf6a68f7 100644
--- a/games/yahtzee/Makefile
+++ b/games/yahtzee/Makefile
@@ -1,28 +1,28 @@
-# New ports collection makefile for: yahtzee
+# New ports collection makefile for: yahtzee
# Date created: Friday 4th July, 1997
# Whom: Joel Sutton <sutton@aardvark.apana.org.au>
-# FreeBSD Version: 2.2.1-RELEASE
#
# $FreeBSD$
#
-PORTNAME= yahtzee
-PORTVERSION= 1.0
-CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SUNSITE}
+PORTNAME= yahtzee
+PORTVERSION= 1.0
+PORTREVISION= 1
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= games/strategy
-DISTFILES= yahtzee-src.tar.Z
+DISTNAME= ${PORTNAME}-src
+EXTRACT_SUFX= .tar.Z
-MAINTAINER= ports@freebsd.org
+MAINTAINER= ports@FreeBSD.org
-WRKSRC= ${WRKDIR}/yahtzee
+WRKSRC= ${WRKDIR}/${PORTNAME}
# Distribution does not include an install target. So here it is.
#
do-install:
- ${INSTALL_PROGRAM} -m 2755 -o root -g games ${WRKSRC}/yahtzee ${PREFIX}/bin/
- ${MKDIR} -m 0755 ${PREFIX}/lib/yahtzee/
- ${INSTALL_DATA} -m 0664 -o root -g games /dev/null ${PREFIX}/lib/yahtzee/yahtzee.sco
+ ${INSTALL_PROGRAM} -m 2755 -o root -g games ${WRKSRC}/yahtzee ${PREFIX}/bin
+ ${MKDIR} -m 0755 ${PREFIX}/share/yahtzee
+ ${INSTALL_DATA} -m 0664 -o root -g games /dev/null ${PREFIX}/share/yahtzee/yahtzee.sco
.include <bsd.port.mk>
-