aboutsummaryrefslogtreecommitdiffstats
path: root/games/zangband/Makefile
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-01-31 11:43:34 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-01-31 11:43:34 +0800
commita6e37d6244f205ee5a16e227c7ad6837212f9e4d (patch)
treee2adc773f2661497fdf7e383d01c4452290a7f27 /games/zangband/Makefile
parentfd4b0bb7aa388b92f7055c34360fcad189ee0498 (diff)
downloadfreebsd-ports-gnome-a6e37d6244f205ee5a16e227c7ad6837212f9e4d.tar.gz
freebsd-ports-gnome-a6e37d6244f205ee5a16e227c7ad6837212f9e4d.tar.zst
freebsd-ports-gnome-a6e37d6244f205ee5a16e227c7ad6837212f9e4d.zip
- use $SUB_FILES to dynamically adjust pkg-message
PR: ports/142536 Submitted by: Sevan Janiyan <venture37@geeklan.co.uk>
Diffstat (limited to 'games/zangband/Makefile')
-rw-r--r--games/zangband/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/games/zangband/Makefile b/games/zangband/Makefile
index 17e6b15f0dd8..8df068c00a55 100644
--- a/games/zangband/Makefile
+++ b/games/zangband/Makefile
@@ -25,8 +25,9 @@ CONFIGURE_ARGS= --datadir=${PREFIX}/lib --mandir=${PREFIX}/man \
NO_CDROM= Possible copyright infringement
WRKSRC= ${WRKDIR}/${PORTNAME}
-PKGMESSAGE= ${WRKDIR}/MESSAGE
PLIST_SUB+= ANGBANDBIN=${ANGBANDBIN} ANGBANDLIB=${ANGBANDLIB}
+SUB_FILES= pkg-message
+SUB_LIST= ANGBANDBIN=${ANGBANDBIN} ANGBANDLIB=${ANGBANDLIB}
SHAREOWN= games
SHAREGRP= games
@@ -54,7 +55,6 @@ post-install:
${CHMOD} -R o+r help ; \
${CHMOD} 1777 save user \
)
- @${SED} -e "s|%%PREFIX%%|${PREFIX}|g;s|%%ANGBANDBIN%%|${ANGBANDBIN}|g;s|%%ANGBANDLIB%%|${ANGBANDLIB}|g" ${FILESDIR}/MESSAGE.in > ${PKGMESSAGE}
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>