aboutsummaryrefslogtreecommitdiffstats
path: root/games/zangband/files
diff options
context:
space:
mode:
authorcpiazza <cpiazza@FreeBSD.org>2000-08-10 01:34:16 +0800
committercpiazza <cpiazza@FreeBSD.org>2000-08-10 01:34:16 +0800
commit6d92cfd24b17f746920e51ee3aed796493a62a8b (patch)
tree095a9eb9b5079ec663e7c28431e8eb1dd115681a /games/zangband/files
parent43c7c270a886c1642d2387246b99a2d50de3de14 (diff)
downloadfreebsd-ports-gnome-6d92cfd24b17f746920e51ee3aed796493a62a8b.tar.gz
freebsd-ports-gnome-6d92cfd24b17f746920e51ee3aed796493a62a8b.tar.zst
freebsd-ports-gnome-6d92cfd24b17f746920e51ee3aed796493a62a8b.zip
Add zangband.
ZAngband is one of the many variants of the freeware rogue-like roleplaying game Angband. PR: 20133 Submitted by: Makoto YAMAKURA <makoto@pinpott.spnet.ne.jp>
Diffstat (limited to 'games/zangband/files')
-rw-r--r--games/zangband/files/MESSAGE.in15
-rw-r--r--games/zangband/files/Makefile.in12
-rw-r--r--games/zangband/files/makefile-adjust.patch13
-rw-r--r--games/zangband/files/patch-aa37
-rw-r--r--games/zangband/files/patch-ab11
5 files changed, 88 insertions, 0 deletions
diff --git a/games/zangband/files/MESSAGE.in b/games/zangband/files/MESSAGE.in
new file mode 100644
index 000000000000..b9dfd64f45ba
--- /dev/null
+++ b/games/zangband/files/MESSAGE.in
@@ -0,0 +1,15 @@
+ ============================================================================
+ To reduce the number of term windows opened, use -n:
+ %%PREFIX%%/%%ANGBANDBIN%% -- -n2
+
+ The binary will changed its owner to 'games:games' and added SETGID bit.
+ Then players can record their score to public score files.
+ You can set fonts by using environment variables such as ANGBAND_X11_FONT,
+ ANGBAND_X11_FONT_1 (the number represents sub-window id),
+ ANGBAND_X11_KFONT (for kanji support), etc.
+
+ WARNING!
+ You now have the following world-writable (mode 1777) directories:
+ %%PREFIX%%/%%ANGBANDLIB%%/save
+ %%PREFIX%%/%%ANGBANDLIB%%/user
+ ============================================================================
diff --git a/games/zangband/files/Makefile.in b/games/zangband/files/Makefile.in
new file mode 100644
index 000000000000..9034917cec35
--- /dev/null
+++ b/games/zangband/files/Makefile.in
@@ -0,0 +1,12 @@
+# My makefile for Angband
+# Matthew Hunt <mph@FreeBSD.org>
+
+ANGBANDLIB?= /usr/local/lib/angband
+
+all: testing
+
+testing:
+ cd src && make "EXTRA_CFLAGS=-I${X11BASE}/include ${JAPANESE_CFLAGS} -DDEFAULT_PATH=\\\"${ANGBANDLIB}\\\""
+
+test: testing
+ ANGBAND_PATH=./lib ./testing
diff --git a/games/zangband/files/makefile-adjust.patch b/games/zangband/files/makefile-adjust.patch
new file mode 100644
index 000000000000..7476abac54a6
--- /dev/null
+++ b/games/zangband/files/makefile-adjust.patch
@@ -0,0 +1,13 @@
+--- /home/makoto/ports/japanese/zangband/work/ZAngband/src/makefile.std Sat Jul 22 21:37:07 2000
++++ src/makefile.std Sat Jul 22 21:30:29 2000
+@@ -127,8 +127,8 @@
+ #CFLAGS = -Wall -O1 -pipe -g -D"USE_X11" -D"USE_GCU"
+ #LIBS = -lX11 -lcurses -ltermcap
+
+-CFLAGS = -Wall -O2 -m486 -pipe -g -D"USE_X11" -D"JP" -D"EUC" -D"JP_ARTDESC" -D"USE_GCU"
+-LIBS = -L/usr/X11R6/lib -lXaw -lXext -lSM -lICE -lXmu -lXt -lX11 -lcurses
++CFLAGS = -Wall -O2 -m486 -pipe -g -D"USE_XAW" -D"USE_GCU"
++LIBS = -L/usr/X11R6/lib -lXaw -lXext -lSM -lICE -lXmu -lXt -lX11 -lcurses
+
+
+ ##
diff --git a/games/zangband/files/patch-aa b/games/zangband/files/patch-aa
new file mode 100644
index 000000000000..3085add0ce00
--- /dev/null
+++ b/games/zangband/files/patch-aa
@@ -0,0 +1,37 @@
+--- src/Makefile.orig Wed Aug 9 11:32:26 2000
++++ src/Makefile Wed Aug 9 11:32:43 2000
+@@ -103,7 +103,7 @@
+ #
+ # This is my compiler of choice, it seems to work most everywhere
+ #
+-CC = gcc
++CC ?= gcc
+
+
+ #
+@@ -127,8 +127,8 @@
+ #CFLAGS = -Wall -O1 -pipe -g -D"USE_X11" -D"USE_GCU"
+ #LIBS = -lX11 -lcurses -ltermcap
+
+-CFLAGS = -Wall -O2 -m486 -pipe -g -D"USE_XAW" -D"USE_GCU"
+-LIBS = -L/usr/X11R6/lib -lXaw -lXext -lSM -lICE -lXmu -lXt -lX11 -lcurses
++#CFLAGS = -Wall -O2 -m486 -pipe -g -D"USE_XAW" -D"USE_GCU"
++#LIBS = -L/usr/X11R6/lib -lXaw -lXext -lSM -lICE -lXmu -lXt -lX11 -lcurses
+
+
+ ##
+@@ -228,6 +228,14 @@
+ ##
+ #CFLAGS = -Wall -O1 -pipe -g -D"USE_GCU" -arch m68k -arch i386
+ #LIBS = -lcurses -ltermcap
++
++
++
++##
++## Variation -- Compile for FreeBSD
++##
++CFLAGS += -D"USE_X11" -D"USE_GCU" ${EXTRA_CFLAGS}
++LIBS = -L${X11BASE}/lib -lXaw -lXext -lSM -lICE -lXmu -lXt -lX11 -lcurses
+
+
+
diff --git a/games/zangband/files/patch-ab b/games/zangband/files/patch-ab
new file mode 100644
index 000000000000..9f38436bb6d8
--- /dev/null
+++ b/games/zangband/files/patch-ab
@@ -0,0 +1,11 @@
+--- src/z-config.h.orig Wed Feb 11 05:30:28 1998
++++ src/z-config.h Sat Sep 18 18:20:32 1999
+@@ -52,7 +52,7 @@
+ /*
+ * OPTION: Use the POSIX "termios" methods in "main-gcu.c"
+ */
+-/* #define USE_TPOSIX */
++#define USE_TPOSIX
+
+ /*
+ * OPTION: Use the "termio" methods in "main-gcu.c"