aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2006-11-18 17:29:32 +0800
committerdinoex <dinoex@FreeBSD.org>2006-11-18 17:29:32 +0800
commit09583bc3715dd6bd051dbe5edfec825ef2fb10bd (patch)
tree1023dcdfea4521257c358f09f02bb3a824310cdc /games
parenta2f9da5e97c49a361ac3518424012f2d4355624e (diff)
downloadfreebsd-ports-gnome-09583bc3715dd6bd051dbe5edfec825ef2fb10bd.tar.gz
freebsd-ports-gnome-09583bc3715dd6bd051dbe5edfec825ef2fb10bd.tar.zst
freebsd-ports-gnome-09583bc3715dd6bd051dbe5edfec825ef2fb10bd.zip
GRubik is a virtual 3D Rubik's cube for you to solve. It features:
- simple but functional and fast 3D - a smart scramble that ensures you get a solvable cube - interesting code that you might enjoy reading and which uses a variety of programming techniques. Left-click for clockwise, right-click for counterclockwise rotation.
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/grubik/Makefile27
-rw-r--r--games/grubik/distinfo3
-rw-r--r--games/grubik/pkg-descr8
-rw-r--r--games/grubik/pkg-plist9
5 files changed, 48 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 151fb5b914e3..065a5bc67f9c 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -289,6 +289,7 @@
SUBDIR += gridlock
SUBDIR += groundhog
SUBDIR += gru
+ SUBDIR += grubik
SUBDIR += grubinvaders
SUBDIR += gshisen
SUBDIR += gtetrinet
diff --git a/games/grubik/Makefile b/games/grubik/Makefile
new file mode 100644
index 000000000000..2d74e3f6263b
--- /dev/null
+++ b/games/grubik/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: grubik
+# Date created: 17 Nov 2006
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= grubik
+PORTVERSION= 0.1
+CATEGORIES= games
+MASTER_SITES= http://debian.uni-essen.de/misc/GNUstep/Apps/Recreational/
+DISTNAME= GRubik
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Virtual 3D Rubiks cube for GNUstep
+
+USE_GMAKE= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+MAKEFILE=
+ALL_TARGET=
+
+.include <bsd.port.mk>
diff --git a/games/grubik/distinfo b/games/grubik/distinfo
new file mode 100644
index 000000000000..cbfb4578dd97
--- /dev/null
+++ b/games/grubik/distinfo
@@ -0,0 +1,3 @@
+MD5 (GRubik.tgz) = 857b50ab5b048975ce99c148da512eb0
+SHA256 (GRubik.tgz) = dcd06939522e53b6b654acaae5aca97f82174418cb20dec178a0e3d53a375feb
+SIZE (GRubik.tgz) = 8635
diff --git a/games/grubik/pkg-descr b/games/grubik/pkg-descr
new file mode 100644
index 000000000000..d0316b2bf243
--- /dev/null
+++ b/games/grubik/pkg-descr
@@ -0,0 +1,8 @@
+GRubik is a virtual 3D Rubik's cube for you to solve. It features:
+
+- simple but functional and fast 3D
+- a smart scramble that ensures you get a solvable cube
+- interesting code that you might enjoy reading and which uses a
+variety of programming techniques.
+
+Left-click for clockwise, right-click for counterclockwise rotation.
diff --git a/games/grubik/pkg-plist b/games/grubik/pkg-plist
new file mode 100644
index 000000000000..3559066c0daf
--- /dev/null
+++ b/games/grubik/pkg-plist
@@ -0,0 +1,9 @@
+System/Applications/GRubik.app/GRubik
+System/Applications/GRubik.app/Resources/GRubik.desktop
+System/Applications/GRubik.app/Resources/Info-gnustep.plist
+System/Applications/GRubik.app/library_paths.openapp
+System/Applications/GRubik.app/stamp.make
+@dirrm System/Applications/GRubik.app/Resources
+@dirrm System/Applications/GRubik.app/%%GNU_ARCH%%/linux-gnu
+@dirrm System/Applications/GRubik.app/%%GNU_ARCH%%
+@dirrm System/Applications/GRubik.app