aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-02-05 03:32:55 +0800
committermarino <marino@FreeBSD.org>2016-02-05 03:32:55 +0800
commit1400b0c484f382c4b6cfbbb85cc3f0ca5a8d2952 (patch)
tree92a38310d9ed0d2b5b1f0892f172dce228421042 /games
parenteb42bc6f8ad541c34cd77a7fb2bb2914a02b768b (diff)
downloadfreebsd-ports-gnome-1400b0c484f382c4b6cfbbb85cc3f0ca5a8d2952.tar.gz
freebsd-ports-gnome-1400b0c484f382c4b6cfbbb85cc3f0ca5a8d2952.tar.zst
freebsd-ports-gnome-1400b0c484f382c4b6cfbbb85cc3f0ca5a8d2952.zip
games/bluemoon: document ncurses rqmt (USES+=ncurses), respect LDFLAGS
approved by: infrastructure blanket
Diffstat (limited to 'games')
-rw-r--r--games/bluemoon/Makefile2
-rw-r--r--games/bluemoon/files/patch-Makefile11
2 files changed, 12 insertions, 1 deletions
diff --git a/games/bluemoon/Makefile b/games/bluemoon/Makefile
index 1a350af3fef1..d52cfaf17881 100644
--- a/games/bluemoon/Makefile
+++ b/games/bluemoon/Makefile
@@ -11,7 +11,7 @@ COMMENT= Blue Moon card solitaire
LICENSE= BSD3CLAUSE
-USES= gmake
+USES= gmake ncurses
ALL_TARGET= ${PORTNAME}
PLIST_FILES= bin/${PORTNAME} \
diff --git a/games/bluemoon/files/patch-Makefile b/games/bluemoon/files/patch-Makefile
new file mode 100644
index 000000000000..1d683f9c74d1
--- /dev/null
+++ b/games/bluemoon/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2014-05-21 12:29:36 UTC
++++ Makefile
+@@ -6,7 +6,7 @@ SOURCES = README COPYING NEWS Makefile c
+ CFLAGS=-O
+
+ bluemoon: bluemoon.c
+- cc $(CFLAGS) -DRELEASE=\"$(VERS)\" bluemoon.c -lncurses -o bluemoon
++ $(CC) $(CFLAGS) -DRELEASE=\"$(VERS)\" bluemoon.c $(LDFLAGS) -lncurses -o bluemoon
+
+ bluemoon.6: bluemoon.xml
+ xmlto man bluemoon.xml