aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-05-05 17:45:36 +0800
committerbapt <bapt@FreeBSD.org>2014-05-05 17:45:36 +0800
commit1fa39fd2c3d6f5edbc6d4a9d6f9ceae142a0f184 (patch)
tree96cc94ba02edcc043c52eb3f26adbc632bbe44d8 /games
parentd8575795a2106dcbddc552f756cb3916f113f9e0 (diff)
downloadfreebsd-ports-gnome-1fa39fd2c3d6f5edbc6d4a9d6f9ceae142a0f184.tar.gz
freebsd-ports-gnome-1fa39fd2c3d6f5edbc6d4a9d6f9ceae142a0f184.tar.zst
freebsd-ports-gnome-1fa39fd2c3d6f5edbc6d4a9d6f9ceae142a0f184.zip
Convert all :U to :tu and :L to :tl
Since FreeBSD 8.4 and FreeBSD 9.1 make(1) do support :tu and :tl as a replacement for :U and :L (which has been marked as deprecated) bmake which is the default on FreeBSD 10+ only support by default :tu/:tl a hack has been added at the time to support :U and :L to ease migration. This hack is now not necessary anymore Note that this makes the ports tree incompatible with make(1) from FreeBSD 8.3 or earlier With hat: portmgr
Diffstat (limited to 'games')
-rw-r--r--games/ftjava/Makefile2
-rw-r--r--games/ioquake3/Makefile2
-rw-r--r--games/linux-unrealgold/Makefile2
-rw-r--r--games/lwjgl/Makefile2
-rw-r--r--games/mtaserver/Makefile2
-rw-r--r--games/pmars/Makefile2
-rw-r--r--games/q2p/Makefile2
-rw-r--r--games/quake-reaper/Makefile4
-rw-r--r--games/quake2-3zb2/Makefile2
-rw-r--r--games/quake2-source/Makefile6
-rw-r--r--games/qudos/Makefile6
-rw-r--r--games/ri-li/Makefile2
-rw-r--r--games/rtb/Makefile4
-rw-r--r--games/searchandrescue/Makefile4
-rw-r--r--games/slashem-tty/Makefile2
-rw-r--r--games/tuxpaint-fonts/Makefile33
-rw-r--r--games/xevil/Makefile2
17 files changed, 38 insertions, 41 deletions
diff --git a/games/ftjava/Makefile b/games/ftjava/Makefile
index b090f057704c..5d358334871b 100644
--- a/games/ftjava/Makefile
+++ b/games/ftjava/Makefile
@@ -44,7 +44,7 @@ do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
cd ${WRKSRC} && ${FIND} ${DATAFILES} -type d -exec ${MKDIR} ${STAGEDIR}${DATADIR}/{} ";"
cd ${WRKSRC} && ${FIND} ${DATAFILES} -type f -exec ${INSTALL_DATA} {} ${STAGEDIR}${DATADIR}/{} ";"
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${STAGEDIR}${PREFIX}/bin/${PORTNAME:L}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${STAGEDIR}${PREFIX}/bin/${PORTNAME:tl}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for doc in ${PORTDOCS}
${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/${doc} ${STAGEDIR}${DOCSDIR}
diff --git a/games/ioquake3/Makefile b/games/ioquake3/Makefile
index 86faf15096a0..d147fd051973 100644
--- a/games/ioquake3/Makefile
+++ b/games/ioquake3/Makefile
@@ -62,7 +62,7 @@ ALL_TARGET= release
LIBDIR= lib/${PORTNAME}${PKGNAMESUFFIX}
DOCSDIR= share/doc/${PORTNAME}${PKGNAMESUFFIX}
-BUILDDIR= ${WRKSRC}/build/${ALL_TARGET}-${OPSYS:L}-${IOQ3ARCH}
+BUILDDIR= ${WRKSRC}/build/${ALL_TARGET}-${OPSYS:tl}-${IOQ3ARCH}
BINSUFFIX?=
HOMEPATH?= /.${PORTNAME}
Q3CLIENT?= ioquake3
diff --git a/games/linux-unrealgold/Makefile b/games/linux-unrealgold/Makefile
index f10cb4470023..b7126d0e62a6 100644
--- a/games/linux-unrealgold/Makefile
+++ b/games/linux-unrealgold/Makefile
@@ -105,7 +105,7 @@ do-extract:
# Original CD
.elif defined(ORIGINAL)
.for dir in ${CDDIRS:NSystem:NMaps/UPak:NSounds/int} Manuals
- @${LN} -sf ${CDROM_MOUNT}/${dir:U} ${WRKDIR}/source/${dir}
+ @${LN} -sf ${CDROM_MOUNT}/${dir:tu} ${WRKDIR}/source/${dir}
.endfor
.for _file in UDSDemo.u UPak.u
@${CP} ${CDROM_MOUNT}/SYSTEM/${_file} ${WRKDIR}/source/System
diff --git a/games/lwjgl/Makefile b/games/lwjgl/Makefile
index d4412e6bc9e8..b38e9271116f 100644
--- a/games/lwjgl/Makefile
+++ b/games/lwjgl/Makefile
@@ -4,7 +4,7 @@
PORTNAME= lwjgl
DISTVERSION= 2.9.1
CATEGORIES= games java
-MASTER_SITES= SF/java-game-lib/Official%20Releases/${PORTNAME:U}%20${PORTVERSION}/
+MASTER_SITES= SF/java-game-lib/Official%20Releases/${PORTNAME:tu}%20${PORTVERSION}/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
${PORTNAME}-source-${DISTVERSION}${EXTRACT_SUFX}
diff --git a/games/mtaserver/Makefile b/games/mtaserver/Makefile
index 14dd9ea08d28..dd8412759bc7 100644
--- a/games/mtaserver/Makefile
+++ b/games/mtaserver/Makefile
@@ -1,7 +1,7 @@
# Created by: Alexander Logvinov <ports@logvinov.com>
# $FreeBSD$
-PORTNAME= ${MTANAME:L}
+PORTNAME= ${MTANAME:tl}
PORTVERSION= 0.5
PORTREVISION= 2
CATEGORIES= games linux
diff --git a/games/pmars/Makefile b/games/pmars/Makefile
index 79f14362aaa1..213c2ff93164 100644
--- a/games/pmars/Makefile
+++ b/games/pmars/Makefile
@@ -55,7 +55,7 @@ X11_ARGS+= CFLAGS+="-DXWINGRAPHX" \
do-build:
.for f in ${TARGETS}
- @(cd ${BUILD_WRKSRC}; ${MAKE} ${MAKE_ARGS} ${${f:U}_ARGS} \
+ @(cd ${BUILD_WRKSRC}; ${MAKE} ${MAKE_ARGS} ${${f:tu}_ARGS} \
${ALL_TARGET} clean)
@(cd ${BUILD_WRKSRC}; ${MV} ${PORTNAME} ${PORTNAME}-${f})
.endfor
diff --git a/games/q2p/Makefile b/games/q2p/Makefile
index 0521d1b8a705..5e55fed72c7b 100644
--- a/games/q2p/Makefile
+++ b/games/q2p/Makefile
@@ -82,7 +82,7 @@ PLIST_SUB+= GAME="@comment "
. if ${PORT_OPTIONS:M${opt}}
MAKE_ENV+= BUILD_${opt}=YES
PLIST_SUB+= ${opt}=""
-Q2REF+= ${opt:L:S/glx/gl/:S/sdlgl/sdl/}
+Q2REF+= ${opt:tl:S/glx/gl/:S/sdlgl/sdl/}
. else
PLIST_SUB+= ${opt}="@comment "
. endif
diff --git a/games/quake-reaper/Makefile b/games/quake-reaper/Makefile
index 14c05bb5f9df..5456c5368e98 100644
--- a/games/quake-reaper/Makefile
+++ b/games/quake-reaper/Makefile
@@ -24,11 +24,11 @@ OPTIONS_DEFINE= DOCS
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
.for f in Autoexec.cfg PROGS.DAT
- ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DATADIR}/${f:L}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DATADIR}/${f:tl}
.endfor
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in B08chg.txt Dedserv.txt Reaprb80.txt Skinspec.txt
- ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/${f:L}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/${f:tl}
.endfor
.include "${.CURDIR}/../quake-data/Makefile.include"
diff --git a/games/quake2-3zb2/Makefile b/games/quake2-3zb2/Makefile
index 9a67616dff4a..2c3b42d5cef0 100644
--- a/games/quake2-3zb2/Makefile
+++ b/games/quake2-3zb2/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= games
MASTER_SITES= http://www.angelfire.com/mt2/quakebots/:prog \
http://ponpoko.tri6.net/3zb2/routes/:routes
PKGNAMEPREFIX= ${Q2PKGNAMEPREFIX}
-DISTNAME= ${PORTNAME:U}
+DISTNAME= ${PORTNAME:tu}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:prog \
${PORTNAME}src${PORTVERSION:S/0.//}${EXTRACT_SUFX}:prog
DIST_SUBDIR= ${PKGNAMEPREFIX}${PORTNAME}
diff --git a/games/quake2-source/Makefile b/games/quake2-source/Makefile
index 0ea9ce2b92d7..94b0d4460093 100644
--- a/games/quake2-source/Makefile
+++ b/games/quake2-source/Makefile
@@ -57,12 +57,12 @@ PLIST_SUB+= XATRIX="@comment "
post-extract:
.for f in rogue xatrix
-. if ${PORT_OPTIONS:M${f:U}}
+. if ${PORT_OPTIONS:M${f:tu}}
@${MKDIR} ${WRKSRC}/src/${f}
@(cd ${WRKSRC}/src/${f} && ${GUNZIP_CMD} -c \
${DISTDIR}/${DIST_SUBDIR}/${f}src320.shar.Z > \
${f}src320.shar && \
- ${TAIL} +${${f:U}_OFF} ${f}src320.shar | ${SH})
+ ${TAIL} +${${f:tu}_OFF} ${f}src320.shar | ${SH})
. endif
.endfor
@@ -76,7 +76,7 @@ do-install:
${CP} -R ${WRKSRC}/src/game ${DATADIR}
${INSTALL_DATA} ${FILESDIR}/Makefile.game ${DATADIR}/game/Makefile
.for f in ctf rogue xatrix
-. if ${PORT_OPTIONS:M${f:U}}
+. if ${PORT_OPTIONS:M${f:tu}}
${CP} -R ${WRKSRC}/src/${f} ${DATADIR}
${INSTALL_DATA} ${FILESDIR}/Makefile.${f} ${DATADIR}/${f}/Makefile
. endif
diff --git a/games/qudos/Makefile b/games/qudos/Makefile
index d11ae7eca1f2..fad594fda879 100644
--- a/games/qudos/Makefile
+++ b/games/qudos/Makefile
@@ -114,7 +114,7 @@ MAKE_ENV+= WITH_GAME_MOD=NO
. if ${PORT_OPTIONS:M${opt}}
MAKE_ENV+= BUILD_${opt}=YES
PLIST_SUB+= ${opt}=""
-Q2REF+= ${opt:L}
+Q2REF+= ${opt:tl}
. else
MAKE_ENV+= BUILD_${opt}=NO
PLIST_SUB+= ${opt}="@comment "
@@ -199,8 +199,8 @@ do-install:
.if ${PORT_OPTIONS:MGAME}
${INSTALL_PROGRAM} ${WRKSRC}/quake2/baseq2/game.so ${LIBDIR}/baseq2
.endif
-.for mod in ${MOD_LIST:L}
-.if ${PORT_OPTIONS:M${mod:U}}
+.for mod in ${MOD_LIST:tl}
+.if ${PORT_OPTIONS:M${mod:tu}}
@${MKDIR} ${LIBDIR}/${mod}
${INSTALL_PROGRAM} ${WRKSRC}/quake2/${mod}/game.so ${LIBDIR}/${mod}
.endif
diff --git a/games/ri-li/Makefile b/games/ri-li/Makefile
index e6c5e513a4dc..4e3936fab8b5 100644
--- a/games/ri-li/Makefile
+++ b/games/ri-li/Makefile
@@ -5,7 +5,7 @@ PORTNAME= Ri-li
PORTVERSION= 2.0.1
PORTREVISION= 5
CATEGORIES= games
-MASTER_SITES= SF/${PORTNAME:L}/${PORTNAME}%20Linux_Unix/${PORTNAME}%20V${PORTVERSION}
+MASTER_SITES= SF/${PORTNAME:tl}/${PORTNAME}%20Linux_Unix/${PORTNAME}%20V${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Drive a toy wood train in many levels - snake-like arcade game
diff --git a/games/rtb/Makefile b/games/rtb/Makefile
index 49aad9ad89be..eac78168b4e9 100644
--- a/games/rtb/Makefile
+++ b/games/rtb/Makefile
@@ -6,7 +6,7 @@ PORTVERSION= 1.0.8
DISTVERSIONSUFFIX= -Ext
PORTREVISION= 10
CATEGORIES= games
-MASTER_SITES= SF/${PORTNAME:L}/${PORTNAME}-1.0.x/${PORTNAME}%20${PORTVERSION}
+MASTER_SITES= SF/${PORTNAME:tl}/${PORTNAME}-1.0.x/${PORTNAME}%20${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Robot programming game for UNIX
@@ -27,7 +27,7 @@ CONFIGURE_ARGS= --with-rtb-dir=${PREFIX}/lib/${PORTNAME}
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-DESKTOP_ENTRIES="${PORTNAME}" "" "" "${PORTNAME:L}" "" ""
+DESKTOP_ENTRIES="${PORTNAME}" "" "" "${PORTNAME:tl}" "" ""
post-patch:
.for i in configure
diff --git a/games/searchandrescue/Makefile b/games/searchandrescue/Makefile
index f6e4c94c1a98..a8e58f40688b 100644
--- a/games/searchandrescue/Makefile
+++ b/games/searchandrescue/Makefile
@@ -5,7 +5,7 @@ PORTNAME= SearchAndRescue
PORTVERSION= 1.4.0
PORTREVISION= 3
CATEGORIES= games
-MASTER_SITES= SF/${PORTNAME:L}/Program/
+MASTER_SITES= SF/${PORTNAME:tl}/Program/
MAINTAINER= jessefrgsmith@yahoo.ca
COMMENT= A flight simulator in which the player rescues people
@@ -15,7 +15,7 @@ RUN_DEPENDS= ${LOCALBASE}/share/searchandrescue/human.ini:${PORTSDIR}/games/sear
USE_SDL= mixer
USE_XORG= x11 xau xdmcp xext xmu xpm xxf86vm
USE_GL= glu
-WRKSRC= ${WRKDIR}/${PORTNAME:L}_${PORTVERSION}
+WRKSRC= ${WRKDIR}/${PORTNAME:tl}_${PORTVERSION}
PLIST_FILES= bin/${PORTNAME} \
${DESKTOPDIR:S,${PREFIX}/,,}/${PORTNAME}.desktop \
diff --git a/games/slashem-tty/Makefile b/games/slashem-tty/Makefile
index 7bc403d95466..f786b673cf51 100644
--- a/games/slashem-tty/Makefile
+++ b/games/slashem-tty/Makefile
@@ -6,7 +6,7 @@ PORTVERSION= 0.0.7E.7F.3
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-source/0.0.7E7F3
PKGNAMESUFFIX= -tty
-DISTNAME= se${PORTVERSION:S/.//g:L}
+DISTNAME= se${PORTVERSION:S/.//g:tl}
MAINTAINER= glewis@FreeBSD.org
COMMENT= A dungeon explorin', slashin', hackin' game
diff --git a/games/tuxpaint-fonts/Makefile b/games/tuxpaint-fonts/Makefile
index a08d0ef51d00..4a448d85cf93 100644
--- a/games/tuxpaint-fonts/Makefile
+++ b/games/tuxpaint-fonts/Makefile
@@ -29,19 +29,16 @@ CHINESE_SIMPLIFIED_CODE= zh_cn
KOREAN_CODE= ko
VIETNAMESE_CODE= vi
-#Bmake compatibility
-.MAKE.FreeBSD_UL= yes
-
# Generate options menu.
.for l in ${LANGS}
-OPTIONS_DEFINE+= ${l:U}
-OPTIONS_DEFAULT+= ${l:U}
-${l:U}_DESC= ${l:S/_/ /} fonts
+OPTIONS_DEFINE+= ${l:tu}
+OPTIONS_DEFAULT+= ${l:tu}
+${l:tu}_DESC= ${l:S/_/ /} fonts
.endfor
# Set MASTER_SITES
.for l in ${LANGS}
-MASTER_SITES+= SF/${PORTNAME}/${PORTNAME}-fonts/${${l:U}_DISTNAME}:${l:U}
+MASTER_SITES+= SF/${PORTNAME}/${PORTNAME}-fonts/${${l:tu}_DISTNAME}:${l:tu}
.endfor
# Do not use the same OPTIONS directory as "games/tuxpaint".
@@ -51,12 +48,12 @@ LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
# Set DISTFILES and PLIST_FILES according to OPTIONS.
.for l in ${LANGS}
-. if ${PORT_OPTIONS:M${l:U}}
-DISTFILES+= ${PORTNAME}-ttf-${${l:U}_DISTNAME}${EXTRACT_SUFX}:${l:U}
-PLIST_FILES+= %%DATADIR%%/fonts/locale/${${l:U}_CODE}.ttf
-PLIST_FILES+= %%DATADIR%%/fonts/locale/${${l:U}_CODE}_docs/COPYING.txt
-PLIST_FILES+= %%DATADIR%%/fonts/locale/${${l:U}_CODE}_docs/README.txt
-PLIST_DIRS+= %%DATADIR%%/fonts/locale/${${l:U}_CODE}_docs
+. if ${PORT_OPTIONS:M${l:tu}}
+DISTFILES+= ${PORTNAME}-ttf-${${l:tu}_DISTNAME}${EXTRACT_SUFX}:${l:tu}
+PLIST_FILES+= %%DATADIR%%/fonts/locale/${${l:tu}_CODE}.ttf
+PLIST_FILES+= %%DATADIR%%/fonts/locale/${${l:tu}_CODE}_docs/COPYING.txt
+PLIST_FILES+= %%DATADIR%%/fonts/locale/${${l:tu}_CODE}_docs/README.txt
+PLIST_DIRS+= %%DATADIR%%/fonts/locale/${${l:tu}_CODE}_docs
. endif
.endfor
@@ -64,14 +61,14 @@ PLIST_DIRS+= %%DATADIR%%/fonts/locale/${${l:U}_CODE}_docs
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}/fonts/locale
.for l in ${LANGS}
-. if ${PORT_OPTIONS:M${l:U}}
+. if ${PORT_OPTIONS:M${l:tu}}
${INSTALL_DATA} \
- ${WRKSRC}/${PORTNAME}-ttf-${${l:U}_DISTNAME}/${${l:U}_CODE}.ttf \
+ ${WRKSRC}/${PORTNAME}-ttf-${${l:tu}_DISTNAME}/${${l:tu}_CODE}.ttf \
${STAGEDIR}${DATADIR}/fonts/locale
- @${MKDIR} ${STAGEDIR}${DATADIR}/fonts/locale/${${l:U}_CODE}_docs
+ @${MKDIR} ${STAGEDIR}${DATADIR}/fonts/locale/${${l:tu}_CODE}_docs
${INSTALL_DATA} \
- ${WRKSRC}/${PORTNAME}-ttf-${${l:U}_DISTNAME}/*.txt \
- ${STAGEDIR}${DATADIR}/fonts/locale/${${l:U}_CODE}_docs
+ ${WRKSRC}/${PORTNAME}-ttf-${${l:tu}_DISTNAME}/*.txt \
+ ${STAGEDIR}${DATADIR}/fonts/locale/${${l:tu}_CODE}_docs
. endif
.endfor
diff --git a/games/xevil/Makefile b/games/xevil/Makefile
index 3bb74cb7b247..a71f643c6db1 100644
--- a/games/xevil/Makefile
+++ b/games/xevil/Makefile
@@ -23,7 +23,7 @@ USE_XORG= xpm
DOS2UNIX_GLOB= *.cpp *.h config.mk makefile
MAKEFILE= makefile
MAKE_ARGS= DEPTH="${WRKSRC}"
-ALL_TARGET= ${OPSYS:L}
+ALL_TARGET= ${OPSYS:tl}
PORTDOCS= *
PLIST_FILES= bin/${PORTNAME}