aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorphilip <philip@FreeBSD.org>2009-03-25 00:31:07 +0800
committerphilip <philip@FreeBSD.org>2009-03-25 00:31:07 +0800
commit20e74b1a9d246f6d1f63b6d594ac6f31fac2889d (patch)
tree15e4a142646a170f98a4acfa9b4df2fba0742b5f /games
parentd97a6dd467cbbd2d50f4576541960b78e1c37101 (diff)
downloadfreebsd-ports-gnome-20e74b1a9d246f6d1f63b6d594ac6f31fac2889d.tar.gz
freebsd-ports-gnome-20e74b1a9d246f6d1f63b6d594ac6f31fac2889d.tar.zst
freebsd-ports-gnome-20e74b1a9d246f6d1f63b6d594ac6f31fac2889d.zip
Replace the "-wholename" find(1) GNUism with the standard "-path" incantation.
This fixes installation on RELENG_7. Spotted by: QAT
Diffstat (limited to 'games')
-rw-r--r--games/wesnoth-devel/files/patch-Makefile.in22
-rw-r--r--games/wesnoth-devel/files/patch-src-Makefile.in11
2 files changed, 22 insertions, 11 deletions
diff --git a/games/wesnoth-devel/files/patch-Makefile.in b/games/wesnoth-devel/files/patch-Makefile.in
index 13f43fc9c441..67524d8aeb8b 100644
--- a/games/wesnoth-devel/files/patch-Makefile.in
+++ b/games/wesnoth-devel/files/patch-Makefile.in
@@ -1,11 +1,11 @@
---- src/Makefile.in.orig 2008-11-02 19:33:40.000000000 +0100
-+++ src/Makefile.in 2008-11-02 19:33:49.000000000 +0100
-@@ -1783,7 +1783,7 @@
- game_config.o: revision.hpp
- .PRECIOUS: revision.hpp
- revision.hpp: FORCE
-- if [ "$(REVISION)" == "" ] || [ "$(REVISION)" == "exported" ]; then echo '' >/tmp/westemp$$$$; \
-+ if [ "$(REVISION)" = "" ] || [ "$(REVISION)" = "exported" ]; then echo '' >/tmp/westemp$$$$; \
- else echo '#define REVISION "$(REVISION)"' >/tmp/westemp$$$$; fi;\
- if cmp -s revision.hpp /tmp/westemp$$$$ 2>/dev/null; then :; else cp /tmp/westemp$$$$ revision.hpp; fi; \
- if [ -e /tmp/westemp$$$$ ]; then rm /tmp/westemp$$$$; fi
+--- Makefile.in.orig 2009-03-24 16:52:32.000000000 +0100
++++ Makefile.in 2009-03-24 16:52:43.000000000 +0100
+@@ -279,7 +279,7 @@
+ bin_SCRIPTS =
+
+ # Ignore junk -- object files, editor backup files, wmllint backup files.
+-findfilterflags = ! \( -name .svn -prune -o -name ".\#*" -o -name "*~" -o -name "*bak" -o -name 'Makefile' -o -name '*Makefile' -o -type d -o -wholename "data/test/*" \)
++findfilterflags = ! \( -name .svn -prune -o -name ".\#*" -o -name "*~" -o -name "*bak" -o -name 'Makefile' -o -name '*Makefile' -o -type d -o -path "data/test/*" \)
+
+ # List all datafiles, ignoring junk
+ finddata = (cd $(top_srcdir) && find data fonts icons images sounds $(findfilterflags) -print )
diff --git a/games/wesnoth-devel/files/patch-src-Makefile.in b/games/wesnoth-devel/files/patch-src-Makefile.in
new file mode 100644
index 000000000000..13f43fc9c441
--- /dev/null
+++ b/games/wesnoth-devel/files/patch-src-Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig 2008-11-02 19:33:40.000000000 +0100
++++ src/Makefile.in 2008-11-02 19:33:49.000000000 +0100
+@@ -1783,7 +1783,7 @@
+ game_config.o: revision.hpp
+ .PRECIOUS: revision.hpp
+ revision.hpp: FORCE
+- if [ "$(REVISION)" == "" ] || [ "$(REVISION)" == "exported" ]; then echo '' >/tmp/westemp$$$$; \
++ if [ "$(REVISION)" = "" ] || [ "$(REVISION)" = "exported" ]; then echo '' >/tmp/westemp$$$$; \
+ else echo '#define REVISION "$(REVISION)"' >/tmp/westemp$$$$; fi;\
+ if cmp -s revision.hpp /tmp/westemp$$$$ 2>/dev/null; then :; else cp /tmp/westemp$$$$ revision.hpp; fi; \
+ if [ -e /tmp/westemp$$$$ ]; then rm /tmp/westemp$$$$; fi