aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2013-10-17 09:58:08 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2013-10-17 09:58:08 +0800
commit27b6b7a1eb0a2205e29fc40c8730385e082f721f (patch)
tree8da54e0a4e24979603c79f855bf365c7b049e933 /games
parentd010a33fdf68ad8b965729a9d15113dc47f78003 (diff)
downloadfreebsd-ports-gnome-27b6b7a1eb0a2205e29fc40c8730385e082f721f.tar.gz
freebsd-ports-gnome-27b6b7a1eb0a2205e29fc40c8730385e082f721f.tar.zst
freebsd-ports-gnome-27b6b7a1eb0a2205e29fc40c8730385e082f721f.zip
- Support staging
- Convert USE_GMAKE to USES
Diffstat (limited to 'games')
-rw-r--r--games/redeclipse/Makefile51
1 files changed, 21 insertions, 30 deletions
diff --git a/games/redeclipse/Makefile b/games/redeclipse/Makefile
index 76162741b871..c0a5c7510e0b 100644
--- a/games/redeclipse/Makefile
+++ b/games/redeclipse/Makefile
@@ -15,18 +15,19 @@ LICENSE= MIT ZLIB
MANUAL_PACKAGE_BUILD= huge
-USE_GMAKE= yes
+USES= gmake
GNU_CONFIGURE= yes
USE_BZIP2= yes
CONFIGURE_WRKSRC= ${WRKSRC}/src/enet
CONFIGURE_ARGS= --enable-shared=no --enable-static=yes
-USE_AUTOTOOLS= aclocal:env automake:env autoconf:env
+USE_AUTOTOOLS= aclocal automake autoconf:env
+AUTOMAKE_ARGS= -ia
BUILD_WRKSRC= ${WRKSRC}/src
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
ALL_TARGET= libenet
-SUB_FILES= redeclipse redeclipse_server
+SUB_FILES= ${PORTNAME} ${PORTNAME}_server
PORTDATA= *
PORTDOCS= *
@@ -34,11 +35,11 @@ PORTDOCS= *
OPTIONS_DEFINE= OPTIMIZED_CFLAGS DOCS
OPTIONS_MULTI= COMPONENTS
OPTIONS_MULTI_COMPONENTS=CLIENT DEDICATED
-OPTIONS_DEFAULT=CLIENT DEDICATED OPTIMIZED_CFLAGS
+OPTIONS_DEFAULT=CLIENT DEDICATED OPTIMIZED_CFLAGS DOCS
+
CLIENT_DESC= Build client
DEDICATED_DESC= Build dedicated server
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${ARCH} == "sparc64"
@@ -48,21 +49,21 @@ BROKEN= does not build on sparc64
.if ${PORT_OPTIONS:MCLIENT}
USE_GL= yes
USE_SDL= image mixer sdl
-PLIST_FILES+= bin/redeclipse libexec/redeclipse share/pixmaps/redeclipse.ico
-BINARIES+= redeclipse
+PLIST_FILES+= bin/${PORTNAME} libexec/${PORTNAME} share/pixmaps/${PORTNAME}.ico
+BINARIES+= ${PORTNAME}
ALL_TARGET+= client
DESKTOP_ENTRIES="Red Eclipse" \
"${COMMENT}" \
- "${PREFIX}/share/pixmaps/redeclipse.ico" \
- "redeclipse" \
- "Game;" \
- false
+ "${PREFIX}/share/pixmaps/${PORTNAME}.ico" \
+ "${PORTNAME}" \
+ "Game;Shooter;" \
+ ""
.endif
.if ${PORT_OPTIONS:MDEDICATED}
-PLIST_FILES+= bin/redeclipse_server libexec/redeclipse_server
-BINARIES+= redeclipse_server
+PLIST_FILES+= bin/${PORTNAME}_server libexec/${PORTNAME}_server
+BINARIES+= ${PORTNAME}_server
ALL_TARGET+= server
.endif
@@ -73,25 +74,15 @@ CXXFLAGS+= -O3 -fomit-frame-pointer
do-install:
.for f in ${BINARIES}
- ${INSTALL_SCRIPT} ${WRKDIR}/${f} ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${f} ${PREFIX}/libexec
+ ${INSTALL_SCRIPT} ${WRKDIR}/${f} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${f} ${STAGEDIR}${PREFIX}/libexec
.endfor
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- cd ${WRKSRC}/doc && ${COPYTREE_SHARE} "*" ${DOCSDIR}/
-.endif
-.if !defined(NOPORTDATA)
- ${MKDIR} ${DATADIR}
- cd ${WRKSRC} && ${COPYTREE_SHARE} "game data" ${DATADIR}/
-.endif
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/doc && ${COPYTREE_SHARE} "*" ${STAGEDIR}${DOCSDIR}/
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} "game data" ${STAGEDIR}${DATADIR}/
.if ${PORT_OPTIONS:MCLIENT}
- ${INSTALL_DATA} ${WRKSRC}/src/redeclipse.ico ${PREFIX}/share/pixmaps/
+ ${INSTALL_DATA} ${WRKSRC}/src/${PORTNAME}.ico ${STAGEDIR}${PREFIX}/share/pixmaps/
.endif
-#post-install:
-# @${FIND} ${DATADIR} -type f | \
-# ${SED} -e 's|^${PREFIX}/||' >> ${TMPPLIST}
-# @${FIND} ${DATADIR} -type d | ${SORT} -r | \
-# ${SED} -e 's|^${PREFIX}/|@dirrm |' >> ${TMPPLIST}
-
.include <bsd.port.mk>