aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-04-23 18:47:02 +0800
committerbapt <bapt@FreeBSD.org>2013-04-23 18:47:02 +0800
commit2a3dfed77d0c78197d3799bd80dbb353ede6f7c9 (patch)
tree26ae2cdd62e364d83407c01fd1f34e1314ccafc3 /games
parent55dc7d6797d7a58c80a2195a08875ccef91992f2 (diff)
downloadfreebsd-ports-gnome-2a3dfed77d0c78197d3799bd80dbb353ede6f7c9.tar.gz
freebsd-ports-gnome-2a3dfed77d0c78197d3799bd80dbb353ede6f7c9.tar.zst
freebsd-ports-gnome-2a3dfed77d0c78197d3799bd80dbb353ede6f7c9.zip
Convert g* to USES=pkgconfig
Diffstat (limited to 'games')
-rw-r--r--games/alienarena/Makefile12
-rw-r--r--games/epiar/Makefile2
-rw-r--r--games/gretools/Makefile3
-rw-r--r--games/gtkevemon/Makefile2
-rw-r--r--games/ioquake3/Makefile8
-rw-r--r--games/klavaro/Makefile2
-rw-r--r--games/lianliankan/Makefile2
-rw-r--r--games/libfov/Makefile3
-rw-r--r--games/nlarn/Makefile2
-rw-r--r--games/poker-engine/Makefile2
-rw-r--r--games/poker-eval/Makefile9
-rw-r--r--games/py-fife/Makefile2
-rw-r--r--games/py-poker-eval/Makefile9
-rw-r--r--games/stonesoup/Makefile3
-rw-r--r--games/super_methane_brothers/Makefile2
-rw-r--r--games/thegrind/Makefile8
-rw-r--r--games/ultimatestunts/Makefile2
17 files changed, 24 insertions, 49 deletions
diff --git a/games/alienarena/Makefile b/games/alienarena/Makefile
index c70780c53379..30da704ebbad 100644
--- a/games/alienarena/Makefile
+++ b/games/alienarena/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: alienarena
-# Date created: 11 May 2006
-# Whom: alepulver
-#
+# Created by: alepulver
# $FreeBSD$
-#
PORTNAME= alienarena
PORTVERSION= 2011.753
@@ -47,10 +43,10 @@ PLIST_SUB= LIBDIR=${LIBDIR:S/${PREFIX}\///}
LIBDIR= ${PREFIX}/lib/${PORTNAME}
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if defined(WITH_CLIENT)
-USE_PKGCONFIG= yes
+USES+= pkgconfig
LIB_DEPENDS+= curl.6:${PORTSDIR}/ftp/curl \
freetype.9:${PORTSDIR}/print/freetype2 \
jpeg.11:${PORTSDIR}/graphics/jpeg \
@@ -107,4 +103,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO_CMD}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/epiar/Makefile b/games/epiar/Makefile
index d332f7df2b8c..89723d644441 100644
--- a/games/epiar/Makefile
+++ b/games/epiar/Makefile
@@ -21,13 +21,13 @@ LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2 \
xml2:${PORTSDIR}/textproc/libxml2 \
physfs:${PORTSDIR}/devel/physfs
+USES= pkgconfig
USE_BZIP2= yes
USE_SDL= image mixer sdl
USE_GL= glu
GNU_CONFIGURE= yes
USE_AUTOTOOLS= aclocal
USE_GMAKE= yes
-USE_PKGCONFIG= build
MAKE_JOBS_SAFE= yes
PORTDOCS= AUTHORS ChangeLog README
diff --git a/games/gretools/Makefile b/games/gretools/Makefile
index c84adb8c4205..64d21a3ee66b 100644
--- a/games/gretools/Makefile
+++ b/games/gretools/Makefile
@@ -13,12 +13,11 @@ COMMENT= GNOME vocabulary builder
LICENSE= GPLv2
-USES= pathfix
+USES= pathfix pkgconfig
USE_GNOME= gnomeprefix pygnome2
USE_PYTHON= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_PKGCONFIG= build
INSTALLS_OMF= yes
post-patch:
diff --git a/games/gtkevemon/Makefile b/games/gtkevemon/Makefile
index 43b488129caf..d5e68b0bf105 100644
--- a/games/gtkevemon/Makefile
+++ b/games/gtkevemon/Makefile
@@ -15,9 +15,9 @@ FETCH_ARGS= -pRr
CHANGESET= 8fa5c0b5f16b
WRKSRC= ${WRKDIR}/BattleClinic-${PORTNAME}-${CHANGESET}/${PORTNAME}
+USES= pkgconfig:both
USE_GNOME= gtk20 libxml2
USE_GMAKE= yes
-USE_PKGCONFIG= both
USE_OPENSSL= yes
.include <bsd.port.pre.mk>
diff --git a/games/ioquake3/Makefile b/games/ioquake3/Makefile
index 255b075b8b6f..48984fc08f57 100644
--- a/games/ioquake3/Makefile
+++ b/games/ioquake3/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ioquake3
-# Date created: 3 Jun 2006
-# Whom: alepulver
-#
+# Created by: alepulver
# $FreeBSD$
-#
PORTNAME?= ioquake3
DISTVERSION?= 1.36
@@ -16,8 +12,8 @@ EXTRACT_SUFX?= .zip
MAINTAINER?= kamikaze@bsdforen.de
COMMENT?= Cleaned-up and enhanced version of Quake 3
+USES= pkgconfig
USE_GMAKE= yes
-USE_PKGCONFIG= yes
.if defined(PKGNAMESUFFIX) && ${PKGNAMESUFFIX:M*-server}
# Server config
diff --git a/games/klavaro/Makefile b/games/klavaro/Makefile
index e8ec3b854e74..5fb726f4728a 100644
--- a/games/klavaro/Makefile
+++ b/games/klavaro/Makefile
@@ -22,9 +22,9 @@ LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
gtkdatabox:${PORTSDIR}/x11-toolkits/gtkdatabox \
xcb:${PORTSDIR}/x11/libxcb
+USES= pkgconfig
USE_BZIP2= yes
USE_GMAKE= yes
-USE_PKGCONFIG= build
USE_GETTEXT= yes
USE_ICONV= yes
USE_XORG= pixman x11 xau xcomposite xcursor xdamage xdmcp xext \
diff --git a/games/lianliankan/Makefile b/games/lianliankan/Makefile
index bf77f7a0cdf7..54febc406972 100644
--- a/games/lianliankan/Makefile
+++ b/games/lianliankan/Makefile
@@ -13,7 +13,7 @@ COMMENT= Tile matching game
LICENSE= GPLv2
-USE_PKGCONFIG= build
+USES= pkgconfig
USE_GNOME= gtk20 esound
USE_AUTOTOOLS= aclocal automake autoconf libtool
MAKE_JOBS_SAFE= yes
diff --git a/games/libfov/Makefile b/games/libfov/Makefile
index 2ddc9f75300d..edad7fce052e 100644
--- a/games/libfov/Makefile
+++ b/games/libfov/Makefile
@@ -12,9 +12,8 @@ COMMENT= C library for calculating fields of view on low resolution rasters
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= pathfix
+USES= pathfix pkgconfig
USE_AUTOTOOLS= libtool
-USE_PKGCONFIG= yes
CONFIGURE_ENV= ac_cv_prog_doxygen=no ac_cv_path_SDL_CONFIG=no
USE_LDCONFIG= yes
diff --git a/games/nlarn/Makefile b/games/nlarn/Makefile
index cf258e5d112f..fcf353cb70ca 100644
--- a/games/nlarn/Makefile
+++ b/games/nlarn/Makefile
@@ -11,9 +11,9 @@ COMMENT= Roguelike game and as such a remake of the classic game Larn
LICENSE= GPLv3
+USES= pkgconfig
USE_LUA= 5.1
USE_GNOME= glib20
-USE_PKGCONFIG= build
USE_GMAKE= yes
post-configure:
diff --git a/games/poker-engine/Makefile b/games/poker-engine/Makefile
index fa5e8e4d9b71..e5850340a64b 100644
--- a/games/poker-engine/Makefile
+++ b/games/poker-engine/Makefile
@@ -22,8 +22,8 @@ RUN_DEPENDS= ${LOCALBASE}/bin/rsync:${PORTSDIR}/net/rsync \
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
+USES= pkgconfig
USE_PYTHON= 2.5-2.7
-USE_PKGCONFIG= yes
USE_GETTEXT= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/games/poker-eval/Makefile b/games/poker-eval/Makefile
index c43e8e4a5471..ad2280659f93 100644
--- a/games/poker-eval/Makefile
+++ b/games/poker-eval/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection Makefile for: poker-eval
-# Date created: Dec 14, 2006
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= poker-eval
PORTVERSION= 0.138
@@ -19,9 +14,9 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
GNU_CONFIGURE= yes
+USES= pkgconfig
USE_GMAKE= yes
USE_LDCONFIG= yes
-USE_PKGCONFIG= yes
MAKE_JOBS_SAFE= yes
post-patch:
diff --git a/games/py-fife/Makefile b/games/py-fife/Makefile
index 5a97aa4e1d48..348fd951c699 100644
--- a/games/py-fife/Makefile
+++ b/games/py-fife/Makefile
@@ -39,7 +39,7 @@ USE_PYTHON= 2.7
USE_XORG= xcursor
USE_GL= gl
-USE_PKGCONFIG= build
+USES= pkgconfig
post-patch:
${REINPLACE_CMD} -e 's/X11R6/local/g; s/libpng/ligpng15/g' ${WRKSRC}/build/openbsd4-config.py && \
diff --git a/games/py-poker-eval/Makefile b/games/py-poker-eval/Makefile
index f45e9d8a5fc5..9cac02240663 100644
--- a/games/py-poker-eval/Makefile
+++ b/games/py-poker-eval/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection Makefile for: py-poker-eval
-# Date created: Dec 14, 2006
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= poker-eval
PORTVERSION= 0.138
@@ -21,8 +16,8 @@ LIB_DEPENDS= poker-eval.1:${PORTSDIR}/games/poker-eval
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
+USES= pkgconfig
USE_PYTHON= 2.5-2.7
-USE_PKGCONFIG= yes
USE_AUTOTOOLS= aclocal autoconf automake libtool
ACLOCAL_ARGS= -I config
CONFIGURE_ARGS= PYTHON=""
diff --git a/games/stonesoup/Makefile b/games/stonesoup/Makefile
index 33261c839ebe..2f9d6b259b1e 100644
--- a/games/stonesoup/Makefile
+++ b/games/stonesoup/Makefile
@@ -15,10 +15,9 @@ LICENSE_FILE= ${WRKDIR}/stone_soup-${PORTVERSION}/licence.txt
USE_SQLITE= yes
USE_XZ= yes
-USES= bison
+USES= bison pkgconfig
USE_GMAKE= yes
USE_LUA= 5.1
-USE_PKGCONFIG= build
USE_PERL5_BUILD= yes
MAKE_JOBS_SAFE= yes
diff --git a/games/super_methane_brothers/Makefile b/games/super_methane_brothers/Makefile
index 8879309ab7ea..12455697b48d 100644
--- a/games/super_methane_brothers/Makefile
+++ b/games/super_methane_brothers/Makefile
@@ -16,9 +16,9 @@ LICENSE= GPLv2
LIB_DEPENDS= clan23Core:${PORTSDIR}/devel/clanlib \
execinfo:${PORTSDIR}/devel/libexecinfo
+USES= pkgconfig
USE_GCC= 4.6+
USE_GL= glu
-USE_PKGCONFIG= build
USE_GMAKE= yes
MAKE_ENV= METHANE_FLAGS="${CPPFLAGS}" METHANE_LIBS="${LDFLAGS}"
MAKE_JOBS_UNSAFE= yes
diff --git a/games/thegrind/Makefile b/games/thegrind/Makefile
index 8c6e70ed45a8..830b40ddd9e1 100644
--- a/games/thegrind/Makefile
+++ b/games/thegrind/Makefile
@@ -1,9 +1,5 @@
-# New Ports collection makefile for: The Grind
-# Date created: 2012-05-18
-# Whom: nemysis@gmx.ch
-#
+# Created by: nemysis@gmx.ch
# $FreeBSD$
-#
PORTNAME= thegrind
PORTVERSION= 0.1.2
@@ -22,8 +18,8 @@ LIB_DEPENDS= radius:${PORTSDIR}/graphics/radius-engine \
physfs.1:${PORTSDIR}/devel/physfs
RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip
+USES= pkgconfig
GNU_CONFIGURE= yes
-USE_PKGCONFIG= build
ALL_TARGET= ${PORTNAME}
USE_SDL= sdl sound
USE_GL= glu
diff --git a/games/ultimatestunts/Makefile b/games/ultimatestunts/Makefile
index dab026f77608..7ca923780428 100644
--- a/games/ultimatestunts/Makefile
+++ b/games/ultimatestunts/Makefile
@@ -17,11 +17,11 @@ LIB_DEPENDS= vorbisfile.6:${PORTSDIR}/audio/libvorbis
OPTIONS_DEFINE= DOCS
+USES= pkgconfig
USE_OPENAL= al alut
USE_GL= gl glu
USE_SDL= sdl image
USE_GETTEXT= yes
-USE_PKGCONFIG= build
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-openal
MAKE_JOBS_UNSAFE= yes