aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2006-09-19 01:31:39 +0800
committeroliver <oliver@FreeBSD.org>2006-09-19 01:31:39 +0800
commit353c3abf1c6fd8e7ba00d963d340143921433a4a (patch)
treed5b4b02a6578132b76606d9e18a3e9b301672b25 /games
parent5672363d53cce8bd4eddc7978de8510ed12a927e (diff)
downloadfreebsd-ports-gnome-353c3abf1c6fd8e7ba00d963d340143921433a4a.tar.gz
freebsd-ports-gnome-353c3abf1c6fd8e7ba00d963d340143921433a4a.tar.zst
freebsd-ports-gnome-353c3abf1c6fd8e7ba00d963d340143921433a4a.zip
update ogre3d to 1.2.3
Diffstat (limited to 'games')
-rw-r--r--games/ember/Makefile11
-rw-r--r--games/fwp/Makefile2
2 files changed, 8 insertions, 5 deletions
diff --git a/games/ember/Makefile b/games/ember/Makefile
index 9dc2a1b43704..7a686b7c27ff 100644
--- a/games/ember/Makefile
+++ b/games/ember/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= oliver@FreeBSD.org
COMMENT= Ember is a WorldForge 3d client using the OGRE 3d library
LIB_DEPENDS= sigc-2.0:${PORTSDIR}/devel/libsigc++20 \
- OgreMain.11:${PORTSDIR}/graphics/ogre3d \
+ OgreMain.12:${PORTSDIR}/graphics/ogre3d \
eris-1.3:${PORTSDIR}/devel/eris \
varconf-1.0.6:${PORTSDIR}/devel/varconf \
mercator-0.2.4:${PORTSDIR}/devel/mercator \
@@ -31,13 +31,14 @@ USE_GCC= 3.4
USE_X_PREFIX= YES
USE_GNOME= gnomehack
USE_BZIP2= YES
+USE_DOS2UNIX= YES
CPPFLAGS= -DBR_NO_MACROS
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 600000
-IGNORE= Does not compile because of inlining error
-.endif
+#.if ${OSVERSION} < 600000
+#IGNORE= Does not compile because of inlining error
+#.endif
post-patch:
@${REINPLACE_CMD} -e '\
@@ -68,6 +69,8 @@ post-patch:
${WRKSRC}/src/services/sound/SoundService.h
@${REINPLACE_CMD} -e 's|@LDFLAGS@|& -lopenal -lalut|' \
${WRKSRC}/src/components/ogre/Makefile.in
+ @${REINPLACE_CMD} '/^[ ]*\*[ ]/d' ${WRKSRC}/src/components/ogre/ogreopcode/opcode/*.cpp ${WRKSRC}/src/components/ogre/ogreopcode/opcode/*.h
+ @${REINPLACE_CMD} -e 's|^[ ]*//.*||g' ${WRKSRC}/src/components/ogre/ogreopcode/opcode/*.cpp ${WRKSRC}/src/components/ogre/ogreopcode/opcode/*.h
.if ${OSVERSION} < 500000
@${REINPLACE_CMD} -e 's|lrintf|(long int)rintf|g' \
${WRKSRC}/src/components/ogre/environment/meshtree/TStem.cpp \
diff --git a/games/fwp/Makefile b/games/fwp/Makefile
index 874b795eee31..f5aa0e0d1d83 100644
--- a/games/fwp/Makefile
+++ b/games/fwp/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= amdmi3@mail.ru
COMMENT= Multiplayer first person shooter
BUILD_DEPENDS= ${X11BASE}/lib/libode.a:${PORTSDIR}/devel/ode
-LIB_DEPENDS= OgreMain.11:${PORTSDIR}/graphics/ogre3d
+LIB_DEPENDS= OgreMain.12:${PORTSDIR}/graphics/ogre3d
GNU_CONFIGURE= yes
USE_GMAKE= yes