aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2012-10-10 07:16:12 +0800
committerjgh <jgh@FreeBSD.org>2012-10-10 07:16:12 +0800
commit355a33adf8747b2dd71fe357a9b493ac6191131b (patch)
tree5b91db81a9a0abc550cca2cbef47e2edf54b3516 /games
parentb73353016a489268b668fed7229b579a0994ee67 (diff)
downloadfreebsd-ports-gnome-355a33adf8747b2dd71fe357a9b493ac6191131b.tar.gz
freebsd-ports-gnome-355a33adf8747b2dd71fe357a9b493ac6191131b.tar.zst
freebsd-ports-gnome-355a33adf8747b2dd71fe357a9b493ac6191131b.zip
- add new port: games/barbie_seahorse_adventures
You are a seahorse and you want to go to the moon! WWW: http://www.imitationpickles.org/barbie/ PR: 167854 Submitted by: nemysis@gmx.ch
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/barbie_seahorse_adventures/Makefile58
-rw-r--r--games/barbie_seahorse_adventures/distinfo4
-rw-r--r--games/barbie_seahorse_adventures/files/barbie_seahorse_adventures.in6
-rw-r--r--games/barbie_seahorse_adventures/pkg-descr3
5 files changed, 72 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 3bdb8e40347c..c1d81a7e7af8 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -64,6 +64,7 @@
SUBDIR += balazar
SUBDIR += balazarbrothers
SUBDIR += banihstypos
+ SUBDIR += barbie_seahorse_adventures
SUBDIR += barrage
SUBDIR += bass
SUBDIR += bastet
diff --git a/games/barbie_seahorse_adventures/Makefile b/games/barbie_seahorse_adventures/Makefile
new file mode 100644
index 000000000000..4d51abff367e
--- /dev/null
+++ b/games/barbie_seahorse_adventures/Makefile
@@ -0,0 +1,58 @@
+# Created by: nemysis@gmx.ch
+#
+# $FreeBSD$
+#
+
+PORTNAME= barbie_seahorse_adventures
+PORTVERSION= 1.0
+CATEGORIES= games python
+MASTER_SITES= http://www.imitationpickles.org/barbie/files/ \
+ SF/nemysisfreebsdp/:icons
+DISTFILES= barbie-${DISTVERSION}${EXTRACT_SUFX} \
+ ${PORTNAME}.png:icons
+DIST_SUBDIR= python
+EXTRACT_ONLY= barbie-${DISTVERSION}${EXTRACT_SUFX}
+
+MAINTAINER= nemysis@gmx.ch
+COMMENT= You are a seahorse and you want to go to the moon!
+
+LICENSE= GPLv2
+
+RUN_DEPENDS= ${PYGAME}
+
+WRKSRC= ${WRKDIR}/barbie-${DISTVERSION}
+
+USE_PYTHON= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/${PORTNAME} \
+ share/pixmaps/${PORTNAME}.png
+
+PORTDATA= *
+PORTDOCS= CHANGES.txt LEVELS.txt NOTES.txt README.txt TODO.txt
+
+SUB_FILES= ${PORTNAME}
+
+DESKTOP_ENTRIES="Barbie Seahorse Adventures" "${COMMENT}" "${PORTNAME}" \
+ "${PORTNAME}" "Game;ArcadeGame;" ${FALSE}
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,/usr/bin/python,${PYTHON_CMD},' \
+ ${WRKSRC}/leveledit.py ${WRKSRC}/tileedit.py
+ @(cd ${WRKSRC} && ${RM} *.py.bak)
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/*.py ${DATADIR}
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} "data lib" ${DATADIR})
+ ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/${PORTNAME}.png ${PREFIX}/share/pixmaps
+
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/barbie_seahorse_adventures/distinfo b/games/barbie_seahorse_adventures/distinfo
new file mode 100644
index 000000000000..020e5d773f38
--- /dev/null
+++ b/games/barbie_seahorse_adventures/distinfo
@@ -0,0 +1,4 @@
+SHA256 (python/barbie-1.0.tar.gz) = 8a5312545e51b94a28194679b2a8b8a7558ac105b706fe07ccabab6d47537861
+SIZE (python/barbie-1.0.tar.gz) = 2172446
+SHA256 (python/barbie_seahorse_adventures.png) = 98b6052da805e533b38ed4b47116b208d8c253ec5cf2bd630a87d311a35488c1
+SIZE (python/barbie_seahorse_adventures.png) = 519
diff --git a/games/barbie_seahorse_adventures/files/barbie_seahorse_adventures.in b/games/barbie_seahorse_adventures/files/barbie_seahorse_adventures.in
new file mode 100644
index 000000000000..e2cb706bb442
--- /dev/null
+++ b/games/barbie_seahorse_adventures/files/barbie_seahorse_adventures.in
@@ -0,0 +1,6 @@
+#!/bin/sh
+#
+# $FreeBSD$
+
+cd "%%DATADIR%%"
+exec ./run_game.py "${@}"
diff --git a/games/barbie_seahorse_adventures/pkg-descr b/games/barbie_seahorse_adventures/pkg-descr
new file mode 100644
index 000000000000..36ecdd54daca
--- /dev/null
+++ b/games/barbie_seahorse_adventures/pkg-descr
@@ -0,0 +1,3 @@
+You are a seahorse and you want to go to the moon!
+
+WWW: http://www.imitationpickles.org/barbie/