aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2017-04-20 12:13:39 +0800
committermiwi <miwi@FreeBSD.org>2017-04-20 12:13:39 +0800
commit3bc8a7fe048d5e60ae95a7b818d4c1d11b372a0c (patch)
tree94d0b78b1c31bf676608e4b95f42350656a14699 /games
parent6f5766ff24b00e6354b47da4870dfc7bf9f81594 (diff)
downloadfreebsd-ports-gnome-3bc8a7fe048d5e60ae95a7b818d4c1d11b372a0c.tar.gz
freebsd-ports-gnome-3bc8a7fe048d5e60ae95a7b818d4c1d11b372a0c.tar.zst
freebsd-ports-gnome-3bc8a7fe048d5e60ae95a7b818d4c1d11b372a0c.zip
- Fix Shebangs
- Added LICENSE - Added NO_ARCH
Diffstat (limited to 'games')
-rw-r--r--games/ptkei/Makefile4
-rw-r--r--games/py-sgflib/Makefile12
2 files changed, 14 insertions, 2 deletions
diff --git a/games/ptkei/Makefile b/games/ptkei/Makefile
index d171bf7e7a25..59b2e65333eb 100644
--- a/games/ptkei/Makefile
+++ b/games/ptkei/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ptkei
PORTVERSION= 2.00.0
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= SF/ptkei2
@@ -12,7 +13,8 @@ COMMENT= Python/Tk graphical client for Wolfpack Empire servers
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter \
${PYTHON_SITELIBDIR}/Pmw/__init__.py:x11-toolkits/py-Pmw
-USES= python
+USES= python shebangfix
+SHEBANG_FILES= empire.py scripts/*.py
do-build:
@${FIND} ${WRKSRC} -name "*.pyc" -delete
diff --git a/games/py-sgflib/Makefile b/games/py-sgflib/Makefile
index 91498b9dfb4e..76d61e19ff9e 100644
--- a/games/py-sgflib/Makefile
+++ b/games/py-sgflib/Makefile
@@ -3,6 +3,7 @@
PORTNAME= sgflib
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= games python
MASTER_SITES= http://gotools.sourceforge.net/sgflib/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,10 +13,19 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Smart Game Format parser library for Python
-USES= python
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/lgpl.txt
+
+USES= python shebangfix
NO_BUILD= yes
+NO_ARCH= yes
WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}
+do-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local/bin/python|${python_CMD}|' \
+ ${WRKSRC}/*.py
+ @${FIND} ${WRKSRC} -name "*.bak" -delete
+
do-install:
@${MKDIR} ${STAGEDIR}${PYTHON_SITELIBDIR}
(cd ${WRKSRC} && ${INSTALL_SCRIPT} sgflib.py typelib.py \