aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorceri <ceri@FreeBSD.org>2003-12-04 19:48:32 +0800
committerceri <ceri@FreeBSD.org>2003-12-04 19:48:32 +0800
commit3bede37cd1d7d65ac827666c5ea0c4fc5e130d0b (patch)
tree7311753872aa1d72aaeb48c01d367b0a5b0f4f5b /games
parentfa4e1f6c8ec59229bc85ddf368d3f024522d48cf (diff)
downloadfreebsd-ports-gnome-3bede37cd1d7d65ac827666c5ea0c4fc5e130d0b.tar.gz
freebsd-ports-gnome-3bede37cd1d7d65ac827666c5ea0c4fc5e130d0b.tar.zst
freebsd-ports-gnome-3bede37cd1d7d65ac827666c5ea0c4fc5e130d0b.zip
You are robot. Your job is to find kitten.
Reviewed by: adamw
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/robotfindskitten/Makefile25
-rw-r--r--games/robotfindskitten/distinfo1
-rw-r--r--games/robotfindskitten/files/patch-src-Makefile.in11
-rw-r--r--games/robotfindskitten/pkg-descr6
-rw-r--r--games/robotfindskitten/pkg-plist1
6 files changed, 45 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 03238be528a9..290bee3ec91a 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -329,6 +329,7 @@
SUBDIR += race
SUBDIR += rfksay
SUBDIR += robocode
+ SUBDIR += robotfindskitten
SUBDIR += rockdodger
SUBDIR += rocksndiamonds
SUBDIR += rt2-demo
diff --git a/games/robotfindskitten/Makefile b/games/robotfindskitten/Makefile
new file mode 100644
index 000000000000..b15249693e0c
--- /dev/null
+++ b/games/robotfindskitten/Makefile
@@ -0,0 +1,25 @@
+# Ports collection makefile for: robotfindskitten
+# Date created: Wed Dec 3, 2003
+# Whom: Ceri Davies (ceri@FreeBSD.org)
+#
+# $FreeBSD$
+#
+
+PORTNAME= robotfindskitten
+PORTVERSION= 1600003.248b
+CATEGORIES= games
+MASTER_SITES= http://robotfindskitten.org/download/POSIX/
+DISTNAME= ${PORTNAME}-v${PORTVERSION}
+
+MAINTAINER= ceri@FreeBSD.org
+COMMENT= Yet another zen simulation
+
+GNU_CONFIGURE= YES
+USE_GNOME= glib12
+
+INFO= ${PORTNAME}
+
+post-extract:
+ ${RM} ${WRKSRC}/doc/robotfindskitten.info
+
+.include <bsd.port.mk>
diff --git a/games/robotfindskitten/distinfo b/games/robotfindskitten/distinfo
new file mode 100644
index 000000000000..52feb2be7238
--- /dev/null
+++ b/games/robotfindskitten/distinfo
@@ -0,0 +1 @@
+MD5 (robotfindskitten-v1600003.248b.tar.gz) = f2dcce4282d536fae4696d03a46bc12c
diff --git a/games/robotfindskitten/files/patch-src-Makefile.in b/games/robotfindskitten/files/patch-src-Makefile.in
new file mode 100644
index 000000000000..56d20900efc9
--- /dev/null
+++ b/games/robotfindskitten/files/patch-src-Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Wed Dec 3 18:43:57 2003
++++ src/Makefile.in Wed Dec 3 18:44:12 2003
+@@ -76,7 +76,7 @@
+ VERSION = @VERSION@
+
+ CFLAGS = $(GLIB_CFLAGS)
+-execgamesdir = $(prefix)/games
++execgamesdir = $(prefix)/bin
+ execgames_PROGRAMS = robotfindskitten
+
+ robotfindskitten_SOURCES = cunit.h cunit.c draw.h messages.h robotfindskitten.c
diff --git a/games/robotfindskitten/pkg-descr b/games/robotfindskitten/pkg-descr
new file mode 100644
index 000000000000..ca8865df8575
--- /dev/null
+++ b/games/robotfindskitten/pkg-descr
@@ -0,0 +1,6 @@
+You are robot. Your job is to find kitten.
+This task is complicated by the existence of things which are not kitten.
+Robot must touch items to determine if they are kitten or not.
+The game ends when robotfindskitten.
+
+WWW: http://robotfindskitten.org/
diff --git a/games/robotfindskitten/pkg-plist b/games/robotfindskitten/pkg-plist
new file mode 100644
index 000000000000..e8e2946d9679
--- /dev/null
+++ b/games/robotfindskitten/pkg-plist
@@ -0,0 +1 @@
+bin/robotfindskitten