aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormph <mph@FreeBSD.org>2002-04-03 03:55:23 +0800
committermph <mph@FreeBSD.org>2002-04-03 03:55:23 +0800
commit41d8ee5d0d3cc7b4ff9e1b858011fb123695bdd5 (patch)
tree7854a4c08378a5e6097c5aff91f23b1d4bc758c2 /games
parent6f22b43df04703af190dbba48470fa5466de59e2 (diff)
downloadfreebsd-ports-gnome-41d8ee5d0d3cc7b4ff9e1b858011fb123695bdd5.tar.gz
freebsd-ports-gnome-41d8ee5d0d3cc7b4ff9e1b858011fb123695bdd5.tar.zst
freebsd-ports-gnome-41d8ee5d0d3cc7b4ff9e1b858011fb123695bdd5.zip
Instead of relying on /dev/fd/3 being available, make a named pipe to
provide input to crafty. This should allow package building to succeed and has no negative consequences that I know of. It is not clear at the moment why /dev/fd/3 is not present in the chroot'ed package building environment, but I wanted to get a fix in before the DP1 ports freeze. I arrived at this solution after helpful discussions with <esoha@attbi.com>.
Diffstat (limited to 'games')
-rw-r--r--games/crafty-open-rock/Makefile6
-rw-r--r--games/crafty-open-rock/files/book-building2
2 files changed, 6 insertions, 2 deletions
diff --git a/games/crafty-open-rock/Makefile b/games/crafty-open-rock/Makefile
index 3690a154ac2d..a44eaa5c54b5 100644
--- a/games/crafty-open-rock/Makefile
+++ b/games/crafty-open-rock/Makefile
@@ -22,11 +22,15 @@ DIST_SUBDIR= crafty
NO_WRKSUBDIR= yes
EXTRACT_ONLY=
+MKFIFO= /usr/bin/mkfifo
+GAMEFIFO= ${WRKDIR}/gamefifo
+
do-build:
@${ECHO_MSG} '================================================================'
@${ECHO_MSG} 'Ignore warnings about illegal moves. These warnings are normal.'
@${ECHO_MSG} '================================================================'
- (cd ${DISTDIR}/${DIST_SUBDIR} && ${CAT} ${DISTFILES} | ${GUNZIP_CMD}) | (cd ${WRKDIR}; crafty 3<&0 < ${FILESDIR}/book-building)
+ ${MKFIFO} ${GAMEFIFO}
+ (cd ${DISTDIR}/${DIST_SUBDIR} && ${CAT} ${DISTFILES} | ${GUNZIP_CMD} > ${GAMEFIFO}) & (cd ${WRKDIR}; crafty < ${FILESDIR}/book-building)
do-install:
${MKDIR} ${PREFIX}/lib/crafty
diff --git a/games/crafty-open-rock/files/book-building b/games/crafty-open-rock/files/book-building
index 95b8a95c8397..bb0133295255 100644
--- a/games/crafty-open-rock/files/book-building
+++ b/games/crafty-open-rock/files/book-building
@@ -1,2 +1,2 @@
-book create /dev/fd/3 60 3
+book create gamefifo 60 3
quit