aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2009-04-03 08:58:09 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2009-04-03 08:58:09 +0800
commit46cf19b23d438bcb2f150b35647c1c110626cded (patch)
tree65d75a5fa6d5cdc9de64f57ac1094ae9ed68f29d /games
parent60ca822ace8761969961a7778cc72802a3d6b6ea (diff)
downloadfreebsd-ports-gnome-46cf19b23d438bcb2f150b35647c1c110626cded.tar.gz
freebsd-ports-gnome-46cf19b23d438bcb2f150b35647c1c110626cded.tar.zst
freebsd-ports-gnome-46cf19b23d438bcb2f150b35647c1c110626cded.zip
- Use SF macro for my remaining ports that don't use it
- Mark MAKE_JOBS_SAFE - Other minor cleanups
Diffstat (limited to 'games')
-rw-r--r--games/interlogic/Makefile8
-rw-r--r--games/kimboot/Makefile3
-rw-r--r--games/pachi/Makefile6
-rw-r--r--games/penguin-command/Makefile5
-rw-r--r--games/stroq/Makefile7
-rw-r--r--games/stroq/pkg-plist3
6 files changed, 14 insertions, 18 deletions
diff --git a/games/interlogic/Makefile b/games/interlogic/Makefile
index 5ab51e89e442..18092753c362 100644
--- a/games/interlogic/Makefile
+++ b/games/interlogic/Makefile
@@ -9,8 +9,7 @@ PORTNAME= interlogic
PORTVERSION= 0.30
PORTREVISION= 3
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= interlogic
+MASTER_SITES= SF
DISTNAME= interLOGIC-src-${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
@@ -19,10 +18,9 @@ COMMENT= Move colored balls through the maze connecting it with each other
USE_SDL= image sdl
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="`${SDL_CONFIG} --cflags`" \
- LDFLAGS="`${SDL_CONFIG} --libs`"
+MAKE_JOBS_SAFE= yes
-WRKSRC= ${WRKDIR}/interlogic
+WRKSRC= ${WRKDIR}/interlogic
PLIST_FILES= bin/interlogic
diff --git a/games/kimboot/Makefile b/games/kimboot/Makefile
index 153796c92ef7..92737fca05cc 100644
--- a/games/kimboot/Makefile
+++ b/games/kimboot/Makefile
@@ -9,8 +9,7 @@ PORTNAME= kimboot
PORTVERSION= 0.74
PORTREVISION= 1
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= amdmi3@FreeBSD.org
diff --git a/games/pachi/Makefile b/games/pachi/Makefile
index f633eac8d5e6..7b9eafa7dde3 100644
--- a/games/pachi/Makefile
+++ b/games/pachi/Makefile
@@ -9,8 +9,7 @@ PORTNAME= pachi
PORTVERSION= 1.0
PORTREVISION= 3
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= dragontech
+MASTER_SITES= SF/dragontech
DISTNAME= pachi_source
EXTRACT_SUFX= .tgz
@@ -20,11 +19,12 @@ COMMENT= A platforms game similar to Manic Miner
USE_SDL= mixer sdl
USE_GMAKE= yes
GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CPPFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ENV= LDFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}" CXX="${CXX}"
+CONFIGURE_ENV= LDFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}"
WRKSRC= ${WRKDIR}/Pachi
diff --git a/games/penguin-command/Makefile b/games/penguin-command/Makefile
index 6130aaaf9432..2e3643cdd784 100644
--- a/games/penguin-command/Makefile
+++ b/games/penguin-command/Makefile
@@ -9,8 +9,7 @@ PORTNAME= penguin-command
PORTVERSION= 1.6.11
PORTREVISION= 2
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= A clone of the classic game Missile Command
@@ -20,7 +19,7 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
USE_SDL= mixer image sdl
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --program-prefix=""
+MAKE_JOBS_SAFE= yes
MAN6= penguin-command.6 penguin-command.ja.6
diff --git a/games/stroq/Makefile b/games/stroq/Makefile
index ef1193528079..66307bbda23f 100644
--- a/games/stroq/Makefile
+++ b/games/stroq/Makefile
@@ -8,8 +8,7 @@ PORTNAME= stroq
PORTVERSION= 0.2
PORTREVISION= 2
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= stroq
+MASTER_SITES= SF
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Flip tiles to make rows of the same color
@@ -19,10 +18,14 @@ BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
USE_BZIP2= yes
USE_QT_VER= 3
MAKE_ENV= QTDIR="${QT_PREFIX}"
+MAKE_JOBS_SAFE= yes
QMAKE= qmake
QMAKESPEC= ${LOCALBASE}/share/qt/mkspecs/freebsd-g++
+PLIST_FILES= bin/stroq
+PORTDOCS= *
+
post-patch:
${REINPLACE_CMD} -e 's|PlaySquare::||' ${WRKSRC}/playsquare.h
${REINPLACE_CMD} -e 's|Puzzle::||' ${WRKSRC}/puzzle.h
diff --git a/games/stroq/pkg-plist b/games/stroq/pkg-plist
deleted file mode 100644
index 55eb6c3f5b24..000000000000
--- a/games/stroq/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-bin/stroq
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%@dirrm %%DOCSDIR%%