aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>2000-09-12 21:04:00 +0800
committerasami <asami@FreeBSD.org>2000-09-12 21:04:00 +0800
commit47da741123ef8e21ee636c92c56aeea79f52ccbd (patch)
treee040907401668bad88013b550a9c94e03adcd7e6 /games
parent799d0bf099681efbc3cb438ad809c1b2f0175d36 (diff)
downloadfreebsd-ports-gnome-47da741123ef8e21ee636c92c56aeea79f52ccbd.tar.gz
freebsd-ports-gnome-47da741123ef8e21ee636c92c56aeea79f52ccbd.tar.zst
freebsd-ports-gnome-47da741123ef8e21ee636c92c56aeea79f52ccbd.zip
Add BUILD_DEPENDS=bdftopcf:XFree86-4-clients and
RUN_DEPENDS=mkfontdir:XFree86-4-clients when XFREE86_VERSION=4. Submitted by: bento
Diffstat (limited to 'games')
-rw-r--r--games/crossfire-client/Makefile7
-rw-r--r--games/crossfire-server/Makefile7
-rw-r--r--games/crossfire/Makefile7
-rw-r--r--games/qix/Makefile10
-rw-r--r--games/xjewel/Makefile10
5 files changed, 39 insertions, 2 deletions
diff --git a/games/crossfire-client/Makefile b/games/crossfire-client/Makefile
index ff3671f03635..d9b75e72ff1f 100644
--- a/games/crossfire-client/Makefile
+++ b/games/crossfire-client/Makefile
@@ -29,6 +29,13 @@ USE_XPM= yes
PREFIX= ${LOCALBASE}
MAN6= crossfire.6 crossedit.6
+.include <bsd.port.pre.mk>
+
+.if ${XFREE86_VERSION} == 4
+BUILD_DEPENDS+= bdftopcf:${PORTSDIR}/x11/XFree86-4-clients
+RUN_DEPENDS= mkfontdir:${PORTSDIR}/x11/XFree86-4-clients
+.endif
+
# Do you want to be able to rebuild documentation after installing the game
# to produce Postscript documentation with colored icons ?! You have to go
# into the workdir and to build everything manually.
diff --git a/games/crossfire-server/Makefile b/games/crossfire-server/Makefile
index ff3671f03635..d9b75e72ff1f 100644
--- a/games/crossfire-server/Makefile
+++ b/games/crossfire-server/Makefile
@@ -29,6 +29,13 @@ USE_XPM= yes
PREFIX= ${LOCALBASE}
MAN6= crossfire.6 crossedit.6
+.include <bsd.port.pre.mk>
+
+.if ${XFREE86_VERSION} == 4
+BUILD_DEPENDS+= bdftopcf:${PORTSDIR}/x11/XFree86-4-clients
+RUN_DEPENDS= mkfontdir:${PORTSDIR}/x11/XFree86-4-clients
+.endif
+
# Do you want to be able to rebuild documentation after installing the game
# to produce Postscript documentation with colored icons ?! You have to go
# into the workdir and to build everything manually.
diff --git a/games/crossfire/Makefile b/games/crossfire/Makefile
index ff3671f03635..d9b75e72ff1f 100644
--- a/games/crossfire/Makefile
+++ b/games/crossfire/Makefile
@@ -29,6 +29,13 @@ USE_XPM= yes
PREFIX= ${LOCALBASE}
MAN6= crossfire.6 crossedit.6
+.include <bsd.port.pre.mk>
+
+.if ${XFREE86_VERSION} == 4
+BUILD_DEPENDS+= bdftopcf:${PORTSDIR}/x11/XFree86-4-clients
+RUN_DEPENDS= mkfontdir:${PORTSDIR}/x11/XFree86-4-clients
+.endif
+
# Do you want to be able to rebuild documentation after installing the game
# to produce Postscript documentation with colored icons ?! You have to go
# into the workdir and to build everything manually.
diff --git a/games/qix/Makefile b/games/qix/Makefile
index 70f87c566684..3edbf2aa2202 100644
--- a/games/qix/Makefile
+++ b/games/qix/Makefile
@@ -14,6 +14,14 @@ MASTER_SITE_SUBDIR= jmz
MAINTAINER= jmz@FreeBSD.org
USE_X_PREFIX= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${XFREE86_VERSION} == 4
+BUILD_DEPENDS= bdftopcf:${PORTSDIR}/x11/XFree86-4-clients
+RUN_DEPENDS= mkfontdir:${PORTSDIR}/x11/XFree86-4-clients
+.endif
+
MAN1= qix.1
FONTSDIR= lib/X11/fonts/local
@@ -24,4 +32,4 @@ do-configure:
@${SED} -e s:/usr/local:${PREFIX}: -e s:/usr/X11R6:${PREFIX}: \
< ${WRKSRC}/Makefile~ > ${WRKSRC}/Makefile
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/xjewel/Makefile b/games/xjewel/Makefile
index 6f8960f3b675..1d9d74e52886 100644
--- a/games/xjewel/Makefile
+++ b/games/xjewel/Makefile
@@ -16,6 +16,14 @@ EXTRACT_SUFX= .tar.z
MAINTAINER= jmz@FreeBSD.org
USE_IMAKE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${XFREE86_VERSION} == 4
+BUILD_DEPENDS= bdftopcf:${PORTSDIR}/x11/XFree86-4-clients
+RUN_DEPENDS= mkfontdir:${PORTSDIR}/x11/XFree86-4-clients
+.endif
+
MAN6= xjewel.6
FONTSDIR= lib/X11/fonts/local
@@ -29,4 +37,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/bitmaps/seven_seg.pcf.gz ${PREFIX}/${FONTSDIR}
@(cd ${PREFIX}/${FONTSDIR} ; mkfontdir)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>