aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2017-05-02 03:25:00 +0800
committerlinimon <linimon@FreeBSD.org>2017-05-02 03:25:00 +0800
commit4aabba205eb753dfe6b95b47bfc4032c9297b8f6 (patch)
treec294df00509e0e3634bb037ebee32db884c7b1c2 /games
parenta6bef84e481b1eb09039107aaf3b73f07b7743b5 (diff)
downloadfreebsd-ports-gnome-4aabba205eb753dfe6b95b47bfc4032c9297b8f6.tar.gz
freebsd-ports-gnome-4aabba205eb753dfe6b95b47bfc4032c9297b8f6.tar.zst
freebsd-ports-gnome-4aabba205eb753dfe6b95b47bfc4032c9297b8f6.zip
Provide error messages for some ports failing on aarch64, and, in a
few cases, other tier-2 archs. While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'games')
-rw-r--r--games/cheech/Makefile2
-rw-r--r--games/freedoko/Makefile2
-rw-r--r--games/shaaft/Makefile3
-rw-r--r--games/trigger-rally/Makefile3
4 files changed, 9 insertions, 1 deletions
diff --git a/games/cheech/Makefile b/games/cheech/Makefile
index 0435fbe71bd2..6ee6beb0e35c 100644
--- a/games/cheech/Makefile
+++ b/games/cheech/Makefile
@@ -15,6 +15,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libgnet-2.0.so:net/gnet2
+BROKEN_aarch64= fails to compile: error: expected ';' at end of declaration list
+
OPTIONS_DEFINE= DOCS
USES= gmake pkgconfig tar:tgz
diff --git a/games/freedoko/Makefile b/games/freedoko/Makefile
index e95afcd46f1c..2f8523459fbd 100644
--- a/games/freedoko/Makefile
+++ b/games/freedoko/Makefile
@@ -16,6 +16,8 @@ LICENSE_FILE= ${WRKSRC}/../doc/GPL
LIB_DEPENDS= libgnet-2.0.so:net/gnet2
+BROKEN_aarch64= fails to compile: error: expected ';' at end of declaration list
+
WRKSRC= ${WRKDIR}/${DISTNAME:C/\.src$//}/src
USES= gmake pkgconfig zip:infozip
diff --git a/games/shaaft/Makefile b/games/shaaft/Makefile
index fa2a353df89c..56f3fce02ab5 100644
--- a/games/shaaft/Makefile
+++ b/games/shaaft/Makefile
@@ -15,7 +15,8 @@ LIB_DEPENDS= libpng.so:graphics/png
CONFLICTS= criticalmass-*
-BROKEN_sparc64= does not compile
+BROKEN_aarch64= fails to compile: error: conflicting declaration typedef int GLintptrARB
+BROKEN_sparc64= does not compile
USES= tar:bzip2
USE_SDL= mixer image sdl
diff --git a/games/trigger-rally/Makefile b/games/trigger-rally/Makefile
index 1b4210c801d0..61431082498a 100644
--- a/games/trigger-rally/Makefile
+++ b/games/trigger-rally/Makefile
@@ -14,6 +14,9 @@ LICENSE= GPLv2
LIB_DEPENDS= libphysfs.so:devel/physfs
LIB_DEPENDS+= libalut.so:audio/freealut
+BROKEN_aarch64= fails to compile: error: the clang compiler does not support -march=native
+BROKEN_armv6= fails to compile: error: the clang compiler does not support -march=native
+
WRKSRC_SUBDIR= src
USES= gmake openal:al,alut
USE_SDL= sdl2 image2