aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2014-06-19 13:34:08 +0800
committerjhale <jhale@FreeBSD.org>2014-06-19 13:34:08 +0800
commit4cebc78f4cdca5b9d9331cde96f8b167a0c02f23 (patch)
tree3dc4adee2adc8b68f41321bd27a1a955c7b5f218 /games
parentf296727e023baa62de3a5c9462832d5168eb36f7 (diff)
downloadfreebsd-ports-gnome-4cebc78f4cdca5b9d9331cde96f8b167a0c02f23.tar.gz
freebsd-ports-gnome-4cebc78f4cdca5b9d9331cde96f8b167a0c02f23.tar.zst
freebsd-ports-gnome-4cebc78f4cdca5b9d9331cde96f8b167a0c02f23.zip
- Support staging (it was easier to define a new do-install target
than further patching the source Makefile) - Add LICENSE (GPLv2) - Rename patch to reflect the file it applies to - Whitespace cleanup Approved by: portmgr (blanket approval)
Diffstat (limited to 'games')
-rw-r--r--games/xtris/Makefile13
-rw-r--r--games/xtris/files/patch-Makefile (renamed from games/xtris/files/patch-aa)10
-rw-r--r--games/xtris/pkg-plist5
3 files changed, 18 insertions, 10 deletions
diff --git a/games/xtris/Makefile b/games/xtris/Makefile
index 00417f1e3419..bb60a84fc266 100644
--- a/games/xtris/Makefile
+++ b/games/xtris/Makefile
@@ -8,20 +8,25 @@ CATEGORIES= games ipv6
MASTER_SITES= http://www.iagora.com/~espel/xtris/ \
ftp://quatramaran.ens.fr/pub/orabidoo/
-PATCH_SITES= ftp://ftp.42.org/pub/orphan/
+PATCH_SITES= ftp://ftp.42.org/pub/orphan/
PATCHFILES= xtris-1.15-v6-19991218.diff.gz
PATCH_DIST_STRIP= -p1
MAINTAINER= sec@42.org
COMMENT= Multi-player version of a popular game for the X Window system
+LICENSE= GPLv2
+
RESTRICTED= Possible trademark infringement
WRKSRC= ${WRKDIR}/xtris
USE_XORG= x11 xext
-MAN6= xtris.6 xtserv.6 xtbot.6
-
MAKE_ENV= IPV6_CFLAGS="-DINET6"
-NO_STAGE= yes
+do-install:
+.for i in xtbot xtris xtserv
+ ${INSTALL_PROGRAM} ${WRKSRC}/${i} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${i}.6 ${STAGEDIR}${MAN6PREFIX}/man/man6
+.endfor
+
.include <bsd.port.mk>
diff --git a/games/xtris/files/patch-aa b/games/xtris/files/patch-Makefile
index 8c31415ccecc..a75a08c1541f 100644
--- a/games/xtris/files/patch-aa
+++ b/games/xtris/files/patch-Makefile
@@ -1,11 +1,11 @@
---- Makefile.orig Mon Jan 17 13:33:15 2000
-+++ Makefile Mon Jan 17 13:36:11 2000
+--- ./Makefile.orig 2014-06-19 00:53:36.000000000 -0400
++++ ./Makefile 2014-06-19 01:00:11.000000000 -0400
@@ -8,27 +8,27 @@
###################
# change this to your favorite ANSI C compiler
-CC = gcc
-+CC? = gcc
++CC ?= cc
# change this to the directory where you want the xtris binaries installed
-BINDIR = /usr/local/bin
@@ -25,8 +25,8 @@
# specify X11 cflags and libdir if your system needs it
-XCFLAGS = #-I/usr/X11/include
-XLIBDIR = #-L/usr/X11/lib
-+XCFLAGS = -I${PREFIX}/include
-+XLIBDIR = -L${PREFIX}/lib
++XCFLAGS = -I${LOCALBASE}/include
++XLIBDIR = -L${LOCALBASE}/lib
# IPv6 Settings
-IPV6_CFLAGS = #-DINET6 #-I/usr/inet6/include
diff --git a/games/xtris/pkg-plist b/games/xtris/pkg-plist
index fb4db3b6e277..55a249f26b30 100644
--- a/games/xtris/pkg-plist
+++ b/games/xtris/pkg-plist
@@ -1,3 +1,6 @@
+bin/xtbot
bin/xtris
bin/xtserv
-bin/xtbot
+man/man6/xtbot.6.gz
+man/man6/xtris.6.gz
+man/man6/xtserv.6.gz