aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorshaun <shaun@FreeBSD.org>2006-11-22 04:19:16 +0800
committershaun <shaun@FreeBSD.org>2006-11-22 04:19:16 +0800
commit5378115305421c3bdceb3e30f3d6da402ecd19bc (patch)
treecf3f1e045077c344c4648d209802be65a966d4c3 /games
parent60cff843900ba5de54d0e2ab1128388afcb9b6c5 (diff)
downloadfreebsd-ports-gnome-5378115305421c3bdceb3e30f3d6da402ecd19bc.tar.gz
freebsd-ports-gnome-5378115305421c3bdceb3e30f3d6da402ecd19bc.tar.zst
freebsd-ports-gnome-5378115305421c3bdceb3e30f3d6da402ecd19bc.zip
Fix build on FreeBSD 4.x.
PR: ports/103429 Submitted by: Dmitry Marakasov <amdmi3@mail.ru> (maintainer)
Diffstat (limited to 'games')
-rw-r--r--games/fwp/Makefile10
1 files changed, 2 insertions, 8 deletions
diff --git a/games/fwp/Makefile b/games/fwp/Makefile
index 1f5e039e25f3..2089006b7efe 100644
--- a/games/fwp/Makefile
+++ b/games/fwp/Makefile
@@ -25,19 +25,13 @@ USE_GL= yes
USE_SDL= sdl net mixer
USE_GCC= 3.4+
-CONFIGURE_ARGS= --program-suffix=
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
SDL_CONFIG="${SDL_CONFIG}"
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= does not compile on 4.x
-.endif
-
post-patch:
@${REINPLACE_CMD} -e '/LDFLAGS=/ s|$$LIBS|$$LDFLAGS|' \
${WRKSRC}/configure
@@ -46,4 +40,4 @@ post-patch:
post-install:
@${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>