aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2010-02-03 08:45:11 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2010-02-03 08:45:11 +0800
commit570d74a3f97bcd08feff4ff51dc33b1d111c0851 (patch)
treee88133e0404dac3cec1559883e808f6290ae9e22 /games
parent34d884cc8aae6aeb332544f5728206436b323906 (diff)
downloadfreebsd-ports-gnome-570d74a3f97bcd08feff4ff51dc33b1d111c0851.tar.gz
freebsd-ports-gnome-570d74a3f97bcd08feff4ff51dc33b1d111c0851.tar.zst
freebsd-ports-gnome-570d74a3f97bcd08feff4ff51dc33b1d111c0851.zip
- Fix on 64bit platforms
Diffstat (limited to 'games')
-rw-r--r--games/reminiscence/Makefile10
-rw-r--r--games/reminiscence/files/patch-sys.h23
2 files changed, 25 insertions, 8 deletions
diff --git a/games/reminiscence/Makefile b/games/reminiscence/Makefile
index 010d3321d9b5..c1165062494f 100644
--- a/games/reminiscence/Makefile
+++ b/games/reminiscence/Makefile
@@ -7,7 +7,7 @@
PORTNAME= REminiscence
PORTVERSION= 0.1.9
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
MASTER_SITES= http://cyxdown.free.fr/reminiscence/ \
http://mirror.amdmi3.ru/distfiles/
@@ -45,10 +45,4 @@ post-install:
.endif
@${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} != i386
-IGNORE= Doesn't work on !i386 (ERROR: Bad CRC for bank data 38!)
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/reminiscence/files/patch-sys.h b/games/reminiscence/files/patch-sys.h
new file mode 100644
index 000000000000..d013c65590bf
--- /dev/null
+++ b/games/reminiscence/files/patch-sys.h
@@ -0,0 +1,23 @@
+--- sys.h.orig 2007-03-17 00:45:52.000000000 +0300
++++ sys.h 2010-02-02 20:23:49.000000000 +0300
+@@ -19,12 +19,14 @@
+ #ifndef __SYS_H__
+ #define __SYS_H__
+
+-typedef unsigned char uint8;
+-typedef signed char int8;
+-typedef unsigned short uint16;
+-typedef signed short int16;
+-typedef unsigned long uint32;
+-typedef signed long int32;
++#include <stdint.h>
++
++typedef uint8_t uint8;
++typedef int8_t int8;
++typedef uint16_t uint16;
++typedef int16_t int16;
++typedef uint32_t uint32;
++typedef int32_t int32;
+
+ inline uint16 READ_BE_UINT16(const void *ptr) {
+ const uint8 *b = (const uint8 *)ptr;