aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorbar <bar@FreeBSD.org>2017-04-17 19:02:20 +0800
committerbar <bar@FreeBSD.org>2017-04-17 19:02:20 +0800
commit5dda853e081311dcdf90a6a4efe73c881fd5af93 (patch)
treed00de82a5e2bd4b06a9c363497a546d10171dada /games
parent7782e0c7658a1df47927fcd67df7a13a2050e5e8 (diff)
downloadfreebsd-ports-gnome-5dda853e081311dcdf90a6a4efe73c881fd5af93.tar.gz
freebsd-ports-gnome-5dda853e081311dcdf90a6a4efe73c881fd5af93.tar.zst
freebsd-ports-gnome-5dda853e081311dcdf90a6a4efe73c881fd5af93.zip
Build using LLVM because after r438668 it builds fine using llvm40.
This also allows to restore LAUNCHER option, because contrarily to default gcc version, llvm still produces working binary for vlaunch.
Diffstat (limited to 'games')
-rw-r--r--games/vavoom/Makefile25
-rw-r--r--games/vavoom/files/pkg-message.in1
-rw-r--r--games/vavoom/pkg-plist2
3 files changed, 11 insertions, 17 deletions
diff --git a/games/vavoom/Makefile b/games/vavoom/Makefile
index 79e1ca325781..8c3f82b9018a 100644
--- a/games/vavoom/Makefile
+++ b/games/vavoom/Makefile
@@ -3,7 +3,7 @@
PORTNAME= vavoom
PORTVERSION= 1.33
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/Vavoom-source/${PORTVERSION}
@@ -15,16 +15,12 @@ LICENSE= GPLv2
LIB_DEPENDS= libpng.so:graphics/png
USES= cmake dos2unix jpeg tar:bzip2
-# Force GCC because llvm (starting from 4.0) generates
-# non working binary for vcc
-USE_GCC= yes
+
DOS2UNIX_REGEX= ((.*\.(c|cpp|h|s|asm|inc|vc|ls|acs|cfg|txt|vs|mak|mgw"))$$|\/(makefile\..*|makefile|Makefile)$$)
-# Removed LAUNCHER because it segfaults
-#OPTIONS_DEFINE= FLAC LAUNCHER MAD MIKMOD OPENAL OPTIMIZED_CFLAGS VORBIS SDL DOCS
-OPTIONS_DEFINE= FLAC MAD MIKMOD OPENAL OPTIMIZED_CFLAGS VORBIS SDL DOCS
-OPTIONS_DEFAULT= OPENGL SDL
-#LAUNCHER_DESC= Build GUI launcher
+OPTIONS_DEFINE= FLAC LAUNCHER MAD MIKMOD OPENAL OPTIMIZED_CFLAGS VORBIS SDL DOCS
+OPTIONS_DEFAULT= LAUNCHER OPENGL SDL
+LAUNCHER_DESC= Build GUI launcher
OPENAL_DESC= Enable OpenAL support
SDL_DESC= Use SDL for OpenGL support
@@ -41,13 +37,10 @@ FLAC_LIB_DEPENDS= libFLAC.so:audio/flac
FLAC_CMAKE_ON= -DWITH_FLAC:BOOL=ON
FLAC_CMAKE_OFF= -DWITH_FLAC:BOOL=OFF
-# Removed LAUNCHER because it segfaults - check also pkg-plist
-#LAUNCHER_USE= WX=2.8+
-#LAUNCHER_CMAKE_ON= -DENABLE_LAUNCHER:BOOL=ON \
-# -DwxWidgets_CONFIG_EXECUTABLE="${WX_CONFIG}"
-#LAUNCHER_CMAKE_OFF= -DENABLE_LAUNCHER:BOOL=OFF
-# Force disable LAUNCHER
-CMAKE_ARGS+= -DENABLE_LAUNCHER:BOOL=OFF
+LAUNCHER_USE= WX=2.8+
+LAUNCHER_CMAKE_ON= -DENABLE_LAUNCHER:BOOL=ON \
+ -DwxWidgets_CONFIG_EXECUTABLE="${WX_CONFIG}"
+LAUNCHER_CMAKE_OFF= -DENABLE_LAUNCHER:BOOL=OFF
MAD_LIB_DEPENDS= libmad.so:audio/libmad
MAD_CMAKE_ON= -DWITH_LIBMAD:BOOL=ON
diff --git a/games/vavoom/files/pkg-message.in b/games/vavoom/files/pkg-message.in
index dae4d5f59f8b..2eae4f53d349 100644
--- a/games/vavoom/files/pkg-message.in
+++ b/games/vavoom/files/pkg-message.in
@@ -16,5 +16,6 @@ need VORBIS (build options).
Refer to %%DOCSDIR%%/vavoom.txt for other options such as
game selection, network options and so on.
+If you enabled LAUNCHER (build option), run "vlaunch" for a launcher GUI.
==============================================================================
diff --git a/games/vavoom/pkg-plist b/games/vavoom/pkg-plist
index 7f4b7c82ef1e..e5dc8faeec68 100644
--- a/games/vavoom/pkg-plist
+++ b/games/vavoom/pkg-plist
@@ -2,7 +2,7 @@ bin/vavoom
bin/vavoom.bin
bin/vavoom-dedicated
bin/vavoom-dedicated.bin
-@comment %%LAUNCHER%%bin/vlaunch
+%%LAUNCHER%%bin/vlaunch
%%PORTDOCS%%%%DOCSDIR%%/vavoom.txt
%%DATADIR%%/basev/common/basepak.pk3
%%DATADIR%%/basev/doom/basepak.pk3