aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2014-01-15 08:31:27 +0800
committernemysis <nemysis@FreeBSD.org>2014-01-15 08:31:27 +0800
commit6625f1f6a6318fb513dd397d093122155c32fc3b (patch)
treedc8475f98a20a98c4aaea207181ef129c404dbc3 /games
parent29627d38dd9398648497ff5037262559b80dc108 (diff)
downloadfreebsd-ports-gnome-6625f1f6a6318fb513dd397d093122155c32fc3b.tar.gz
freebsd-ports-gnome-6625f1f6a6318fb513dd397d093122155c32fc3b.tar.zst
freebsd-ports-gnome-6625f1f6a6318fb513dd397d093122155c32fc3b.zip
Economic development in the land of the balls has rendered communism an
obsolete ideology, but one ball is ready to stand against the cruel corporate oppressors. Is one ball enough to free the capitalist balls from their egocentric ideology and send them to labour camps, or is the process doomed to fail? There's only one way to find out... WWW: http://hectigo.net/games/oneisenough/ PR: ports/172944 Submitted by: nemysis (self)
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/oneisenough/Makefile65
-rw-r--r--games/oneisenough/distinfo4
-rw-r--r--games/oneisenough/files/oneisenough.in7
-rw-r--r--games/oneisenough/pkg-descr7
-rw-r--r--games/oneisenough/pkg-plist65
6 files changed, 149 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index afc94f4a8506..5d8335a7f83d 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -658,6 +658,7 @@
SUBDIR += odamex
SUBDIR += oldrunner
SUBDIR += omega
+ SUBDIR += oneisenough
SUBDIR += oneko
SUBDIR += oneko-sakura
SUBDIR += oolite
diff --git a/games/oneisenough/Makefile b/games/oneisenough/Makefile
new file mode 100644
index 000000000000..3c4082f6fdab
--- /dev/null
+++ b/games/oneisenough/Makefile
@@ -0,0 +1,65 @@
+# Created by: Rusmir Dusko <nemysis@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= oneisenough
+PORTVERSION= 0.4.0
+CATEGORIES= games python
+MASTER_SITES= http://hectigo.net/games/oneisenough/ \
+ SF/nemysisfreebsdp/games/:icons
+DISTFILES= ${PORTNAME}_a${DISTVERSION:S/.//g}_src${EXTRACT_SUFX} \
+ ${PORTNAME}.png:icons
+EXTRACT_ONLY= ${PORTNAME}_a${DISTVERSION:S/.//g}_src${EXTRACT_SUFX}
+
+MAINTAINER= nemysis@FreeBSD.org
+COMMENT= Economic development in the land of the balls
+
+LICENSE= GPLv2
+
+RUN_DEPENDS= ${PYGAME}
+
+WRKSRC= ${WRKDIR}/"one is enough"
+
+USE_ZIP= yes
+USES= dos2unix
+DOS2UNIX_FILES= README.txt bin/*.py
+DOS2UNIX_REGEX= .*.[^pt][^nt][^gf]
+USE_PYTHON= 2
+
+PORTDOCS= README.txt
+
+OPTIONS_DEFINE= DOCS
+
+SUB_FILES= ${PORTNAME}
+
+DESKTOP_ENTRIES="One Is Enough" "" ${PORTNAME} \
+ "${PORTNAME}" "Game;ArcadeGame;" ""
+
+post-extract:
+ @${FIND} ${WRKSRC} \
+ -name "Thumbs.db" -delete -or -name "pack.bat" -delete
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/bin/env python|${PYTHON_CMD}|' \
+ ${WRKSRC}/run_game.py
+
+do-build:
+ @${PYTHON_CMD} -m compileall ${WRKSRC}
+ @${PYTHON_CMD} -O -m compileall ${WRKSRC}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+.for d in *.py *.pyc *.pyo
+ @(cd ${WRKSRC} ; ${INSTALL_SCRIPT} ${d} ${STAGEDIR}${DATADIR})
+.endfor
+
+ @(cd ${WRKSRC}/bin && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/bin)
+
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/games/oneisenough/distinfo b/games/oneisenough/distinfo
new file mode 100644
index 000000000000..1c6b58cdc747
--- /dev/null
+++ b/games/oneisenough/distinfo
@@ -0,0 +1,4 @@
+SHA256 (oneisenough_a040_src.zip) = 93da49735d6b7c7978c65f28c99b955c8e95ac0a6716d91be5790650277def88
+SIZE (oneisenough_a040_src.zip) = 356589
+SHA256 (oneisenough.png) = b0c8fa5467e5743e605e72da804161b2e3cc593f0eaa4b2f1b379d834779c12c
+SIZE (oneisenough.png) = 4756
diff --git a/games/oneisenough/files/oneisenough.in b/games/oneisenough/files/oneisenough.in
new file mode 100644
index 000000000000..d82102b69d8a
--- /dev/null
+++ b/games/oneisenough/files/oneisenough.in
@@ -0,0 +1,7 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+cd "%%DATADIR%%"
+exec ./run_game.py "${@}"
diff --git a/games/oneisenough/pkg-descr b/games/oneisenough/pkg-descr
new file mode 100644
index 000000000000..20d018305558
--- /dev/null
+++ b/games/oneisenough/pkg-descr
@@ -0,0 +1,7 @@
+Economic development in the land of the balls has rendered communism an
+obsolete ideology, but one ball is ready to stand against the cruel
+corporate oppressors. Is one ball enough to free the capitalist balls
+from their egocentric ideology and send them to labour camps,
+or is the process doomed to fail? There's only one way to find out...
+
+WWW: http://hectigo.net/games/oneisenough/
diff --git a/games/oneisenough/pkg-plist b/games/oneisenough/pkg-plist
new file mode 100644
index 000000000000..868fbeb233f6
--- /dev/null
+++ b/games/oneisenough/pkg-plist
@@ -0,0 +1,65 @@
+bin/oneisenough
+%%DATADIR%%/bin/background.py
+%%DATADIR%%/bin/background.pyc
+%%DATADIR%%/bin/background.pyo
+%%DATADIR%%/bin/bank.py
+%%DATADIR%%/bin/bank.pyc
+%%DATADIR%%/bin/bank.pyo
+%%DATADIR%%/bin/camp.py
+%%DATADIR%%/bin/camp.pyc
+%%DATADIR%%/bin/camp.pyo
+%%DATADIR%%/bin/data/Vera.ttf
+%%DATADIR%%/bin/enemy.py
+%%DATADIR%%/bin/enemy.pyc
+%%DATADIR%%/bin/enemy.pyo
+%%DATADIR%%/bin/follower.py
+%%DATADIR%%/bin/follower.pyc
+%%DATADIR%%/bin/follower.pyo
+%%DATADIR%%/bin/game.py
+%%DATADIR%%/bin/game.pyc
+%%DATADIR%%/bin/game.pyo
+%%DATADIR%%/bin/locals.py
+%%DATADIR%%/bin/locals.pyc
+%%DATADIR%%/bin/locals.pyo
+%%DATADIR%%/bin/main.py
+%%DATADIR%%/bin/main.pyc
+%%DATADIR%%/bin/main.pyo
+%%DATADIR%%/bin/mainmenu.py
+%%DATADIR%%/bin/mainmenu.pyc
+%%DATADIR%%/bin/mainmenu.pyo
+%%DATADIR%%/bin/object.py
+%%DATADIR%%/bin/object.pyc
+%%DATADIR%%/bin/object.pyo
+%%DATADIR%%/bin/pictures/ball1.png
+%%DATADIR%%/bin/pictures/ball2.png
+%%DATADIR%%/bin/pictures/balldollar.png
+%%DATADIR%%/bin/pictures/ballinvincible.png
+%%DATADIR%%/bin/pictures/bank.png
+%%DATADIR%%/bin/pictures/bg.png
+%%DATADIR%%/bin/pictures/camp.png
+%%DATADIR%%/bin/pictures/gameover.png
+%%DATADIR%%/bin/pictures/star.png
+%%DATADIR%%/bin/pictures/staricon.png
+%%DATADIR%%/bin/player.py
+%%DATADIR%%/bin/player.pyc
+%%DATADIR%%/bin/player.pyo
+%%DATADIR%%/bin/setup.py
+%%DATADIR%%/bin/setup.pyc
+%%DATADIR%%/bin/setup.pyo
+%%DATADIR%%/bin/sound.py
+%%DATADIR%%/bin/sound.pyc
+%%DATADIR%%/bin/sound.pyo
+%%DATADIR%%/bin/sounds/whau.wav
+%%DATADIR%%/bin/sounds/woosh.wav
+%%DATADIR%%/bin/util.py
+%%DATADIR%%/bin/util.pyc
+%%DATADIR%%/bin/util.pyo
+%%DATADIR%%/run_game.py
+%%DATADIR%%/run_game.pyc
+%%DATADIR%%/run_game.pyo
+share/pixmaps/oneisenough.png
+@dirrm %%DATADIR%%/bin/sounds
+@dirrm %%DATADIR%%/bin/pictures
+@dirrm %%DATADIR%%/bin/data
+@dirrm %%DATADIR%%/bin
+@dirrm %%DATADIR%%